i?86-*-darwin* target?

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

i?86-*-darwin* target?

Lior Balkohen
is not supported with current versions of GNU binutils so I must use
vendor's as and ld? Please correct me if I'm wrong.
Reply | Threaded
Open this post in threaded view
|

Re: i?86-*-darwin* target?

Ian Lance Taylor
Lior Balkohen <[hidden email]> writes:

> is not supported with current versions of GNU binutils so I must use
> vendor's as and ld? Please correct me if I'm wrong.

You are correct.

The GNU assembler and linker do not support the Mach-O format which is
used on Darwin (at least, I assume that x86 Darwin will also use
Mach-O).

Ian
Reply | Threaded
Open this post in threaded view
|

Re: i?86-*-darwin* target?

Eric Christopher-2

On Dec 23, 2005, at 12:07 PM, Ian Lance Taylor wrote:

> Lior Balkohen <[hidden email]> writes:
>
>> is not supported with current versions of GNU binutils so I must use
>> vendor's as and ld? Please correct me if I'm wrong.
>
> You are correct.
>
> The GNU assembler and linker do not support the Mach-O format which is
> used on Darwin (at least, I assume that x86 Darwin will also use
> Mach-O).

*sigh* It does.

-eric