error requiring swank-kawa.scm

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

error requiring swank-kawa.scm

ljarndt273
Hello,

i'm trying to run a swank server from kawa and was using swank-kawa.scm
as currently on gitlab *) for this. I'm getting below error when i
require swank-kawa.scm.

I am using kawa 2.0.

I'd actually rather use kawa with emacs+slime and get the same error
when i do this from within emacs.

Would much appreciate any help!

Thanks & Regards

ludwig

#|kawa:1|# (require "swank-kawa.scm")
Exception in thread "main" java.lang.InternalError:
java.io.UTFDataFormatException: encoded string too long: 897958 bytes
     at gnu.bytecode.ClassType.writeToArray(ClassType.java:1255)
     at gnu.expr.ModuleExp.evalToClass(ModuleExp.java:98)
     at gnu.expr.ModuleExp.evalToClass(ModuleExp.java:157)
     at gnu.expr.ModuleExp.evalModule1(ModuleExp.java:259)
     at gnu.expr.ModuleExp.evalModule(ModuleExp.java:214)
     at kawa.Shell.run(Shell.java:291)
     at kawa.Shell.run(Shell.java:203)
     at kawa.Shell.run(Shell.java:184)
     at kawa.repl.main(repl.java:892)

*) i've literally copy/pasted swank-kawa.scm from
https://gitlab.common-lisp.net/slime/slime/blob/master/contrib/swank-kawa.scm

Reply | Threaded
Open this post in threaded view
|

Re: error requiring swank-kawa.scm

Helmut Eller-2
On Fri, Jul 17 2015, ljarndt273 wrote:

> #|kawa:1|# (require "swank-kawa.scm")

There are some installation instructions at the beginning of the file
swank-kawa.scm.  The recommended way is to create a swank-kawa.jar and
the start the JVM as described there.

To load the source the --r7rs command line flag is needed (along with
the others to start the debugger agent).  And I don't know who to use
Kawa's require; I always use import instead.

Helmut

Reply | Threaded
Open this post in threaded view
|

Re: error requiring swank-kawa.scm

ljarndt273
Thanks a lot, the --r7rs helped.

i managed to build the swank-kawa.jar as described.

(i found that the library (kawa base) is only included/available in the
svn repository, i couldn't import it using the src/bin distributions
given in

http://www.gnu.org/software/kawa/Getting-Kawa.html

anyway - the svn + --r7rs did work, i had to add the --r7rs flag to
slime-lisp-implentations in swank-kawa.scm).

+ i can even kick it off from emacs now.

I ran into 2 new issues inside emacs -

1) on slime startup it breaks, offering one restart:

(from emacs *inferior-lisp* buffer):
(begin (import swank-kawa ...))
...
canGetInstanceInfo: #t
breakpoint event: BreakpointEvent@swank$Mnkawa:1577 in thread swank-listener

debugger buffer:

java.lang.Error: swank:init-presentations not implemented
   [type java.lang.Error]

Restarts:
  0: [quit] terminate current thread

after invoking restart 0 i'm in the repl and it works.

2) i'm thrown into the debugger on any first sexp element (first letter
even, after opening bracket). i type in the repl. debugger says:

java.lang.Error: swank:autodoc not implemented
   [type java.lang.Error]

Restarts:
  0: [quit] terminate current thread

is there a way to get autodoc to work?


Thanks for your help

ludwig








On 07/17/2015 10:35 AM, Helmut Eller wrote:

> On Fri, Jul 17 2015, ljarndt273 wrote:
>
>> #|kawa:1|# (require "swank-kawa.scm")
> There are some installation instructions at the beginning of the file
> swank-kawa.scm.  The recommended way is to create a swank-kawa.jar and
> the start the JVM as described there.
>
> To load the source the --r7rs command line flag is needed (along with
> the others to start the debugger agent).  And I don't know who to use
> Kawa's require; I always use import instead.
>
> Helmut
>

Reply | Threaded
Open this post in threaded view
|

Fwd: Re: error requiring swank-kawa.scm

ljarndt273
Apologies, looks like the autodoc issue is known & solvable

http://comments.gmane.org/gmane.lisp.scheme.kawa/3316

i'll try that. sorry again

thanks

ludwig


-------- Forwarded Message --------
Subject: Re: error requiring swank-kawa.scm
Date: Fri, 17 Jul 2015 23:50:57 +0200
From: lja <[hidden email]>
To: [hidden email]

Thanks a lot, the --r7rs helped.

i managed to build the swank-kawa.jar as described.

(i found that the library (kawa base) is only included/available in the
svn repository, i couldn't import it using the src/bin distributions
given in

http://www.gnu.org/software/kawa/Getting-Kawa.html

anyway - the svn + --r7rs did work, i had to add the --r7rs flag to
slime-lisp-implentations in swank-kawa.scm).

+ i can even kick it off from emacs now.

I ran into 2 new issues inside emacs -

1) on slime startup it breaks, offering one restart:

(from emacs *inferior-lisp* buffer):
(begin (import swank-kawa ...))
...
canGetInstanceInfo: #t
breakpoint event: BreakpointEvent@swank$Mnkawa:1577 in thread swank-listener

debugger buffer:

java.lang.Error: swank:init-presentations not implemented
   [type java.lang.Error]

Restarts:
  0: [quit] terminate current thread

after invoking restart 0 i'm in the repl and it works.

2) i'm thrown into the debugger on any first sexp element (first letter
even, after opening bracket). i type in the repl. debugger says:

java.lang.Error: swank:autodoc not implemented
   [type java.lang.Error]

Restarts:
  0: [quit] terminate current thread

is there a way to get autodoc to work?


Thanks for your help

ludwig








On 07/17/2015 10:35 AM, Helmut Eller wrote:

> On Fri, Jul 17 2015, ljarndt273 wrote:
>
>> #|kawa:1|# (require "swank-kawa.scm")
> There are some installation instructions at the beginning of the file
> swank-kawa.scm.  The recommended way is to create a swank-kawa.jar and
> the start the JVM as described there.
>
> To load the source the --r7rs command line flag is needed (along with
> the others to start the debugger agent).  And I don't know who to use
> Kawa's require; I always use import instead.
>
> Helmut
>