[crosstool-ng/crosstool-ng] af2f3a: libc: glibc 2.28 needs make 4.0

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[crosstool-ng/crosstool-ng] af2f3a: libc: glibc 2.28 needs make 4.0

Alexey Neyman-2
  Branch: refs/heads/master
  Home:   https://github.com/crosstool-ng/crosstool-ng
  Commit: af2f3ac9c5454cb89d081405468ee5df58994ab4
      https://github.com/crosstool-ng/crosstool-ng/commit/af2f3ac9c5454cb89d081405468ee5df58994ab4
  Author: Chris Packham <[hidden email]>
  Date:   2019-09-04 (Wed, 04 Sep 2019)

  Changed paths:
    M config/libc/glibc.in

  Log Message:
  -----------
  libc: glibc 2.28 needs make 4.0

Fixes: #1210

Per the release notes for the GNU C library 2.28[1] make 4.0 or newer is
required. Previously the logic was applied to glibc 2.29 or newer.

[1] - https://www.sourceware.org/ml/libc-alpha/2018-08/msg00003.html

Signed-off-by: Chris Packham <[hidden email]>


  Commit: 715591306ff97f2838d15b5ac641db9098d7bf6f
      https://github.com/crosstool-ng/crosstool-ng/commit/715591306ff97f2838d15b5ac641db9098d7bf6f
  Author: Alexey Neyman <[hidden email]>
  Date:   2019-10-01 (Tue, 01 Oct 2019)

  Changed paths:
    M config/libc/glibc.in

  Log Message:
  -----------
  Merge pull request #1231 from cpackham/glibc-2.28-make-4.0

libc: glibc 2.28 needs make 4.0


Compare: https://github.com/crosstool-ng/crosstool-ng/compare/b01fbcb8b05b...715591306ff9