[crosstool-ng/crosstool-ng] 7b929a: Disallow linux versions before 4.8 for ARC

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[crosstool-ng/crosstool-ng] 7b929a: Disallow linux versions before 4.8 for ARC

Alexey Neyman
  Branch: refs/heads/master
  Home:   https://github.com/crosstool-ng/crosstool-ng
  Commit: 7b929a528ef8b78ecdf295d4c0536b4707e358e6
      https://github.com/crosstool-ng/crosstool-ng/commit/7b929a528ef8b78ecdf295d4c0536b4707e358e6
  Author: Alexey Brodkin <[hidden email]>
  Date:   2018-10-01 (Mon, 01 Oct 2018)

  Changed paths:
    M config/arch/arc.in
    M packages/linux/package.desc

  Log Message:
  -----------
  Disallow linux versions before 4.8 for ARC

Inspired by a similar fix for AArch64 in 481cbaac9b23.

The point is in Linux v4.8 we introduced new ABIv4 which is now used in
both Linux kernel and up-to-date GNU tools for ARC (based on GCC 6.x+).
See [1] for more details.

[1] https://github.com/foss-for-synopsys-dwc-arc-processors/linux/wiki/ARC-Linux-Syscall-ABI-Compatibility

Signed-off-by: Alexey Brodkin <[hidden email]>


  Commit: 7c4c6892b9a5ea8e989ecb8a120db4d9f3aa46f6
      https://github.com/crosstool-ng/crosstool-ng/commit/7c4c6892b9a5ea8e989ecb8a120db4d9f3aa46f6
  Author: Alexey Neyman <[hidden email]>
  Date:   2018-10-29 (Mon, 29 Oct 2018)

  Changed paths:
    M config/arch/arc.in
    M packages/linux/package.desc

  Log Message:
  -----------
  Merge pull request #1044 from abrodkin/topic-arc-linux-4.8

Disallow linux versions before 4.8 for ARC


Compare: https://github.com/crosstool-ng/crosstool-ng/compare/3b1e2f6d8686...7c4c6892b9a5
      **NOTE:** This service has been marked for deprecation: https://developer.github.com/changes/2018-04-25-github-services-deprecation/

      Functionality will be removed from GitHub.com on January 31st, 2019.