crosstool-ng 1.16.0: libtool problem

classic Classic list List threaded Threaded
13 messages Options
Reply | Threaded
Open this post in threaded view
|

crosstool-ng 1.16.0: libtool problem

zvivered
Hello,

I'm using crosstool-ng 1.16.0 to create a toolchain for
"i686-nptl-linux-gnu" under centos 5.3

I got the following error:

[ALL  ]    ./libtool: line 466: CDPATH: command not found
[ALL  ]    ./libtool: line 466: CDPATH: command not found
[ALL  ]    ./libtool: line 1144: func_opt_split: command not found
[ALL  ]    libtool: Version mismatch error.  This is libtool 2.2.6
Debian-2.2.6a-1ubuntu1, but the
[ALL  ]    libtool: definition of this LT_INIT comes from an older release.
[ALL  ]    libtool: You should recreate aclocal.m4 with macros from
libtool 2.2.6 Debian-2.2.6a-1ubuntu1
[ALL  ]    libtool: and run autoconf again.
[ERROR]    make[1]: *** [loop.lo] Error 1
[ALL  ]    make[1]: *** Waiting for unfinished jobs....
[ALL  ]    ./libtool: line 466: CDPATH: command not found
[ALL  ]    ./libtool: line 1144: func_opt_split: command not found
[ALL  ]    libtool: Version mismatch error.  This is libtool 2.2.6
Debian-2.2.6a-1ubuntu1, but the
[ALL  ]    libtool: definition of this LT_INIT comes from an older release.
[ALL  ]    libtool: You should recreate aclocal.m4 with macros from
libtool 2.2.6 Debian-2.2.6a-1ubuntu1
[ALL  ]    libtool: and run autoconf again.
[ERROR]    make[1]: *** [block.lo] Error 1
[ALL  ]    ./libtool: line 1144: func_opt_split: command not found
[ALL  ]    libtool: Version mismatch error.  This is libtool 2.2.6
Debian-2.2.6a-1ubuntu1, but the
[ALL  ]    libtool: definition of this LT_INIT comes from an older release.
[ALL  ]    libtool: You should recreate aclocal.m4 with macros from
libtool 2.2.6 Debian-2.2.6a-1ubuntu1
[ALL  ]    libtool: and run autoconf again.
[ERROR]    make[1]: *** [names.lo] Error 1
[ALL  ]    make[1]: Leaving directory
`/home/zvivered/GNU/ct-ng-1.16.0/working/i686-nptl-linux-gnu/build/build-cloog-ppl-host-i686-build_pc-linux-gnu'
[ERROR]
[ERROR]  >>
[ERROR]  >>  Build failed in step 'Installing CLooG/PPL for host'
[ERROR]  >>        called in step '(top-level)'
[ERROR]  >>
[ERROR]  >>  Error happened in: CT_DoExecLog[scripts/functions@158]
[ERROR]  >>        called from:
do_cloog_backend[scripts/build/companion_libs/cloog.sh@111]
[ERROR]  >>        called from:
do_cloog_for_host[scripts/build/companion_libs/cloog.sh@72]
[ERROR]  >>        called from: main[scripts/crosstool-NG.sh@598]
[ERROR]  >>
[ERROR]  >>  For more info on this error, look at the file: 'build.log'
[ERROR]  >>  There is a list of known issues, some with workarounds, in:
[ERROR]  >>
'/home/zvivered/GNU/ct-ng-1.16.0/share/doc/crosstool-ng/ct-ng.1.16.0/B
- Known issues.txt'
[ERROR]
[ERROR]  (elapsed: 6:05.48)

Attached config.ng (copy of .config).

Can you help find the problem ?

Thanks,
Zvika

--
For unsubscribe information see http://sourceware.org/lists.html#faq

config.ng (14K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: crosstool-ng 1.16.0: libtool problem

Bryan Hundven
On Fri, Oct 5, 2012 at 10:14 PM, Zvi Vered <[hidden email]> wrote:

> Hello,
>
> I'm using crosstool-ng 1.16.0 to create a toolchain for
> "i686-nptl-linux-gnu" under centos 5.3
>
> I got the following error:
>
> [ALL  ]    ./libtool: line 466: CDPATH: command not found
> [ALL  ]    ./libtool: line 466: CDPATH: command not found
> [ALL  ]    ./libtool: line 1144: func_opt_split: command not found
> [ALL  ]    libtool: Version mismatch error.  This is libtool 2.2.6
> Debian-2.2.6a-1ubuntu1, but the
> [ALL  ]    libtool: definition of this LT_INIT comes from an older release.
> [ALL  ]    libtool: You should recreate aclocal.m4 with macros from
> libtool 2.2.6 Debian-2.2.6a-1ubuntu1
> [ALL  ]    libtool: and run autoconf again.
> [ERROR]    make[1]: *** [loop.lo] Error 1
> [ALL  ]    make[1]: *** Waiting for unfinished jobs....
> [ALL  ]    ./libtool: line 466: CDPATH: command not found
> [ALL  ]    ./libtool: line 1144: func_opt_split: command not found
> [ALL  ]    libtool: Version mismatch error.  This is libtool 2.2.6
> Debian-2.2.6a-1ubuntu1, but the
> [ALL  ]    libtool: definition of this LT_INIT comes from an older release.
> [ALL  ]    libtool: You should recreate aclocal.m4 with macros from
> libtool 2.2.6 Debian-2.2.6a-1ubuntu1
> [ALL  ]    libtool: and run autoconf again.
> [ERROR]    make[1]: *** [block.lo] Error 1
> [ALL  ]    ./libtool: line 1144: func_opt_split: command not found
> [ALL  ]    libtool: Version mismatch error.  This is libtool 2.2.6
> Debian-2.2.6a-1ubuntu1, but the
> [ALL  ]    libtool: definition of this LT_INIT comes from an older release.
> [ALL  ]    libtool: You should recreate aclocal.m4 with macros from
> libtool 2.2.6 Debian-2.2.6a-1ubuntu1
> [ALL  ]    libtool: and run autoconf again.
> [ERROR]    make[1]: *** [names.lo] Error 1
> [ALL  ]    make[1]: Leaving directory
> `/home/zvivered/GNU/ct-ng-1.16.0/working/i686-nptl-linux-gnu/build/build-cloog-ppl-host-i686-build_pc-linux-gnu'
> [ERROR]
> [ERROR]  >>
> [ERROR]  >>  Build failed in step 'Installing CLooG/PPL for host'
> [ERROR]  >>        called in step '(top-level)'
> [ERROR]  >>
> [ERROR]  >>  Error happened in: CT_DoExecLog[scripts/functions@158]
> [ERROR]  >>        called from:
> do_cloog_backend[scripts/build/companion_libs/cloog.sh@111]
> [ERROR]  >>        called from:
> do_cloog_for_host[scripts/build/companion_libs/cloog.sh@72]
> [ERROR]  >>        called from: main[scripts/crosstool-NG.sh@598]
> [ERROR]  >>
> [ERROR]  >>  For more info on this error, look at the file: 'build.log'
> [ERROR]  >>  There is a list of known issues, some with workarounds, in:
> [ERROR]  >>
> '/home/zvivered/GNU/ct-ng-1.16.0/share/doc/crosstool-ng/ct-ng.1.16.0/B
> - Known issues.txt'
> [ERROR]
> [ERROR]  (elapsed: 6:05.48)
>
> Attached config.ng (copy of .config).
>
> Can you help find the problem ?
>
> Thanks,
> Zvika
>
> --
> For unsubscribe information see http://sourceware.org/lists.html#faq

Zvi,

Having the full log - posted to pastebin, or similar site, or hosted
on some other web site to save space on the mailing list - would also
be very helpful in this situation.

From what I read, it looks like you have two different versions of
libtool in the same path!?! weird!

Have you tried cloog 0.15.11?

As I said in my previous message about automake, try using the
companion tools bundled with ct-ng.
( http://sourceware.org/ml/crossgcc/2012-10/msg00014.html )

># CT_COMP_TOOLS is not set

Not all systems are compatible with ct-ng, which is why we provide m4,
autoconf, automake, libtool, and make.

Also, this only seems to be a problem with cloog-ppl, have you also
tried google searching around for similar cloog build errors? This
doesn't look like it would be specific to crosstool-ng, but having the
full build log might prove that otherwise.

-Bryan

--
For unsubscribe information see http://sourceware.org/lists.html#faq

Reply | Threaded
Open this post in threaded view
|

Re: crosstool-ng 1.16.0: libtool problem

zvivered
Dear Mr. Hundven,

How can I set ct-ng to use "companion tools bundled with ct-ng" ?

The output of "libtool --version" is:
ltmain.sh (GNU libtool) 1.5.22 (1.1220.2.365 2005/12/18 22:14:06)
I used "yum install" to install it.

This is weird. According to .configure --help, the minimum libtool
version should be:
 1.5.26
But running .configure does not alert on a libtool problem.
Can this cause the problem ?

I tried pastebin but I should be a PRO user to paste all build.log

You help is highly appreciated.

Thanks,
Zvika

On Sat, Oct 6, 2012 at 10:10 AM, Bryan Hundven <[hidden email]> wrote:

> On Fri, Oct 5, 2012 at 10:14 PM, Zvi Vered <[hidden email]> wrote:
>> Hello,
>>
>> I'm using crosstool-ng 1.16.0 to create a toolchain for
>> "i686-nptl-linux-gnu" under centos 5.3
>>
>> I got the following error:
>>
>> [ALL  ]    ./libtool: line 466: CDPATH: command not found
>> [ALL  ]    ./libtool: line 466: CDPATH: command not found
>> [ALL  ]    ./libtool: line 1144: func_opt_split: command not found
>> [ALL  ]    libtool: Version mismatch error.  This is libtool 2.2.6
>> Debian-2.2.6a-1ubuntu1, but the
>> [ALL  ]    libtool: definition of this LT_INIT comes from an older release.
>> [ALL  ]    libtool: You should recreate aclocal.m4 with macros from
>> libtool 2.2.6 Debian-2.2.6a-1ubuntu1
>> [ALL  ]    libtool: and run autoconf again.
>> [ERROR]    make[1]: *** [loop.lo] Error 1
>> [ALL  ]    make[1]: *** Waiting for unfinished jobs....
>> [ALL  ]    ./libtool: line 466: CDPATH: command not found
>> [ALL  ]    ./libtool: line 1144: func_opt_split: command not found
>> [ALL  ]    libtool: Version mismatch error.  This is libtool 2.2.6
>> Debian-2.2.6a-1ubuntu1, but the
>> [ALL  ]    libtool: definition of this LT_INIT comes from an older release.
>> [ALL  ]    libtool: You should recreate aclocal.m4 with macros from
>> libtool 2.2.6 Debian-2.2.6a-1ubuntu1
>> [ALL  ]    libtool: and run autoconf again.
>> [ERROR]    make[1]: *** [block.lo] Error 1
>> [ALL  ]    ./libtool: line 1144: func_opt_split: command not found
>> [ALL  ]    libtool: Version mismatch error.  This is libtool 2.2.6
>> Debian-2.2.6a-1ubuntu1, but the
>> [ALL  ]    libtool: definition of this LT_INIT comes from an older release.
>> [ALL  ]    libtool: You should recreate aclocal.m4 with macros from
>> libtool 2.2.6 Debian-2.2.6a-1ubuntu1
>> [ALL  ]    libtool: and run autoconf again.
>> [ERROR]    make[1]: *** [names.lo] Error 1
>> [ALL  ]    make[1]: Leaving directory
>> `/home/zvivered/GNU/ct-ng-1.16.0/working/i686-nptl-linux-gnu/build/build-cloog-ppl-host-i686-build_pc-linux-gnu'
>> [ERROR]
>> [ERROR]  >>
>> [ERROR]  >>  Build failed in step 'Installing CLooG/PPL for host'
>> [ERROR]  >>        called in step '(top-level)'
>> [ERROR]  >>
>> [ERROR]  >>  Error happened in: CT_DoExecLog[scripts/functions@158]
>> [ERROR]  >>        called from:
>> do_cloog_backend[scripts/build/companion_libs/cloog.sh@111]
>> [ERROR]  >>        called from:
>> do_cloog_for_host[scripts/build/companion_libs/cloog.sh@72]
>> [ERROR]  >>        called from: main[scripts/crosstool-NG.sh@598]
>> [ERROR]  >>
>> [ERROR]  >>  For more info on this error, look at the file: 'build.log'
>> [ERROR]  >>  There is a list of known issues, some with workarounds, in:
>> [ERROR]  >>
>> '/home/zvivered/GNU/ct-ng-1.16.0/share/doc/crosstool-ng/ct-ng.1.16.0/B
>> - Known issues.txt'
>> [ERROR]
>> [ERROR]  (elapsed: 6:05.48)
>>
>> Attached config.ng (copy of .config).
>>
>> Can you help find the problem ?
>>
>> Thanks,
>> Zvika
>>
>> --
>> For unsubscribe information see http://sourceware.org/lists.html#faq
>
> Zvi,
>
> Having the full log - posted to pastebin, or similar site, or hosted
> on some other web site to save space on the mailing list - would also
> be very helpful in this situation.
>
> From what I read, it looks like you have two different versions of
> libtool in the same path!?! weird!
>
> Have you tried cloog 0.15.11?
>
> As I said in my previous message about automake, try using the
> companion tools bundled with ct-ng.
> ( http://sourceware.org/ml/crossgcc/2012-10/msg00014.html )
>
>># CT_COMP_TOOLS is not set
>
> Not all systems are compatible with ct-ng, which is why we provide m4,
> autoconf, automake, libtool, and make.
>
> Also, this only seems to be a problem with cloog-ppl, have you also
> tried google searching around for similar cloog build errors? This
> doesn't look like it would be specific to crosstool-ng, but having the
> full build log might prove that otherwise.
>
> -Bryan

--
For unsubscribe information see http://sourceware.org/lists.html#faq

Reply | Threaded
Open this post in threaded view
|

Re: crosstool-ng 1.16.0: libtool problem

Bryan Hundven
Zvi,

On Sat, Oct 6, 2012 at 12:02 PM, Zvi Vered <[hidden email]> wrote:
> Dear Mr. Hundven,

My name is Bryan. ;)

>
> How can I set ct-ng to use "companion tools bundled with ct-ng" ?

Read the documentation:

http://crosstool-ng.org/hg/crosstool-ng/raw-file/43ace4bb005e/docs/3%20-%20Configuring%20a%20toolchain.txt

> The output of "libtool --version" is:
> ltmain.sh (GNU libtool) 1.5.22 (1.1220.2.365 2005/12/18 22:14:06)
> I used "yum install" to install it.
>
> This is weird. According to .configure --help, the minimum libtool
> version should be:
>  1.5.26
> But running .configure does not alert on a libtool problem.
> Can this cause the problem ?
>
> I tried pastebin but I should be a PRO user to paste all build.log
>
> You help is highly appreciated.
>
> Thanks,
> Zvika
>
> On Sat, Oct 6, 2012 at 10:10 AM, Bryan Hundven <[hidden email]> wrote:
>> On Fri, Oct 5, 2012 at 10:14 PM, Zvi Vered <[hidden email]> wrote:
>>> Hello,
>>>
>>> I'm using crosstool-ng 1.16.0 to create a toolchain for
>>> "i686-nptl-linux-gnu" under centos 5.3
>>>
>>> I got the following error:
>>>
>>> [ALL  ]    ./libtool: line 466: CDPATH: command not found
>>> [ALL  ]    ./libtool: line 466: CDPATH: command not found
>>> [ALL  ]    ./libtool: line 1144: func_opt_split: command not found
>>> [ALL  ]    libtool: Version mismatch error.  This is libtool 2.2.6
>>> Debian-2.2.6a-1ubuntu1, but the
>>> [ALL  ]    libtool: definition of this LT_INIT comes from an older release.
>>> [ALL  ]    libtool: You should recreate aclocal.m4 with macros from
>>> libtool 2.2.6 Debian-2.2.6a-1ubuntu1
>>> [ALL  ]    libtool: and run autoconf again.
>>> [ERROR]    make[1]: *** [loop.lo] Error 1
>>> [ALL  ]    make[1]: *** Waiting for unfinished jobs....
>>> [ALL  ]    ./libtool: line 466: CDPATH: command not found
>>> [ALL  ]    ./libtool: line 1144: func_opt_split: command not found
>>> [ALL  ]    libtool: Version mismatch error.  This is libtool 2.2.6
>>> Debian-2.2.6a-1ubuntu1, but the
>>> [ALL  ]    libtool: definition of this LT_INIT comes from an older release.
>>> [ALL  ]    libtool: You should recreate aclocal.m4 with macros from
>>> libtool 2.2.6 Debian-2.2.6a-1ubuntu1
>>> [ALL  ]    libtool: and run autoconf again.
>>> [ERROR]    make[1]: *** [block.lo] Error 1
>>> [ALL  ]    ./libtool: line 1144: func_opt_split: command not found
>>> [ALL  ]    libtool: Version mismatch error.  This is libtool 2.2.6
>>> Debian-2.2.6a-1ubuntu1, but the
>>> [ALL  ]    libtool: definition of this LT_INIT comes from an older release.
>>> [ALL  ]    libtool: You should recreate aclocal.m4 with macros from
>>> libtool 2.2.6 Debian-2.2.6a-1ubuntu1
>>> [ALL  ]    libtool: and run autoconf again.
>>> [ERROR]    make[1]: *** [names.lo] Error 1
>>> [ALL  ]    make[1]: Leaving directory
>>> `/home/zvivered/GNU/ct-ng-1.16.0/working/i686-nptl-linux-gnu/build/build-cloog-ppl-host-i686-build_pc-linux-gnu'
>>> [ERROR]
>>> [ERROR]  >>
>>> [ERROR]  >>  Build failed in step 'Installing CLooG/PPL for host'
>>> [ERROR]  >>        called in step '(top-level)'
>>> [ERROR]  >>
>>> [ERROR]  >>  Error happened in: CT_DoExecLog[scripts/functions@158]
>>> [ERROR]  >>        called from:
>>> do_cloog_backend[scripts/build/companion_libs/cloog.sh@111]
>>> [ERROR]  >>        called from:
>>> do_cloog_for_host[scripts/build/companion_libs/cloog.sh@72]
>>> [ERROR]  >>        called from: main[scripts/crosstool-NG.sh@598]
>>> [ERROR]  >>
>>> [ERROR]  >>  For more info on this error, look at the file: 'build.log'
>>> [ERROR]  >>  There is a list of known issues, some with workarounds, in:
>>> [ERROR]  >>
>>> '/home/zvivered/GNU/ct-ng-1.16.0/share/doc/crosstool-ng/ct-ng.1.16.0/B
>>> - Known issues.txt'
>>> [ERROR]
>>> [ERROR]  (elapsed: 6:05.48)
>>>
>>> Attached config.ng (copy of .config).
>>>
>>> Can you help find the problem ?
>>>
>>> Thanks,
>>> Zvika
>>>
>>> --
>>> For unsubscribe information see http://sourceware.org/lists.html#faq
>>
>> Zvi,
>>
>> Having the full log - posted to pastebin, or similar site, or hosted
>> on some other web site to save space on the mailing list - would also
>> be very helpful in this situation.
>>
>> From what I read, it looks like you have two different versions of
>> libtool in the same path!?! weird!
>>
>> Have you tried cloog 0.15.11?
>>
>> As I said in my previous message about automake, try using the
>> companion tools bundled with ct-ng.
>> ( http://sourceware.org/ml/crossgcc/2012-10/msg00014.html )
>>
>>># CT_COMP_TOOLS is not set
>>
>> Not all systems are compatible with ct-ng, which is why we provide m4,
>> autoconf, automake, libtool, and make.
>>
>> Also, this only seems to be a problem with cloog-ppl, have you also
>> tried google searching around for similar cloog build errors? This
>> doesn't look like it would be specific to crosstool-ng, but having the
>> full build log might prove that otherwise.
>>
>> -Bryan

-Bryan

--
For unsubscribe information see http://sourceware.org/lists.html#faq

Reply | Threaded
Open this post in threaded view
|

Re: crosstool-ng 1.16.0: libtool problem

zvivered
Hi Bryan,

I read the documentation.
But I failed to find something that talks about "companion tools
bundled with ct-ng".

Can you point to the exact place in the link you sent ?

Thanks,
Zvika

On 10/6/12, Bryan Hundven <[hidden email]> wrote:

> Zvi,
>
> On Sat, Oct 6, 2012 at 12:02 PM, Zvi Vered <[hidden email]> wrote:
>> Dear Mr. Hundven,
>
> My name is Bryan. ;)
>
>>
>> How can I set ct-ng to use "companion tools bundled with ct-ng" ?
>
> Read the documentation:
>
> http://crosstool-ng.org/hg/crosstool-ng/raw-file/43ace4bb005e/docs/3%20-%20Configuring%20a%20toolchain.txt
>
>> The output of "libtool --version" is:
>> ltmain.sh (GNU libtool) 1.5.22 (1.1220.2.365 2005/12/18 22:14:06)
>> I used "yum install" to install it.
>>
>> This is weird. According to .configure --help, the minimum libtool
>> version should be:
>>  1.5.26
>> But running .configure does not alert on a libtool problem.
>> Can this cause the problem ?
>>
>> I tried pastebin but I should be a PRO user to paste all build.log
>>
>> You help is highly appreciated.
>>
>> Thanks,
>> Zvika
>>
>> On Sat, Oct 6, 2012 at 10:10 AM, Bryan Hundven <[hidden email]>
>> wrote:
>>> On Fri, Oct 5, 2012 at 10:14 PM, Zvi Vered <[hidden email]> wrote:
>>>> Hello,
>>>>
>>>> I'm using crosstool-ng 1.16.0 to create a toolchain for
>>>> "i686-nptl-linux-gnu" under centos 5.3
>>>>
>>>> I got the following error:
>>>>
>>>> [ALL  ]    ./libtool: line 466: CDPATH: command not found
>>>> [ALL  ]    ./libtool: line 466: CDPATH: command not found
>>>> [ALL  ]    ./libtool: line 1144: func_opt_split: command not found
>>>> [ALL  ]    libtool: Version mismatch error.  This is libtool 2.2.6
>>>> Debian-2.2.6a-1ubuntu1, but the
>>>> [ALL  ]    libtool: definition of this LT_INIT comes from an older
>>>> release.
>>>> [ALL  ]    libtool: You should recreate aclocal.m4 with macros from
>>>> libtool 2.2.6 Debian-2.2.6a-1ubuntu1
>>>> [ALL  ]    libtool: and run autoconf again.
>>>> [ERROR]    make[1]: *** [loop.lo] Error 1
>>>> [ALL  ]    make[1]: *** Waiting for unfinished jobs....
>>>> [ALL  ]    ./libtool: line 466: CDPATH: command not found
>>>> [ALL  ]    ./libtool: line 1144: func_opt_split: command not found
>>>> [ALL  ]    libtool: Version mismatch error.  This is libtool 2.2.6
>>>> Debian-2.2.6a-1ubuntu1, but the
>>>> [ALL  ]    libtool: definition of this LT_INIT comes from an older
>>>> release.
>>>> [ALL  ]    libtool: You should recreate aclocal.m4 with macros from
>>>> libtool 2.2.6 Debian-2.2.6a-1ubuntu1
>>>> [ALL  ]    libtool: and run autoconf again.
>>>> [ERROR]    make[1]: *** [block.lo] Error 1
>>>> [ALL  ]    ./libtool: line 1144: func_opt_split: command not found
>>>> [ALL  ]    libtool: Version mismatch error.  This is libtool 2.2.6
>>>> Debian-2.2.6a-1ubuntu1, but the
>>>> [ALL  ]    libtool: definition of this LT_INIT comes from an older
>>>> release.
>>>> [ALL  ]    libtool: You should recreate aclocal.m4 with macros from
>>>> libtool 2.2.6 Debian-2.2.6a-1ubuntu1
>>>> [ALL  ]    libtool: and run autoconf again.
>>>> [ERROR]    make[1]: *** [names.lo] Error 1
>>>> [ALL  ]    make[1]: Leaving directory
>>>> `/home/zvivered/GNU/ct-ng-1.16.0/working/i686-nptl-linux-gnu/build/build-cloog-ppl-host-i686-build_pc-linux-gnu'
>>>> [ERROR]
>>>> [ERROR]  >>
>>>> [ERROR]  >>  Build failed in step 'Installing CLooG/PPL for host'
>>>> [ERROR]  >>        called in step '(top-level)'
>>>> [ERROR]  >>
>>>> [ERROR]  >>  Error happened in: CT_DoExecLog[scripts/functions@158]
>>>> [ERROR]  >>        called from:
>>>> do_cloog_backend[scripts/build/companion_libs/cloog.sh@111]
>>>> [ERROR]  >>        called from:
>>>> do_cloog_for_host[scripts/build/companion_libs/cloog.sh@72]
>>>> [ERROR]  >>        called from: main[scripts/crosstool-NG.sh@598]
>>>> [ERROR]  >>
>>>> [ERROR]  >>  For more info on this error, look at the file: 'build.log'
>>>> [ERROR]  >>  There is a list of known issues, some with workarounds,
>>>> in:
>>>> [ERROR]  >>
>>>> '/home/zvivered/GNU/ct-ng-1.16.0/share/doc/crosstool-ng/ct-ng.1.16.0/B
>>>> - Known issues.txt'
>>>> [ERROR]
>>>> [ERROR]  (elapsed: 6:05.48)
>>>>
>>>> Attached config.ng (copy of .config).
>>>>
>>>> Can you help find the problem ?
>>>>
>>>> Thanks,
>>>> Zvika
>>>>
>>>> --
>>>> For unsubscribe information see http://sourceware.org/lists.html#faq
>>>
>>> Zvi,
>>>
>>> Having the full log - posted to pastebin, or similar site, or hosted
>>> on some other web site to save space on the mailing list - would also
>>> be very helpful in this situation.
>>>
>>> From what I read, it looks like you have two different versions of
>>> libtool in the same path!?! weird!
>>>
>>> Have you tried cloog 0.15.11?
>>>
>>> As I said in my previous message about automake, try using the
>>> companion tools bundled with ct-ng.
>>> ( http://sourceware.org/ml/crossgcc/2012-10/msg00014.html )
>>>
>>>># CT_COMP_TOOLS is not set
>>>
>>> Not all systems are compatible with ct-ng, which is why we provide m4,
>>> autoconf, automake, libtool, and make.
>>>
>>> Also, this only seems to be a problem with cloog-ppl, have you also
>>> tried google searching around for similar cloog build errors? This
>>> doesn't look like it would be specific to crosstool-ng, but having the
>>> full build log might prove that otherwise.
>>>
>>> -Bryan
>
> -Bryan
>

--
For unsubscribe information see http://sourceware.org/lists.html#faq

Reply | Threaded
Open this post in threaded view
|

Re: crosstool-ng 1.16.0: libtool problem

zvivered
In reply to this post by Bryan Hundven
Hi Bryan,

Did you mean:
./configure --prefix=$HOME/GNU/ct-ng-1.16.0 --without-automake
--without-libtool --without-libtoolize
?

But now I got the following error:

Already extracted 'linux-3.4.7'
[DEBUG]    Already patched 'linux-3.4.7'
[DEBUG]    Already extracted 'gmp-4.3.2'
[DEBUG]    Already patched 'gmp-4.3.2'
[DEBUG]    Already extracted 'mpfr-2.4.2'
[DEBUG]    Already patched 'mpfr-2.4.2'
[DEBUG]    Running autoreconf
[DEBUG]    ==> Executing: 'autoreconf'
[ERROR]    acinclude.m4:26: error: Autoconf version 2.60 or higher is required
[ALL  ]    acinclude.m4:26: the top level
[ALL  ]    autom4te: /usr/bin/m4 failed with exit status: 63
[ALL  ]    aclocal: autom4te failed with exit status: 63
[ALL  ]    autoreconf: aclocal failed with exit status: 63
[ERROR]

I ran "yum install autoconf" and it installs autoconf 2.59

What autoconf should I install and how ?

Thanks,
Zvika

On Sat, Oct 6, 2012 at 9:05 PM, Bryan Hundven <[hidden email]> wrote:

> Zvi,
>
> On Sat, Oct 6, 2012 at 12:02 PM, Zvi Vered <[hidden email]> wrote:
>> Dear Mr. Hundven,
>
> My name is Bryan. ;)
>
>>
>> How can I set ct-ng to use "companion tools bundled with ct-ng" ?
>
> Read the documentation:
>
> http://crosstool-ng.org/hg/crosstool-ng/raw-file/43ace4bb005e/docs/3%20-%20Configuring%20a%20toolchain.txt
>
>> The output of "libtool --version" is:
>> ltmain.sh (GNU libtool) 1.5.22 (1.1220.2.365 2005/12/18 22:14:06)
>> I used "yum install" to install it.
>>
>> This is weird. According to .configure --help, the minimum libtool
>> version should be:
>>  1.5.26
>> But running .configure does not alert on a libtool problem.
>> Can this cause the problem ?
>>
>> I tried pastebin but I should be a PRO user to paste all build.log
>>
>> You help is highly appreciated.
>>
>> Thanks,
>> Zvika
>>
>> On Sat, Oct 6, 2012 at 10:10 AM, Bryan Hundven <[hidden email]> wrote:
>>> On Fri, Oct 5, 2012 at 10:14 PM, Zvi Vered <[hidden email]> wrote:
>>>> Hello,
>>>>
>>>> I'm using crosstool-ng 1.16.0 to create a toolchain for
>>>> "i686-nptl-linux-gnu" under centos 5.3
>>>>
>>>> I got the following error:
>>>>
>>>> [ALL  ]    ./libtool: line 466: CDPATH: command not found
>>>> [ALL  ]    ./libtool: line 466: CDPATH: command not found
>>>> [ALL  ]    ./libtool: line 1144: func_opt_split: command not found
>>>> [ALL  ]    libtool: Version mismatch error.  This is libtool 2.2.6
>>>> Debian-2.2.6a-1ubuntu1, but the
>>>> [ALL  ]    libtool: definition of this LT_INIT comes from an older release.
>>>> [ALL  ]    libtool: You should recreate aclocal.m4 with macros from
>>>> libtool 2.2.6 Debian-2.2.6a-1ubuntu1
>>>> [ALL  ]    libtool: and run autoconf again.
>>>> [ERROR]    make[1]: *** [loop.lo] Error 1
>>>> [ALL  ]    make[1]: *** Waiting for unfinished jobs....
>>>> [ALL  ]    ./libtool: line 466: CDPATH: command not found
>>>> [ALL  ]    ./libtool: line 1144: func_opt_split: command not found
>>>> [ALL  ]    libtool: Version mismatch error.  This is libtool 2.2.6
>>>> Debian-2.2.6a-1ubuntu1, but the
>>>> [ALL  ]    libtool: definition of this LT_INIT comes from an older release.
>>>> [ALL  ]    libtool: You should recreate aclocal.m4 with macros from
>>>> libtool 2.2.6 Debian-2.2.6a-1ubuntu1
>>>> [ALL  ]    libtool: and run autoconf again.
>>>> [ERROR]    make[1]: *** [block.lo] Error 1
>>>> [ALL  ]    ./libtool: line 1144: func_opt_split: command not found
>>>> [ALL  ]    libtool: Version mismatch error.  This is libtool 2.2.6
>>>> Debian-2.2.6a-1ubuntu1, but the
>>>> [ALL  ]    libtool: definition of this LT_INIT comes from an older release.
>>>> [ALL  ]    libtool: You should recreate aclocal.m4 with macros from
>>>> libtool 2.2.6 Debian-2.2.6a-1ubuntu1
>>>> [ALL  ]    libtool: and run autoconf again.
>>>> [ERROR]    make[1]: *** [names.lo] Error 1
>>>> [ALL  ]    make[1]: Leaving directory
>>>> `/home/zvivered/GNU/ct-ng-1.16.0/working/i686-nptl-linux-gnu/build/build-cloog-ppl-host-i686-build_pc-linux-gnu'
>>>> [ERROR]
>>>> [ERROR]  >>
>>>> [ERROR]  >>  Build failed in step 'Installing CLooG/PPL for host'
>>>> [ERROR]  >>        called in step '(top-level)'
>>>> [ERROR]  >>
>>>> [ERROR]  >>  Error happened in: CT_DoExecLog[scripts/functions@158]
>>>> [ERROR]  >>        called from:
>>>> do_cloog_backend[scripts/build/companion_libs/cloog.sh@111]
>>>> [ERROR]  >>        called from:
>>>> do_cloog_for_host[scripts/build/companion_libs/cloog.sh@72]
>>>> [ERROR]  >>        called from: main[scripts/crosstool-NG.sh@598]
>>>> [ERROR]  >>
>>>> [ERROR]  >>  For more info on this error, look at the file: 'build.log'
>>>> [ERROR]  >>  There is a list of known issues, some with workarounds, in:
>>>> [ERROR]  >>
>>>> '/home/zvivered/GNU/ct-ng-1.16.0/share/doc/crosstool-ng/ct-ng.1.16.0/B
>>>> - Known issues.txt'
>>>> [ERROR]
>>>> [ERROR]  (elapsed: 6:05.48)
>>>>
>>>> Attached config.ng (copy of .config).
>>>>
>>>> Can you help find the problem ?
>>>>
>>>> Thanks,
>>>> Zvika
>>>>
>>>> --
>>>> For unsubscribe information see http://sourceware.org/lists.html#faq
>>>
>>> Zvi,
>>>
>>> Having the full log - posted to pastebin, or similar site, or hosted
>>> on some other web site to save space on the mailing list - would also
>>> be very helpful in this situation.
>>>
>>> From what I read, it looks like you have two different versions of
>>> libtool in the same path!?! weird!
>>>
>>> Have you tried cloog 0.15.11?
>>>
>>> As I said in my previous message about automake, try using the
>>> companion tools bundled with ct-ng.
>>> ( http://sourceware.org/ml/crossgcc/2012-10/msg00014.html )
>>>
>>>># CT_COMP_TOOLS is not set
>>>
>>> Not all systems are compatible with ct-ng, which is why we provide m4,
>>> autoconf, automake, libtool, and make.
>>>
>>> Also, this only seems to be a problem with cloog-ppl, have you also
>>> tried google searching around for similar cloog build errors? This
>>> doesn't look like it would be specific to crosstool-ng, but having the
>>> full build log might prove that otherwise.
>>>
>>> -Bryan
>
> -Bryan

--
For unsubscribe information see http://sourceware.org/lists.html#faq

Reply | Threaded
Open this post in threaded view
|

Re: crosstool-ng 1.16.0: libtool problem

Bryan Hundven
Zvika

On Sat, Oct 6, 2012 at 4:23 PM, Zvi Vered <[hidden email]> wrote:
> Hi Bryan,
>
> Did you mean:
> ./configure --prefix=$HOME/GNU/ct-ng-1.16.0 --without-automake
> --without-libtool --without-libtoolize
> ?

No, It's in 'ct-ng menuconfig'. You should find it under the
"companion tools" menu.

> But now I got the following error:
>
> Already extracted 'linux-3.4.7'
> [DEBUG]    Already patched 'linux-3.4.7'
> [DEBUG]    Already extracted 'gmp-4.3.2'
> [DEBUG]    Already patched 'gmp-4.3.2'
> [DEBUG]    Already extracted 'mpfr-2.4.2'
> [DEBUG]    Already patched 'mpfr-2.4.2'
> [DEBUG]    Running autoreconf
> [DEBUG]    ==> Executing: 'autoreconf'
> [ERROR]    acinclude.m4:26: error: Autoconf version 2.60 or higher is required
> [ALL  ]    acinclude.m4:26: the top level
> [ALL  ]    autom4te: /usr/bin/m4 failed with exit status: 63
> [ALL  ]    aclocal: autom4te failed with exit status: 63
> [ALL  ]    autoreconf: aclocal failed with exit status: 63
> [ERROR]
>
> I ran "yum install autoconf" and it installs autoconf 2.59
>
> What autoconf should I install and how ?
>
> Thanks,
> Zvika
>
> On Sat, Oct 6, 2012 at 9:05 PM, Bryan Hundven <[hidden email]> wrote:
>> Zvi,
>>
>> On Sat, Oct 6, 2012 at 12:02 PM, Zvi Vered <[hidden email]> wrote:
>>> Dear Mr. Hundven,
>>
>> My name is Bryan. ;)
>>
>>>
>>> How can I set ct-ng to use "companion tools bundled with ct-ng" ?
>>
>> Read the documentation:
>>
>> http://crosstool-ng.org/hg/crosstool-ng/raw-file/43ace4bb005e/docs/3%20-%20Configuring%20a%20toolchain.txt
>>
>>> The output of "libtool --version" is:
>>> ltmain.sh (GNU libtool) 1.5.22 (1.1220.2.365 2005/12/18 22:14:06)
>>> I used "yum install" to install it.
>>>
>>> This is weird. According to .configure --help, the minimum libtool
>>> version should be:
>>>  1.5.26
>>> But running .configure does not alert on a libtool problem.
>>> Can this cause the problem ?
>>>
>>> I tried pastebin but I should be a PRO user to paste all build.log
>>>
>>> You help is highly appreciated.
>>>
>>> Thanks,
>>> Zvika
>>>
>>> On Sat, Oct 6, 2012 at 10:10 AM, Bryan Hundven <[hidden email]> wrote:
>>>> On Fri, Oct 5, 2012 at 10:14 PM, Zvi Vered <[hidden email]> wrote:
>>>>> Hello,
>>>>>
>>>>> I'm using crosstool-ng 1.16.0 to create a toolchain for
>>>>> "i686-nptl-linux-gnu" under centos 5.3
>>>>>
>>>>> I got the following error:
>>>>>
>>>>> [ALL  ]    ./libtool: line 466: CDPATH: command not found
>>>>> [ALL  ]    ./libtool: line 466: CDPATH: command not found
>>>>> [ALL  ]    ./libtool: line 1144: func_opt_split: command not found
>>>>> [ALL  ]    libtool: Version mismatch error.  This is libtool 2.2.6
>>>>> Debian-2.2.6a-1ubuntu1, but the
>>>>> [ALL  ]    libtool: definition of this LT_INIT comes from an older release.
>>>>> [ALL  ]    libtool: You should recreate aclocal.m4 with macros from
>>>>> libtool 2.2.6 Debian-2.2.6a-1ubuntu1
>>>>> [ALL  ]    libtool: and run autoconf again.
>>>>> [ERROR]    make[1]: *** [loop.lo] Error 1
>>>>> [ALL  ]    make[1]: *** Waiting for unfinished jobs....
>>>>> [ALL  ]    ./libtool: line 466: CDPATH: command not found
>>>>> [ALL  ]    ./libtool: line 1144: func_opt_split: command not found
>>>>> [ALL  ]    libtool: Version mismatch error.  This is libtool 2.2.6
>>>>> Debian-2.2.6a-1ubuntu1, but the
>>>>> [ALL  ]    libtool: definition of this LT_INIT comes from an older release.
>>>>> [ALL  ]    libtool: You should recreate aclocal.m4 with macros from
>>>>> libtool 2.2.6 Debian-2.2.6a-1ubuntu1
>>>>> [ALL  ]    libtool: and run autoconf again.
>>>>> [ERROR]    make[1]: *** [block.lo] Error 1
>>>>> [ALL  ]    ./libtool: line 1144: func_opt_split: command not found
>>>>> [ALL  ]    libtool: Version mismatch error.  This is libtool 2.2.6
>>>>> Debian-2.2.6a-1ubuntu1, but the
>>>>> [ALL  ]    libtool: definition of this LT_INIT comes from an older release.
>>>>> [ALL  ]    libtool: You should recreate aclocal.m4 with macros from
>>>>> libtool 2.2.6 Debian-2.2.6a-1ubuntu1
>>>>> [ALL  ]    libtool: and run autoconf again.
>>>>> [ERROR]    make[1]: *** [names.lo] Error 1
>>>>> [ALL  ]    make[1]: Leaving directory
>>>>> `/home/zvivered/GNU/ct-ng-1.16.0/working/i686-nptl-linux-gnu/build/build-cloog-ppl-host-i686-build_pc-linux-gnu'
>>>>> [ERROR]
>>>>> [ERROR]  >>
>>>>> [ERROR]  >>  Build failed in step 'Installing CLooG/PPL for host'
>>>>> [ERROR]  >>        called in step '(top-level)'
>>>>> [ERROR]  >>
>>>>> [ERROR]  >>  Error happened in: CT_DoExecLog[scripts/functions@158]
>>>>> [ERROR]  >>        called from:
>>>>> do_cloog_backend[scripts/build/companion_libs/cloog.sh@111]
>>>>> [ERROR]  >>        called from:
>>>>> do_cloog_for_host[scripts/build/companion_libs/cloog.sh@72]
>>>>> [ERROR]  >>        called from: main[scripts/crosstool-NG.sh@598]
>>>>> [ERROR]  >>
>>>>> [ERROR]  >>  For more info on this error, look at the file: 'build.log'
>>>>> [ERROR]  >>  There is a list of known issues, some with workarounds, in:
>>>>> [ERROR]  >>
>>>>> '/home/zvivered/GNU/ct-ng-1.16.0/share/doc/crosstool-ng/ct-ng.1.16.0/B
>>>>> - Known issues.txt'
>>>>> [ERROR]
>>>>> [ERROR]  (elapsed: 6:05.48)
>>>>>
>>>>> Attached config.ng (copy of .config).
>>>>>
>>>>> Can you help find the problem ?
>>>>>
>>>>> Thanks,
>>>>> Zvika
>>>>>
>>>>> --
>>>>> For unsubscribe information see http://sourceware.org/lists.html#faq
>>>>
>>>> Zvi,
>>>>
>>>> Having the full log - posted to pastebin, or similar site, or hosted
>>>> on some other web site to save space on the mailing list - would also
>>>> be very helpful in this situation.
>>>>
>>>> From what I read, it looks like you have two different versions of
>>>> libtool in the same path!?! weird!
>>>>
>>>> Have you tried cloog 0.15.11?
>>>>
>>>> As I said in my previous message about automake, try using the
>>>> companion tools bundled with ct-ng.
>>>> ( http://sourceware.org/ml/crossgcc/2012-10/msg00014.html )
>>>>
>>>>># CT_COMP_TOOLS is not set
>>>>
>>>> Not all systems are compatible with ct-ng, which is why we provide m4,
>>>> autoconf, automake, libtool, and make.
>>>>
>>>> Also, this only seems to be a problem with cloog-ppl, have you also
>>>> tried google searching around for similar cloog build errors? This
>>>> doesn't look like it would be specific to crosstool-ng, but having the
>>>> full build log might prove that otherwise.
>>>>
>>>> -Bryan
>>
>> -Bryan

-Bryan

--
For unsubscribe information see http://sourceware.org/lists.html#faq

Reply | Threaded
Open this post in threaded view
|

Re: crosstool-ng 1.16.0: libtool problem

zvivered
Hi Bryan,

Attached the new .config
Now I got the following error:

[ALL  ]    ./libtool: line 466: CDPATH: command not found
[ALL  ]    ./libtool: line 466: CDPATH: command not found
[ALL  ]    ./libtool: line 1144: func_opt_split: command not found
[ALL  ]    libtool: Version mismatch error.  This is libtool 2.2.6
Debian-2.2.6a-1ubuntu1, but the
[ALL  ]    libtool: definition of this LT_INIT comes from an older release.
[ALL  ]    libtool: You should recreate aclocal.m4 with macros from
libtool 2.2.6 Debian-2.2.6a-1ubuntu1
[ALL  ]    libtool: and run autoconf again.
[ERROR]    make[1]: *** [block.lo] Error 1
[ALL  ]    make[1]: *** Waiting for unfinished jobs....
[ALL  ]    ./libtool: line 466: CDPATH: command not found
[ALL  ]    ./libtool: line 1144: func_opt_split: command not found
[ALL  ]    libtool: Version mismatch error.  This is libtool 2.2.6
Debian-2.2.6a-1ubuntu1, but the
[ALL  ]    libtool: definition of this LT_INIT comes from an older release.
[ALL  ]    libtool: You should recreate aclocal.m4 with macros from
libtool 2.2.6 Debian-2.2.6a-1ubuntu1
[ALL  ]    libtool: and run autoconf again.
[ERROR]    make[1]: *** [names.lo] Error 1
[ALL  ]    ./libtool: line 1144: func_opt_split: command not found
[ALL  ]    libtool: Version mismatch error.  This is libtool 2.2.6
Debian-2.2.6a-1ubuntu1, but the
[ALL  ]    libtool: definition of this LT_INIT comes from an older release.
[ALL  ]    libtool: You should recreate aclocal.m4 with macros from
libtool 2.2.6 Debian-2.2.6a-1ubuntu1
[ALL  ]    libtool: and run autoconf again.
[ERROR]    make[1]: *** [loop.lo] Error 1
[ALL  ]    make[1]: Leaving directory
`/home/zvivered/GNU/ct-ng-1.16.0/bin/.build/i686-nptl-linux-gnu/build/build-cloog-ppl-host-i686-build_pc-linux-gnu'
[ERROR]
[ERROR]  >>
[ERROR]  >>  Build failed in step 'Installing CLooG/PPL for host'
[ERROR]  >>        called in step '(top-level)'
[ERROR]  >>
[ERROR]  >>  Error happened in: CT_DoExecLog[scripts/functions@158]
[ERROR]  >>        called from:
do_cloog_backend[scripts/build/companion_libs/cloog.sh@111]
[ERROR]  >>        called from:
do_cloog_for_host[scripts/build/companion_libs/cloog.sh@72]
[ERROR]  >>        called from: main[scripts/crosstool-NG.sh@598]
[ERROR]  >>
[ERROR]  >>  For more info on this error, look at the file: 'build.log'
[ERROR]  >>  There is a list of known issues, some with workarounds, in:
[ERROR]  >>
'/home/zvivered/GNU/ct-ng-1.16.0/share/doc/crosstool-ng/ct-ng.1.16.0/B
- Known issues.txt'
[ERROR]

I did not install libtool manually. I have one libtool installed by CENTOS:
ltmain.sh (GNU libtool) 1.5.22 (1.1220.2.365 2005/12/18 22:14:06)

I installed automake 1.10, autoconf 2.60 ***manually*** because
crosstool-ng failed at earlier stages. (./configure, make, make
install). But when I checked "companion tools", crosstool should
ignore them. Am I right ?

Can you help ?

Thanks,
Zvika


On Sun, Oct 7, 2012 at 3:24 AM, Bryan Hundven <[hidden email]> wrote:

> Zvika
>
> On Sat, Oct 6, 2012 at 4:23 PM, Zvi Vered <[hidden email]> wrote:
>> Hi Bryan,
>>
>> Did you mean:
>> ./configure --prefix=$HOME/GNU/ct-ng-1.16.0 --without-automake
>> --without-libtool --without-libtoolize
>> ?
>
> No, It's in 'ct-ng menuconfig'. You should find it under the
> "companion tools" menu.
>
>> But now I got the following error:
>>
>> Already extracted 'linux-3.4.7'
>> [DEBUG]    Already patched 'linux-3.4.7'
>> [DEBUG]    Already extracted 'gmp-4.3.2'
>> [DEBUG]    Already patched 'gmp-4.3.2'
>> [DEBUG]    Already extracted 'mpfr-2.4.2'
>> [DEBUG]    Already patched 'mpfr-2.4.2'
>> [DEBUG]    Running autoreconf
>> [DEBUG]    ==> Executing: 'autoreconf'
>> [ERROR]    acinclude.m4:26: error: Autoconf version 2.60 or higher is required
>> [ALL  ]    acinclude.m4:26: the top level
>> [ALL  ]    autom4te: /usr/bin/m4 failed with exit status: 63
>> [ALL  ]    aclocal: autom4te failed with exit status: 63
>> [ALL  ]    autoreconf: aclocal failed with exit status: 63
>> [ERROR]
>>
>> I ran "yum install autoconf" and it installs autoconf 2.59
>>
>> What autoconf should I install and how ?
>>
>> Thanks,
>> Zvika
>>
>> On Sat, Oct 6, 2012 at 9:05 PM, Bryan Hundven <[hidden email]> wrote:
>>> Zvi,
>>>
>>> On Sat, Oct 6, 2012 at 12:02 PM, Zvi Vered <[hidden email]> wrote:
>>>> Dear Mr. Hundven,
>>>
>>> My name is Bryan. ;)
>>>
>>>>
>>>> How can I set ct-ng to use "companion tools bundled with ct-ng" ?
>>>
>>> Read the documentation:
>>>
>>> http://crosstool-ng.org/hg/crosstool-ng/raw-file/43ace4bb005e/docs/3%20-%20Configuring%20a%20toolchain.txt
>>>
>>>> The output of "libtool --version" is:
>>>> ltmain.sh (GNU libtool) 1.5.22 (1.1220.2.365 2005/12/18 22:14:06)
>>>> I used "yum install" to install it.
>>>>
>>>> This is weird. According to .configure --help, the minimum libtool
>>>> version should be:
>>>>  1.5.26
>>>> But running .configure does not alert on a libtool problem.
>>>> Can this cause the problem ?
>>>>
>>>> I tried pastebin but I should be a PRO user to paste all build.log
>>>>
>>>> You help is highly appreciated.
>>>>
>>>> Thanks,
>>>> Zvika
>>>>
>>>> On Sat, Oct 6, 2012 at 10:10 AM, Bryan Hundven <[hidden email]> wrote:
>>>>> On Fri, Oct 5, 2012 at 10:14 PM, Zvi Vered <[hidden email]> wrote:
>>>>>> Hello,
>>>>>>
>>>>>> I'm using crosstool-ng 1.16.0 to create a toolchain for
>>>>>> "i686-nptl-linux-gnu" under centos 5.3
>>>>>>
>>>>>> I got the following error:
>>>>>>
>>>>>> [ALL  ]    ./libtool: line 466: CDPATH: command not found
>>>>>> [ALL  ]    ./libtool: line 466: CDPATH: command not found
>>>>>> [ALL  ]    ./libtool: line 1144: func_opt_split: command not found
>>>>>> [ALL  ]    libtool: Version mismatch error.  This is libtool 2.2.6
>>>>>> Debian-2.2.6a-1ubuntu1, but the
>>>>>> [ALL  ]    libtool: definition of this LT_INIT comes from an older release.
>>>>>> [ALL  ]    libtool: You should recreate aclocal.m4 with macros from
>>>>>> libtool 2.2.6 Debian-2.2.6a-1ubuntu1
>>>>>> [ALL  ]    libtool: and run autoconf again.
>>>>>> [ERROR]    make[1]: *** [loop.lo] Error 1
>>>>>> [ALL  ]    make[1]: *** Waiting for unfinished jobs....
>>>>>> [ALL  ]    ./libtool: line 466: CDPATH: command not found
>>>>>> [ALL  ]    ./libtool: line 1144: func_opt_split: command not found
>>>>>> [ALL  ]    libtool: Version mismatch error.  This is libtool 2.2.6
>>>>>> Debian-2.2.6a-1ubuntu1, but the
>>>>>> [ALL  ]    libtool: definition of this LT_INIT comes from an older release.
>>>>>> [ALL  ]    libtool: You should recreate aclocal.m4 with macros from
>>>>>> libtool 2.2.6 Debian-2.2.6a-1ubuntu1
>>>>>> [ALL  ]    libtool: and run autoconf again.
>>>>>> [ERROR]    make[1]: *** [block.lo] Error 1
>>>>>> [ALL  ]    ./libtool: line 1144: func_opt_split: command not found
>>>>>> [ALL  ]    libtool: Version mismatch error.  This is libtool 2.2.6
>>>>>> Debian-2.2.6a-1ubuntu1, but the
>>>>>> [ALL  ]    libtool: definition of this LT_INIT comes from an older release.
>>>>>> [ALL  ]    libtool: You should recreate aclocal.m4 with macros from
>>>>>> libtool 2.2.6 Debian-2.2.6a-1ubuntu1
>>>>>> [ALL  ]    libtool: and run autoconf again.
>>>>>> [ERROR]    make[1]: *** [names.lo] Error 1
>>>>>> [ALL  ]    make[1]: Leaving directory
>>>>>> `/home/zvivered/GNU/ct-ng-1.16.0/working/i686-nptl-linux-gnu/build/build-cloog-ppl-host-i686-build_pc-linux-gnu'
>>>>>> [ERROR]
>>>>>> [ERROR]  >>
>>>>>> [ERROR]  >>  Build failed in step 'Installing CLooG/PPL for host'
>>>>>> [ERROR]  >>        called in step '(top-level)'
>>>>>> [ERROR]  >>
>>>>>> [ERROR]  >>  Error happened in: CT_DoExecLog[scripts/functions@158]
>>>>>> [ERROR]  >>        called from:
>>>>>> do_cloog_backend[scripts/build/companion_libs/cloog.sh@111]
>>>>>> [ERROR]  >>        called from:
>>>>>> do_cloog_for_host[scripts/build/companion_libs/cloog.sh@72]
>>>>>> [ERROR]  >>        called from: main[scripts/crosstool-NG.sh@598]
>>>>>> [ERROR]  >>
>>>>>> [ERROR]  >>  For more info on this error, look at the file: 'build.log'
>>>>>> [ERROR]  >>  There is a list of known issues, some with workarounds, in:
>>>>>> [ERROR]  >>
>>>>>> '/home/zvivered/GNU/ct-ng-1.16.0/share/doc/crosstool-ng/ct-ng.1.16.0/B
>>>>>> - Known issues.txt'
>>>>>> [ERROR]
>>>>>> [ERROR]  (elapsed: 6:05.48)
>>>>>>
>>>>>> Attached config.ng (copy of .config).
>>>>>>
>>>>>> Can you help find the problem ?
>>>>>>
>>>>>> Thanks,
>>>>>> Zvika
>>>>>>
>>>>>> --
>>>>>> For unsubscribe information see http://sourceware.org/lists.html#faq
>>>>>
>>>>> Zvi,
>>>>>
>>>>> Having the full log - posted to pastebin, or similar site, or hosted
>>>>> on some other web site to save space on the mailing list - would also
>>>>> be very helpful in this situation.
>>>>>
>>>>> From what I read, it looks like you have two different versions of
>>>>> libtool in the same path!?! weird!
>>>>>
>>>>> Have you tried cloog 0.15.11?
>>>>>
>>>>> As I said in my previous message about automake, try using the
>>>>> companion tools bundled with ct-ng.
>>>>> ( http://sourceware.org/ml/crossgcc/2012-10/msg00014.html )
>>>>>
>>>>>># CT_COMP_TOOLS is not set
>>>>>
>>>>> Not all systems are compatible with ct-ng, which is why we provide m4,
>>>>> autoconf, automake, libtool, and make.
>>>>>
>>>>> Also, this only seems to be a problem with cloog-ppl, have you also
>>>>> tried google searching around for similar cloog build errors? This
>>>>> doesn't look like it would be specific to crosstool-ng, but having the
>>>>> full build log might prove that otherwise.
>>>>>
>>>>> -Bryan
>>>
>>> -Bryan
>
> -Bryan

--
For unsubscribe information see http://sourceware.org/lists.html#faq

config.ng (13K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: crosstool-ng 1.16.0: libtool problem

Bryan Hundven
On Sat, Oct 6, 2012 at 8:38 PM, Zvi Vered <[hidden email]> wrote:
> Hi Bryan,
>
> Attached the new .config
> Now I got the following error:

Zvika,

Please post the full log to pastebin or similar site.

Thanks,

-Bryan

> [ALL  ]    ./libtool: line 466: CDPATH: command not found
> [ALL  ]    ./libtool: line 466: CDPATH: command not found
> [ALL  ]    ./libtool: line 1144: func_opt_split: command not found
> [ALL  ]    libtool: Version mismatch error.  This is libtool 2.2.6
> Debian-2.2.6a-1ubuntu1, but the
> [ALL  ]    libtool: definition of this LT_INIT comes from an older release.
> [ALL  ]    libtool: You should recreate aclocal.m4 with macros from
> libtool 2.2.6 Debian-2.2.6a-1ubuntu1
> [ALL  ]    libtool: and run autoconf again.
> [ERROR]    make[1]: *** [block.lo] Error 1
> [ALL  ]    make[1]: *** Waiting for unfinished jobs....
> [ALL  ]    ./libtool: line 466: CDPATH: command not found
> [ALL  ]    ./libtool: line 1144: func_opt_split: command not found
> [ALL  ]    libtool: Version mismatch error.  This is libtool 2.2.6
> Debian-2.2.6a-1ubuntu1, but the
> [ALL  ]    libtool: definition of this LT_INIT comes from an older release.
> [ALL  ]    libtool: You should recreate aclocal.m4 with macros from
> libtool 2.2.6 Debian-2.2.6a-1ubuntu1
> [ALL  ]    libtool: and run autoconf again.
> [ERROR]    make[1]: *** [names.lo] Error 1
> [ALL  ]    ./libtool: line 1144: func_opt_split: command not found
> [ALL  ]    libtool: Version mismatch error.  This is libtool 2.2.6
> Debian-2.2.6a-1ubuntu1, but the
> [ALL  ]    libtool: definition of this LT_INIT comes from an older release.
> [ALL  ]    libtool: You should recreate aclocal.m4 with macros from
> libtool 2.2.6 Debian-2.2.6a-1ubuntu1
> [ALL  ]    libtool: and run autoconf again.
> [ERROR]    make[1]: *** [loop.lo] Error 1
> [ALL  ]    make[1]: Leaving directory
> `/home/zvivered/GNU/ct-ng-1.16.0/bin/.build/i686-nptl-linux-gnu/build/build-cloog-ppl-host-i686-build_pc-linux-gnu'
> [ERROR]
> [ERROR]  >>
> [ERROR]  >>  Build failed in step 'Installing CLooG/PPL for host'
> [ERROR]  >>        called in step '(top-level)'
> [ERROR]  >>
> [ERROR]  >>  Error happened in: CT_DoExecLog[scripts/functions@158]
> [ERROR]  >>        called from:
> do_cloog_backend[scripts/build/companion_libs/cloog.sh@111]
> [ERROR]  >>        called from:
> do_cloog_for_host[scripts/build/companion_libs/cloog.sh@72]
> [ERROR]  >>        called from: main[scripts/crosstool-NG.sh@598]
> [ERROR]  >>
> [ERROR]  >>  For more info on this error, look at the file: 'build.log'
> [ERROR]  >>  There is a list of known issues, some with workarounds, in:
> [ERROR]  >>
> '/home/zvivered/GNU/ct-ng-1.16.0/share/doc/crosstool-ng/ct-ng.1.16.0/B
> - Known issues.txt'
> [ERROR]
>
> I did not install libtool manually. I have one libtool installed by CENTOS:
> ltmain.sh (GNU libtool) 1.5.22 (1.1220.2.365 2005/12/18 22:14:06)
>
> I installed automake 1.10, autoconf 2.60 ***manually*** because
> crosstool-ng failed at earlier stages. (./configure, make, make
> install). But when I checked "companion tools", crosstool should
> ignore them. Am I right ?
>
> Can you help ?
>
> Thanks,
> Zvika
>
>
> On Sun, Oct 7, 2012 at 3:24 AM, Bryan Hundven <[hidden email]> wrote:
>> Zvika
>>
>> On Sat, Oct 6, 2012 at 4:23 PM, Zvi Vered <[hidden email]> wrote:
>>> Hi Bryan,
>>>
>>> Did you mean:
>>> ./configure --prefix=$HOME/GNU/ct-ng-1.16.0 --without-automake
>>> --without-libtool --without-libtoolize
>>> ?
>>
>> No, It's in 'ct-ng menuconfig'. You should find it under the
>> "companion tools" menu.
>>
>>> But now I got the following error:
>>>
>>> Already extracted 'linux-3.4.7'
>>> [DEBUG]    Already patched 'linux-3.4.7'
>>> [DEBUG]    Already extracted 'gmp-4.3.2'
>>> [DEBUG]    Already patched 'gmp-4.3.2'
>>> [DEBUG]    Already extracted 'mpfr-2.4.2'
>>> [DEBUG]    Already patched 'mpfr-2.4.2'
>>> [DEBUG]    Running autoreconf
>>> [DEBUG]    ==> Executing: 'autoreconf'
>>> [ERROR]    acinclude.m4:26: error: Autoconf version 2.60 or higher is required
>>> [ALL  ]    acinclude.m4:26: the top level
>>> [ALL  ]    autom4te: /usr/bin/m4 failed with exit status: 63
>>> [ALL  ]    aclocal: autom4te failed with exit status: 63
>>> [ALL  ]    autoreconf: aclocal failed with exit status: 63
>>> [ERROR]
>>>
>>> I ran "yum install autoconf" and it installs autoconf 2.59
>>>
>>> What autoconf should I install and how ?
>>>
>>> Thanks,
>>> Zvika
>>>
>>> On Sat, Oct 6, 2012 at 9:05 PM, Bryan Hundven <[hidden email]> wrote:
>>>> Zvi,
>>>>
>>>> On Sat, Oct 6, 2012 at 12:02 PM, Zvi Vered <[hidden email]> wrote:
>>>>> Dear Mr. Hundven,
>>>>
>>>> My name is Bryan. ;)
>>>>
>>>>>
>>>>> How can I set ct-ng to use "companion tools bundled with ct-ng" ?
>>>>
>>>> Read the documentation:
>>>>
>>>> http://crosstool-ng.org/hg/crosstool-ng/raw-file/43ace4bb005e/docs/3%20-%20Configuring%20a%20toolchain.txt
>>>>
>>>>> The output of "libtool --version" is:
>>>>> ltmain.sh (GNU libtool) 1.5.22 (1.1220.2.365 2005/12/18 22:14:06)
>>>>> I used "yum install" to install it.
>>>>>
>>>>> This is weird. According to .configure --help, the minimum libtool
>>>>> version should be:
>>>>>  1.5.26
>>>>> But running .configure does not alert on a libtool problem.
>>>>> Can this cause the problem ?
>>>>>
>>>>> I tried pastebin but I should be a PRO user to paste all build.log
>>>>>
>>>>> You help is highly appreciated.
>>>>>
>>>>> Thanks,
>>>>> Zvika
>>>>>
>>>>> On Sat, Oct 6, 2012 at 10:10 AM, Bryan Hundven <[hidden email]> wrote:
>>>>>> On Fri, Oct 5, 2012 at 10:14 PM, Zvi Vered <[hidden email]> wrote:
>>>>>>> Hello,
>>>>>>>
>>>>>>> I'm using crosstool-ng 1.16.0 to create a toolchain for
>>>>>>> "i686-nptl-linux-gnu" under centos 5.3
>>>>>>>
>>>>>>> I got the following error:
>>>>>>>
>>>>>>> [ALL  ]    ./libtool: line 466: CDPATH: command not found
>>>>>>> [ALL  ]    ./libtool: line 466: CDPATH: command not found
>>>>>>> [ALL  ]    ./libtool: line 1144: func_opt_split: command not found
>>>>>>> [ALL  ]    libtool: Version mismatch error.  This is libtool 2.2.6
>>>>>>> Debian-2.2.6a-1ubuntu1, but the
>>>>>>> [ALL  ]    libtool: definition of this LT_INIT comes from an older release.
>>>>>>> [ALL  ]    libtool: You should recreate aclocal.m4 with macros from
>>>>>>> libtool 2.2.6 Debian-2.2.6a-1ubuntu1
>>>>>>> [ALL  ]    libtool: and run autoconf again.
>>>>>>> [ERROR]    make[1]: *** [loop.lo] Error 1
>>>>>>> [ALL  ]    make[1]: *** Waiting for unfinished jobs....
>>>>>>> [ALL  ]    ./libtool: line 466: CDPATH: command not found
>>>>>>> [ALL  ]    ./libtool: line 1144: func_opt_split: command not found
>>>>>>> [ALL  ]    libtool: Version mismatch error.  This is libtool 2.2.6
>>>>>>> Debian-2.2.6a-1ubuntu1, but the
>>>>>>> [ALL  ]    libtool: definition of this LT_INIT comes from an older release.
>>>>>>> [ALL  ]    libtool: You should recreate aclocal.m4 with macros from
>>>>>>> libtool 2.2.6 Debian-2.2.6a-1ubuntu1
>>>>>>> [ALL  ]    libtool: and run autoconf again.
>>>>>>> [ERROR]    make[1]: *** [block.lo] Error 1
>>>>>>> [ALL  ]    ./libtool: line 1144: func_opt_split: command not found
>>>>>>> [ALL  ]    libtool: Version mismatch error.  This is libtool 2.2.6
>>>>>>> Debian-2.2.6a-1ubuntu1, but the
>>>>>>> [ALL  ]    libtool: definition of this LT_INIT comes from an older release.
>>>>>>> [ALL  ]    libtool: You should recreate aclocal.m4 with macros from
>>>>>>> libtool 2.2.6 Debian-2.2.6a-1ubuntu1
>>>>>>> [ALL  ]    libtool: and run autoconf again.
>>>>>>> [ERROR]    make[1]: *** [names.lo] Error 1
>>>>>>> [ALL  ]    make[1]: Leaving directory
>>>>>>> `/home/zvivered/GNU/ct-ng-1.16.0/working/i686-nptl-linux-gnu/build/build-cloog-ppl-host-i686-build_pc-linux-gnu'
>>>>>>> [ERROR]
>>>>>>> [ERROR]  >>
>>>>>>> [ERROR]  >>  Build failed in step 'Installing CLooG/PPL for host'
>>>>>>> [ERROR]  >>        called in step '(top-level)'
>>>>>>> [ERROR]  >>
>>>>>>> [ERROR]  >>  Error happened in: CT_DoExecLog[scripts/functions@158]
>>>>>>> [ERROR]  >>        called from:
>>>>>>> do_cloog_backend[scripts/build/companion_libs/cloog.sh@111]
>>>>>>> [ERROR]  >>        called from:
>>>>>>> do_cloog_for_host[scripts/build/companion_libs/cloog.sh@72]
>>>>>>> [ERROR]  >>        called from: main[scripts/crosstool-NG.sh@598]
>>>>>>> [ERROR]  >>
>>>>>>> [ERROR]  >>  For more info on this error, look at the file: 'build.log'
>>>>>>> [ERROR]  >>  There is a list of known issues, some with workarounds, in:
>>>>>>> [ERROR]  >>
>>>>>>> '/home/zvivered/GNU/ct-ng-1.16.0/share/doc/crosstool-ng/ct-ng.1.16.0/B
>>>>>>> - Known issues.txt'
>>>>>>> [ERROR]
>>>>>>> [ERROR]  (elapsed: 6:05.48)
>>>>>>>
>>>>>>> Attached config.ng (copy of .config).
>>>>>>>
>>>>>>> Can you help find the problem ?
>>>>>>>
>>>>>>> Thanks,
>>>>>>> Zvika
>>>>>>>
>>>>>>> --
>>>>>>> For unsubscribe information see http://sourceware.org/lists.html#faq
>>>>>>
>>>>>> Zvi,
>>>>>>
>>>>>> Having the full log - posted to pastebin, or similar site, or hosted
>>>>>> on some other web site to save space on the mailing list - would also
>>>>>> be very helpful in this situation.
>>>>>>
>>>>>> From what I read, it looks like you have two different versions of
>>>>>> libtool in the same path!?! weird!
>>>>>>
>>>>>> Have you tried cloog 0.15.11?
>>>>>>
>>>>>> As I said in my previous message about automake, try using the
>>>>>> companion tools bundled with ct-ng.
>>>>>> ( http://sourceware.org/ml/crossgcc/2012-10/msg00014.html )
>>>>>>
>>>>>>># CT_COMP_TOOLS is not set
>>>>>>
>>>>>> Not all systems are compatible with ct-ng, which is why we provide m4,
>>>>>> autoconf, automake, libtool, and make.
>>>>>>
>>>>>> Also, this only seems to be a problem with cloog-ppl, have you also
>>>>>> tried google searching around for similar cloog build errors? This
>>>>>> doesn't look like it would be specific to crosstool-ng, but having the
>>>>>> full build log might prove that otherwise.
>>>>>>
>>>>>> -Bryan
>>>>
>>>> -Bryan
>>
>> -Bryan

--
For unsubscribe information see http://sourceware.org/lists.html#faq

Reply | Threaded
Open this post in threaded view
|

Re: crosstool-ng 1.16.0: libtool problem

zvivered
Hi Bryan,

I just sent the file using https://www.transferbigfiles.com.

Thanks,
Zvika

On Sun, Oct 7, 2012 at 6:27 AM, Bryan Hundven <[hidden email]> wrote:

> On Sat, Oct 6, 2012 at 8:38 PM, Zvi Vered <[hidden email]> wrote:
>> Hi Bryan,
>>
>> Attached the new .config
>> Now I got the following error:
>
> Zvika,
>
> Please post the full log to pastebin or similar site.
>
> Thanks,
>
> -Bryan
>
>> [ALL  ]    ./libtool: line 466: CDPATH: command not found
>> [ALL  ]    ./libtool: line 466: CDPATH: command not found
>> [ALL  ]    ./libtool: line 1144: func_opt_split: command not found
>> [ALL  ]    libtool: Version mismatch error.  This is libtool 2.2.6
>> Debian-2.2.6a-1ubuntu1, but the
>> [ALL  ]    libtool: definition of this LT_INIT comes from an older release.
>> [ALL  ]    libtool: You should recreate aclocal.m4 with macros from
>> libtool 2.2.6 Debian-2.2.6a-1ubuntu1
>> [ALL  ]    libtool: and run autoconf again.
>> [ERROR]    make[1]: *** [block.lo] Error 1
>> [ALL  ]    make[1]: *** Waiting for unfinished jobs....
>> [ALL  ]    ./libtool: line 466: CDPATH: command not found
>> [ALL  ]    ./libtool: line 1144: func_opt_split: command not found
>> [ALL  ]    libtool: Version mismatch error.  This is libtool 2.2.6
>> Debian-2.2.6a-1ubuntu1, but the
>> [ALL  ]    libtool: definition of this LT_INIT comes from an older release.
>> [ALL  ]    libtool: You should recreate aclocal.m4 with macros from
>> libtool 2.2.6 Debian-2.2.6a-1ubuntu1
>> [ALL  ]    libtool: and run autoconf again.
>> [ERROR]    make[1]: *** [names.lo] Error 1
>> [ALL  ]    ./libtool: line 1144: func_opt_split: command not found
>> [ALL  ]    libtool: Version mismatch error.  This is libtool 2.2.6
>> Debian-2.2.6a-1ubuntu1, but the
>> [ALL  ]    libtool: definition of this LT_INIT comes from an older release.
>> [ALL  ]    libtool: You should recreate aclocal.m4 with macros from
>> libtool 2.2.6 Debian-2.2.6a-1ubuntu1
>> [ALL  ]    libtool: and run autoconf again.
>> [ERROR]    make[1]: *** [loop.lo] Error 1
>> [ALL  ]    make[1]: Leaving directory
>> `/home/zvivered/GNU/ct-ng-1.16.0/bin/.build/i686-nptl-linux-gnu/build/build-cloog-ppl-host-i686-build_pc-linux-gnu'
>> [ERROR]
>> [ERROR]  >>
>> [ERROR]  >>  Build failed in step 'Installing CLooG/PPL for host'
>> [ERROR]  >>        called in step '(top-level)'
>> [ERROR]  >>
>> [ERROR]  >>  Error happened in: CT_DoExecLog[scripts/functions@158]
>> [ERROR]  >>        called from:
>> do_cloog_backend[scripts/build/companion_libs/cloog.sh@111]
>> [ERROR]  >>        called from:
>> do_cloog_for_host[scripts/build/companion_libs/cloog.sh@72]
>> [ERROR]  >>        called from: main[scripts/crosstool-NG.sh@598]
>> [ERROR]  >>
>> [ERROR]  >>  For more info on this error, look at the file: 'build.log'
>> [ERROR]  >>  There is a list of known issues, some with workarounds, in:
>> [ERROR]  >>
>> '/home/zvivered/GNU/ct-ng-1.16.0/share/doc/crosstool-ng/ct-ng.1.16.0/B
>> - Known issues.txt'
>> [ERROR]
>>
>> I did not install libtool manually. I have one libtool installed by CENTOS:
>> ltmain.sh (GNU libtool) 1.5.22 (1.1220.2.365 2005/12/18 22:14:06)
>>
>> I installed automake 1.10, autoconf 2.60 ***manually*** because
>> crosstool-ng failed at earlier stages. (./configure, make, make
>> install). But when I checked "companion tools", crosstool should
>> ignore them. Am I right ?
>>
>> Can you help ?
>>
>> Thanks,
>> Zvika
>>
>>
>> On Sun, Oct 7, 2012 at 3:24 AM, Bryan Hundven <[hidden email]> wrote:
>>> Zvika
>>>
>>> On Sat, Oct 6, 2012 at 4:23 PM, Zvi Vered <[hidden email]> wrote:
>>>> Hi Bryan,
>>>>
>>>> Did you mean:
>>>> ./configure --prefix=$HOME/GNU/ct-ng-1.16.0 --without-automake
>>>> --without-libtool --without-libtoolize
>>>> ?
>>>
>>> No, It's in 'ct-ng menuconfig'. You should find it under the
>>> "companion tools" menu.
>>>
>>>> But now I got the following error:
>>>>
>>>> Already extracted 'linux-3.4.7'
>>>> [DEBUG]    Already patched 'linux-3.4.7'
>>>> [DEBUG]    Already extracted 'gmp-4.3.2'
>>>> [DEBUG]    Already patched 'gmp-4.3.2'
>>>> [DEBUG]    Already extracted 'mpfr-2.4.2'
>>>> [DEBUG]    Already patched 'mpfr-2.4.2'
>>>> [DEBUG]    Running autoreconf
>>>> [DEBUG]    ==> Executing: 'autoreconf'
>>>> [ERROR]    acinclude.m4:26: error: Autoconf version 2.60 or higher is required
>>>> [ALL  ]    acinclude.m4:26: the top level
>>>> [ALL  ]    autom4te: /usr/bin/m4 failed with exit status: 63
>>>> [ALL  ]    aclocal: autom4te failed with exit status: 63
>>>> [ALL  ]    autoreconf: aclocal failed with exit status: 63
>>>> [ERROR]
>>>>
>>>> I ran "yum install autoconf" and it installs autoconf 2.59
>>>>
>>>> What autoconf should I install and how ?
>>>>
>>>> Thanks,
>>>> Zvika
>>>>
>>>> On Sat, Oct 6, 2012 at 9:05 PM, Bryan Hundven <[hidden email]> wrote:
>>>>> Zvi,
>>>>>
>>>>> On Sat, Oct 6, 2012 at 12:02 PM, Zvi Vered <[hidden email]> wrote:
>>>>>> Dear Mr. Hundven,
>>>>>
>>>>> My name is Bryan. ;)
>>>>>
>>>>>>
>>>>>> How can I set ct-ng to use "companion tools bundled with ct-ng" ?
>>>>>
>>>>> Read the documentation:
>>>>>
>>>>> http://crosstool-ng.org/hg/crosstool-ng/raw-file/43ace4bb005e/docs/3%20-%20Configuring%20a%20toolchain.txt
>>>>>
>>>>>> The output of "libtool --version" is:
>>>>>> ltmain.sh (GNU libtool) 1.5.22 (1.1220.2.365 2005/12/18 22:14:06)
>>>>>> I used "yum install" to install it.
>>>>>>
>>>>>> This is weird. According to .configure --help, the minimum libtool
>>>>>> version should be:
>>>>>>  1.5.26
>>>>>> But running .configure does not alert on a libtool problem.
>>>>>> Can this cause the problem ?
>>>>>>
>>>>>> I tried pastebin but I should be a PRO user to paste all build.log
>>>>>>
>>>>>> You help is highly appreciated.
>>>>>>
>>>>>> Thanks,
>>>>>> Zvika
>>>>>>
>>>>>> On Sat, Oct 6, 2012 at 10:10 AM, Bryan Hundven <[hidden email]> wrote:
>>>>>>> On Fri, Oct 5, 2012 at 10:14 PM, Zvi Vered <[hidden email]> wrote:
>>>>>>>> Hello,
>>>>>>>>
>>>>>>>> I'm using crosstool-ng 1.16.0 to create a toolchain for
>>>>>>>> "i686-nptl-linux-gnu" under centos 5.3
>>>>>>>>
>>>>>>>> I got the following error:
>>>>>>>>
>>>>>>>> [ALL  ]    ./libtool: line 466: CDPATH: command not found
>>>>>>>> [ALL  ]    ./libtool: line 466: CDPATH: command not found
>>>>>>>> [ALL  ]    ./libtool: line 1144: func_opt_split: command not found
>>>>>>>> [ALL  ]    libtool: Version mismatch error.  This is libtool 2.2.6
>>>>>>>> Debian-2.2.6a-1ubuntu1, but the
>>>>>>>> [ALL  ]    libtool: definition of this LT_INIT comes from an older release.
>>>>>>>> [ALL  ]    libtool: You should recreate aclocal.m4 with macros from
>>>>>>>> libtool 2.2.6 Debian-2.2.6a-1ubuntu1
>>>>>>>> [ALL  ]    libtool: and run autoconf again.
>>>>>>>> [ERROR]    make[1]: *** [loop.lo] Error 1
>>>>>>>> [ALL  ]    make[1]: *** Waiting for unfinished jobs....
>>>>>>>> [ALL  ]    ./libtool: line 466: CDPATH: command not found
>>>>>>>> [ALL  ]    ./libtool: line 1144: func_opt_split: command not found
>>>>>>>> [ALL  ]    libtool: Version mismatch error.  This is libtool 2.2.6
>>>>>>>> Debian-2.2.6a-1ubuntu1, but the
>>>>>>>> [ALL  ]    libtool: definition of this LT_INIT comes from an older release.
>>>>>>>> [ALL  ]    libtool: You should recreate aclocal.m4 with macros from
>>>>>>>> libtool 2.2.6 Debian-2.2.6a-1ubuntu1
>>>>>>>> [ALL  ]    libtool: and run autoconf again.
>>>>>>>> [ERROR]    make[1]: *** [block.lo] Error 1
>>>>>>>> [ALL  ]    ./libtool: line 1144: func_opt_split: command not found
>>>>>>>> [ALL  ]    libtool: Version mismatch error.  This is libtool 2.2.6
>>>>>>>> Debian-2.2.6a-1ubuntu1, but the
>>>>>>>> [ALL  ]    libtool: definition of this LT_INIT comes from an older release.
>>>>>>>> [ALL  ]    libtool: You should recreate aclocal.m4 with macros from
>>>>>>>> libtool 2.2.6 Debian-2.2.6a-1ubuntu1
>>>>>>>> [ALL  ]    libtool: and run autoconf again.
>>>>>>>> [ERROR]    make[1]: *** [names.lo] Error 1
>>>>>>>> [ALL  ]    make[1]: Leaving directory
>>>>>>>> `/home/zvivered/GNU/ct-ng-1.16.0/working/i686-nptl-linux-gnu/build/build-cloog-ppl-host-i686-build_pc-linux-gnu'
>>>>>>>> [ERROR]
>>>>>>>> [ERROR]  >>
>>>>>>>> [ERROR]  >>  Build failed in step 'Installing CLooG/PPL for host'
>>>>>>>> [ERROR]  >>        called in step '(top-level)'
>>>>>>>> [ERROR]  >>
>>>>>>>> [ERROR]  >>  Error happened in: CT_DoExecLog[scripts/functions@158]
>>>>>>>> [ERROR]  >>        called from:
>>>>>>>> do_cloog_backend[scripts/build/companion_libs/cloog.sh@111]
>>>>>>>> [ERROR]  >>        called from:
>>>>>>>> do_cloog_for_host[scripts/build/companion_libs/cloog.sh@72]
>>>>>>>> [ERROR]  >>        called from: main[scripts/crosstool-NG.sh@598]
>>>>>>>> [ERROR]  >>
>>>>>>>> [ERROR]  >>  For more info on this error, look at the file: 'build.log'
>>>>>>>> [ERROR]  >>  There is a list of known issues, some with workarounds, in:
>>>>>>>> [ERROR]  >>
>>>>>>>> '/home/zvivered/GNU/ct-ng-1.16.0/share/doc/crosstool-ng/ct-ng.1.16.0/B
>>>>>>>> - Known issues.txt'
>>>>>>>> [ERROR]
>>>>>>>> [ERROR]  (elapsed: 6:05.48)
>>>>>>>>
>>>>>>>> Attached config.ng (copy of .config).
>>>>>>>>
>>>>>>>> Can you help find the problem ?
>>>>>>>>
>>>>>>>> Thanks,
>>>>>>>> Zvika
>>>>>>>>
>>>>>>>> --
>>>>>>>> For unsubscribe information see http://sourceware.org/lists.html#faq
>>>>>>>
>>>>>>> Zvi,
>>>>>>>
>>>>>>> Having the full log - posted to pastebin, or similar site, or hosted
>>>>>>> on some other web site to save space on the mailing list - would also
>>>>>>> be very helpful in this situation.
>>>>>>>
>>>>>>> From what I read, it looks like you have two different versions of
>>>>>>> libtool in the same path!?! weird!
>>>>>>>
>>>>>>> Have you tried cloog 0.15.11?
>>>>>>>
>>>>>>> As I said in my previous message about automake, try using the
>>>>>>> companion tools bundled with ct-ng.
>>>>>>> ( http://sourceware.org/ml/crossgcc/2012-10/msg00014.html )
>>>>>>>
>>>>>>>># CT_COMP_TOOLS is not set
>>>>>>>
>>>>>>> Not all systems are compatible with ct-ng, which is why we provide m4,
>>>>>>> autoconf, automake, libtool, and make.
>>>>>>>
>>>>>>> Also, this only seems to be a problem with cloog-ppl, have you also
>>>>>>> tried google searching around for similar cloog build errors? This
>>>>>>> doesn't look like it would be specific to crosstool-ng, but having the
>>>>>>> full build log might prove that otherwise.
>>>>>>>
>>>>>>> -Bryan
>>>>>
>>>>> -Bryan
>>>
>>> -Bryan

--
For unsubscribe information see http://sourceware.org/lists.html#faq

Reply | Threaded
Open this post in threaded view
|

Re: crosstool-ng 1.16.0: libtool problem

Bryan Hundven
On Sat, Oct 6, 2012 at 11:12 PM, Zvi Vered <[hidden email]> wrote:
> Hi Bryan,
>
> I just sent the file using https://www.transferbigfiles.com.

I have posted the build.log here:
http://bryanhundven.com/zvi-build.log

for anyone else to view it.

-Bryan

> Thanks,
> Zvika
>
> On Sun, Oct 7, 2012 at 6:27 AM, Bryan Hundven <[hidden email]> wrote:
>> On Sat, Oct 6, 2012 at 8:38 PM, Zvi Vered <[hidden email]> wrote:
>>> Hi Bryan,
>>>
>>> Attached the new .config
>>> Now I got the following error:
>>
>> Zvika,
>>
>> Please post the full log to pastebin or similar site.
>>
>> Thanks,
>>
>> -Bryan
>>
>>> [ALL  ]    ./libtool: line 466: CDPATH: command not found
>>> [ALL  ]    ./libtool: line 466: CDPATH: command not found
>>> [ALL  ]    ./libtool: line 1144: func_opt_split: command not found
>>> [ALL  ]    libtool: Version mismatch error.  This is libtool 2.2.6
>>> Debian-2.2.6a-1ubuntu1, but the
>>> [ALL  ]    libtool: definition of this LT_INIT comes from an older release.
>>> [ALL  ]    libtool: You should recreate aclocal.m4 with macros from
>>> libtool 2.2.6 Debian-2.2.6a-1ubuntu1
>>> [ALL  ]    libtool: and run autoconf again.
>>> [ERROR]    make[1]: *** [block.lo] Error 1
>>> [ALL  ]    make[1]: *** Waiting for unfinished jobs....
>>> [ALL  ]    ./libtool: line 466: CDPATH: command not found
>>> [ALL  ]    ./libtool: line 1144: func_opt_split: command not found
>>> [ALL  ]    libtool: Version mismatch error.  This is libtool 2.2.6
>>> Debian-2.2.6a-1ubuntu1, but the
>>> [ALL  ]    libtool: definition of this LT_INIT comes from an older release.
>>> [ALL  ]    libtool: You should recreate aclocal.m4 with macros from
>>> libtool 2.2.6 Debian-2.2.6a-1ubuntu1
>>> [ALL  ]    libtool: and run autoconf again.
>>> [ERROR]    make[1]: *** [names.lo] Error 1
>>> [ALL  ]    ./libtool: line 1144: func_opt_split: command not found
>>> [ALL  ]    libtool: Version mismatch error.  This is libtool 2.2.6
>>> Debian-2.2.6a-1ubuntu1, but the
>>> [ALL  ]    libtool: definition of this LT_INIT comes from an older release.
>>> [ALL  ]    libtool: You should recreate aclocal.m4 with macros from
>>> libtool 2.2.6 Debian-2.2.6a-1ubuntu1
>>> [ALL  ]    libtool: and run autoconf again.
>>> [ERROR]    make[1]: *** [loop.lo] Error 1
>>> [ALL  ]    make[1]: Leaving directory
>>> `/home/zvivered/GNU/ct-ng-1.16.0/bin/.build/i686-nptl-linux-gnu/build/build-cloog-ppl-host-i686-build_pc-linux-gnu'
>>> [ERROR]
>>> [ERROR]  >>
>>> [ERROR]  >>  Build failed in step 'Installing CLooG/PPL for host'
>>> [ERROR]  >>        called in step '(top-level)'
>>> [ERROR]  >>
>>> [ERROR]  >>  Error happened in: CT_DoExecLog[scripts/functions@158]
>>> [ERROR]  >>        called from:
>>> do_cloog_backend[scripts/build/companion_libs/cloog.sh@111]
>>> [ERROR]  >>        called from:
>>> do_cloog_for_host[scripts/build/companion_libs/cloog.sh@72]
>>> [ERROR]  >>        called from: main[scripts/crosstool-NG.sh@598]
>>> [ERROR]  >>
>>> [ERROR]  >>  For more info on this error, look at the file: 'build.log'
>>> [ERROR]  >>  There is a list of known issues, some with workarounds, in:
>>> [ERROR]  >>
>>> '/home/zvivered/GNU/ct-ng-1.16.0/share/doc/crosstool-ng/ct-ng.1.16.0/B
>>> - Known issues.txt'
>>> [ERROR]
>>>
>>> I did not install libtool manually. I have one libtool installed by CENTOS:
>>> ltmain.sh (GNU libtool) 1.5.22 (1.1220.2.365 2005/12/18 22:14:06)
>>>
>>> I installed automake 1.10, autoconf 2.60 ***manually*** because
>>> crosstool-ng failed at earlier stages. (./configure, make, make
>>> install). But when I checked "companion tools", crosstool should
>>> ignore them. Am I right ?
>>>
>>> Can you help ?
>>>
>>> Thanks,
>>> Zvika
>>>
>>>
>>> On Sun, Oct 7, 2012 at 3:24 AM, Bryan Hundven <[hidden email]> wrote:
>>>> Zvika
>>>>
>>>> On Sat, Oct 6, 2012 at 4:23 PM, Zvi Vered <[hidden email]> wrote:
>>>>> Hi Bryan,
>>>>>
>>>>> Did you mean:
>>>>> ./configure --prefix=$HOME/GNU/ct-ng-1.16.0 --without-automake
>>>>> --without-libtool --without-libtoolize
>>>>> ?
>>>>
>>>> No, It's in 'ct-ng menuconfig'. You should find it under the
>>>> "companion tools" menu.
>>>>
>>>>> But now I got the following error:
>>>>>
>>>>> Already extracted 'linux-3.4.7'
>>>>> [DEBUG]    Already patched 'linux-3.4.7'
>>>>> [DEBUG]    Already extracted 'gmp-4.3.2'
>>>>> [DEBUG]    Already patched 'gmp-4.3.2'
>>>>> [DEBUG]    Already extracted 'mpfr-2.4.2'
>>>>> [DEBUG]    Already patched 'mpfr-2.4.2'
>>>>> [DEBUG]    Running autoreconf
>>>>> [DEBUG]    ==> Executing: 'autoreconf'
>>>>> [ERROR]    acinclude.m4:26: error: Autoconf version 2.60 or higher is required
>>>>> [ALL  ]    acinclude.m4:26: the top level
>>>>> [ALL  ]    autom4te: /usr/bin/m4 failed with exit status: 63
>>>>> [ALL  ]    aclocal: autom4te failed with exit status: 63
>>>>> [ALL  ]    autoreconf: aclocal failed with exit status: 63
>>>>> [ERROR]
>>>>>
>>>>> I ran "yum install autoconf" and it installs autoconf 2.59
>>>>>
>>>>> What autoconf should I install and how ?
>>>>>
>>>>> Thanks,
>>>>> Zvika
>>>>>
>>>>> On Sat, Oct 6, 2012 at 9:05 PM, Bryan Hundven <[hidden email]> wrote:
>>>>>> Zvi,
>>>>>>
>>>>>> On Sat, Oct 6, 2012 at 12:02 PM, Zvi Vered <[hidden email]> wrote:
>>>>>>> Dear Mr. Hundven,
>>>>>>
>>>>>> My name is Bryan. ;)
>>>>>>
>>>>>>>
>>>>>>> How can I set ct-ng to use "companion tools bundled with ct-ng" ?
>>>>>>
>>>>>> Read the documentation:
>>>>>>
>>>>>> http://crosstool-ng.org/hg/crosstool-ng/raw-file/43ace4bb005e/docs/3%20-%20Configuring%20a%20toolchain.txt
>>>>>>
>>>>>>> The output of "libtool --version" is:
>>>>>>> ltmain.sh (GNU libtool) 1.5.22 (1.1220.2.365 2005/12/18 22:14:06)
>>>>>>> I used "yum install" to install it.
>>>>>>>
>>>>>>> This is weird. According to .configure --help, the minimum libtool
>>>>>>> version should be:
>>>>>>>  1.5.26
>>>>>>> But running .configure does not alert on a libtool problem.
>>>>>>> Can this cause the problem ?
>>>>>>>
>>>>>>> I tried pastebin but I should be a PRO user to paste all build.log
>>>>>>>
>>>>>>> You help is highly appreciated.
>>>>>>>
>>>>>>> Thanks,
>>>>>>> Zvika
>>>>>>>
>>>>>>> On Sat, Oct 6, 2012 at 10:10 AM, Bryan Hundven <[hidden email]> wrote:
>>>>>>>> On Fri, Oct 5, 2012 at 10:14 PM, Zvi Vered <[hidden email]> wrote:
>>>>>>>>> Hello,
>>>>>>>>>
>>>>>>>>> I'm using crosstool-ng 1.16.0 to create a toolchain for
>>>>>>>>> "i686-nptl-linux-gnu" under centos 5.3
>>>>>>>>>
>>>>>>>>> I got the following error:
>>>>>>>>>
>>>>>>>>> [ALL  ]    ./libtool: line 466: CDPATH: command not found
>>>>>>>>> [ALL  ]    ./libtool: line 466: CDPATH: command not found
>>>>>>>>> [ALL  ]    ./libtool: line 1144: func_opt_split: command not found
>>>>>>>>> [ALL  ]    libtool: Version mismatch error.  This is libtool 2.2.6
>>>>>>>>> Debian-2.2.6a-1ubuntu1, but the
>>>>>>>>> [ALL  ]    libtool: definition of this LT_INIT comes from an older release.
>>>>>>>>> [ALL  ]    libtool: You should recreate aclocal.m4 with macros from
>>>>>>>>> libtool 2.2.6 Debian-2.2.6a-1ubuntu1
>>>>>>>>> [ALL  ]    libtool: and run autoconf again.
>>>>>>>>> [ERROR]    make[1]: *** [loop.lo] Error 1
>>>>>>>>> [ALL  ]    make[1]: *** Waiting for unfinished jobs....
>>>>>>>>> [ALL  ]    ./libtool: line 466: CDPATH: command not found
>>>>>>>>> [ALL  ]    ./libtool: line 1144: func_opt_split: command not found
>>>>>>>>> [ALL  ]    libtool: Version mismatch error.  This is libtool 2.2.6
>>>>>>>>> Debian-2.2.6a-1ubuntu1, but the
>>>>>>>>> [ALL  ]    libtool: definition of this LT_INIT comes from an older release.
>>>>>>>>> [ALL  ]    libtool: You should recreate aclocal.m4 with macros from
>>>>>>>>> libtool 2.2.6 Debian-2.2.6a-1ubuntu1
>>>>>>>>> [ALL  ]    libtool: and run autoconf again.
>>>>>>>>> [ERROR]    make[1]: *** [block.lo] Error 1
>>>>>>>>> [ALL  ]    ./libtool: line 1144: func_opt_split: command not found
>>>>>>>>> [ALL  ]    libtool: Version mismatch error.  This is libtool 2.2.6
>>>>>>>>> Debian-2.2.6a-1ubuntu1, but the
>>>>>>>>> [ALL  ]    libtool: definition of this LT_INIT comes from an older release.
>>>>>>>>> [ALL  ]    libtool: You should recreate aclocal.m4 with macros from
>>>>>>>>> libtool 2.2.6 Debian-2.2.6a-1ubuntu1
>>>>>>>>> [ALL  ]    libtool: and run autoconf again.
>>>>>>>>> [ERROR]    make[1]: *** [names.lo] Error 1
>>>>>>>>> [ALL  ]    make[1]: Leaving directory
>>>>>>>>> `/home/zvivered/GNU/ct-ng-1.16.0/working/i686-nptl-linux-gnu/build/build-cloog-ppl-host-i686-build_pc-linux-gnu'
>>>>>>>>> [ERROR]
>>>>>>>>> [ERROR]  >>
>>>>>>>>> [ERROR]  >>  Build failed in step 'Installing CLooG/PPL for host'
>>>>>>>>> [ERROR]  >>        called in step '(top-level)'
>>>>>>>>> [ERROR]  >>
>>>>>>>>> [ERROR]  >>  Error happened in: CT_DoExecLog[scripts/functions@158]
>>>>>>>>> [ERROR]  >>        called from:
>>>>>>>>> do_cloog_backend[scripts/build/companion_libs/cloog.sh@111]
>>>>>>>>> [ERROR]  >>        called from:
>>>>>>>>> do_cloog_for_host[scripts/build/companion_libs/cloog.sh@72]
>>>>>>>>> [ERROR]  >>        called from: main[scripts/crosstool-NG.sh@598]
>>>>>>>>> [ERROR]  >>
>>>>>>>>> [ERROR]  >>  For more info on this error, look at the file: 'build.log'
>>>>>>>>> [ERROR]  >>  There is a list of known issues, some with workarounds, in:
>>>>>>>>> [ERROR]  >>
>>>>>>>>> '/home/zvivered/GNU/ct-ng-1.16.0/share/doc/crosstool-ng/ct-ng.1.16.0/B
>>>>>>>>> - Known issues.txt'
>>>>>>>>> [ERROR]
>>>>>>>>> [ERROR]  (elapsed: 6:05.48)
>>>>>>>>>
>>>>>>>>> Attached config.ng (copy of .config).
>>>>>>>>>
>>>>>>>>> Can you help find the problem ?
>>>>>>>>>
>>>>>>>>> Thanks,
>>>>>>>>> Zvika
>>>>>>>>>
>>>>>>>>> --
>>>>>>>>> For unsubscribe information see http://sourceware.org/lists.html#faq
>>>>>>>>
>>>>>>>> Zvi,
>>>>>>>>
>>>>>>>> Having the full log - posted to pastebin, or similar site, or hosted
>>>>>>>> on some other web site to save space on the mailing list - would also
>>>>>>>> be very helpful in this situation.
>>>>>>>>
>>>>>>>> From what I read, it looks like you have two different versions of
>>>>>>>> libtool in the same path!?! weird!
>>>>>>>>
>>>>>>>> Have you tried cloog 0.15.11?
>>>>>>>>
>>>>>>>> As I said in my previous message about automake, try using the
>>>>>>>> companion tools bundled with ct-ng.
>>>>>>>> ( http://sourceware.org/ml/crossgcc/2012-10/msg00014.html )
>>>>>>>>
>>>>>>>>># CT_COMP_TOOLS is not set
>>>>>>>>
>>>>>>>> Not all systems are compatible with ct-ng, which is why we provide m4,
>>>>>>>> autoconf, automake, libtool, and make.
>>>>>>>>
>>>>>>>> Also, this only seems to be a problem with cloog-ppl, have you also
>>>>>>>> tried google searching around for similar cloog build errors? This
>>>>>>>> doesn't look like it would be specific to crosstool-ng, but having the
>>>>>>>> full build log might prove that otherwise.
>>>>>>>>
>>>>>>>> -Bryan
>>>>>>
>>>>>> -Bryan
>>>>
>>>> -Bryan

--
For unsubscribe information see http://sourceware.org/lists.html#faq

Reply | Threaded
Open this post in threaded view
|

Re: crosstool-ng 1.16.0: libtool problem

zvivered
Hi Bryan,

I found in Google similar threads.
Do you think it will be solved soon ?
Or should I upgrade my CENTOS to 6.x and hope for better results ?

Thanks,
Zvika.

-----Original Message-----
From: Bryan Hundven
Sent: Sunday, October 07, 2012 8:18 AM
To: Zvi Vered
Cc: [hidden email]
Subject: Re: crosstool-ng 1.16.0: libtool problem

On Sat, Oct 6, 2012 at 11:12 PM, Zvi Vered <[hidden email]> wrote:
> Hi Bryan,
>
> I just sent the file using https://www.transferbigfiles.com.

I have posted the build.log here:
http://bryanhundven.com/zvi-build.log

for anyone else to view it.

-Bryan

> Thanks,
> Zvika
>
> On Sun, Oct 7, 2012 at 6:27 AM, Bryan Hundven <[hidden email]>
> wrote:
>> On Sat, Oct 6, 2012 at 8:38 PM, Zvi Vered <[hidden email]> wrote:
>>> Hi Bryan,
>>>
>>> Attached the new .config
>>> Now I got the following error:
>>
>> Zvika,
>>
>> Please post the full log to pastebin or similar site.
>>
>> Thanks,
>>
>> -Bryan
>>
>>> [ALL  ]    ./libtool: line 466: CDPATH: command not found
>>> [ALL  ]    ./libtool: line 466: CDPATH: command not found
>>> [ALL  ]    ./libtool: line 1144: func_opt_split: command not found
>>> [ALL  ]    libtool: Version mismatch error.  This is libtool 2.2.6
>>> Debian-2.2.6a-1ubuntu1, but the
>>> [ALL  ]    libtool: definition of this LT_INIT comes from an older
>>> release.
>>> [ALL  ]    libtool: You should recreate aclocal.m4 with macros from
>>> libtool 2.2.6 Debian-2.2.6a-1ubuntu1
>>> [ALL  ]    libtool: and run autoconf again.
>>> [ERROR]    make[1]: *** [block.lo] Error 1
>>> [ALL  ]    make[1]: *** Waiting for unfinished jobs....
>>> [ALL  ]    ./libtool: line 466: CDPATH: command not found
>>> [ALL  ]    ./libtool: line 1144: func_opt_split: command not found
>>> [ALL  ]    libtool: Version mismatch error.  This is libtool 2.2.6
>>> Debian-2.2.6a-1ubuntu1, but the
>>> [ALL  ]    libtool: definition of this LT_INIT comes from an older
>>> release.
>>> [ALL  ]    libtool: You should recreate aclocal.m4 with macros from
>>> libtool 2.2.6 Debian-2.2.6a-1ubuntu1
>>> [ALL  ]    libtool: and run autoconf again.
>>> [ERROR]    make[1]: *** [names.lo] Error 1
>>> [ALL  ]    ./libtool: line 1144: func_opt_split: command not found
>>> [ALL  ]    libtool: Version mismatch error.  This is libtool 2.2.6
>>> Debian-2.2.6a-1ubuntu1, but the
>>> [ALL  ]    libtool: definition of this LT_INIT comes from an older
>>> release.
>>> [ALL  ]    libtool: You should recreate aclocal.m4 with macros from
>>> libtool 2.2.6 Debian-2.2.6a-1ubuntu1
>>> [ALL  ]    libtool: and run autoconf again.
>>> [ERROR]    make[1]: *** [loop.lo] Error 1
>>> [ALL  ]    make[1]: Leaving directory
>>> `/home/zvivered/GNU/ct-ng-1.16.0/bin/.build/i686-nptl-linux-gnu/build/build-cloog-ppl-host-i686-build_pc-linux-gnu'
>>> [ERROR]
>>> [ERROR]  >>
>>> [ERROR]  >>  Build failed in step 'Installing CLooG/PPL for host'
>>> [ERROR]  >>        called in step '(top-level)'
>>> [ERROR]  >>
>>> [ERROR]  >>  Error happened in: CT_DoExecLog[scripts/functions@158]
>>> [ERROR]  >>        called from:
>>> do_cloog_backend[scripts/build/companion_libs/cloog.sh@111]
>>> [ERROR]  >>        called from:
>>> do_cloog_for_host[scripts/build/companion_libs/cloog.sh@72]
>>> [ERROR]  >>        called from: main[scripts/crosstool-NG.sh@598]
>>> [ERROR]  >>
>>> [ERROR]  >>  For more info on this error, look at the file: 'build.log'
>>> [ERROR]  >>  There is a list of known issues, some with workarounds, in:
>>> [ERROR]  >>
>>> '/home/zvivered/GNU/ct-ng-1.16.0/share/doc/crosstool-ng/ct-ng.1.16.0/B
>>> - Known issues.txt'
>>> [ERROR]
>>>
>>> I did not install libtool manually. I have one libtool installed by
>>> CENTOS:
>>> ltmain.sh (GNU libtool) 1.5.22 (1.1220.2.365 2005/12/18 22:14:06)
>>>
>>> I installed automake 1.10, autoconf 2.60 ***manually*** because
>>> crosstool-ng failed at earlier stages. (./configure, make, make
>>> install). But when I checked "companion tools", crosstool should
>>> ignore them. Am I right ?
>>>
>>> Can you help ?
>>>
>>> Thanks,
>>> Zvika
>>>
>>>
>>> On Sun, Oct 7, 2012 at 3:24 AM, Bryan Hundven <[hidden email]>
>>> wrote:
>>>> Zvika
>>>>
>>>> On Sat, Oct 6, 2012 at 4:23 PM, Zvi Vered <[hidden email]> wrote:
>>>>> Hi Bryan,
>>>>>
>>>>> Did you mean:
>>>>> ./configure --prefix=$HOME/GNU/ct-ng-1.16.0 --without-automake
>>>>> --without-libtool --without-libtoolize
>>>>> ?
>>>>
>>>> No, It's in 'ct-ng menuconfig'. You should find it under the
>>>> "companion tools" menu.
>>>>
>>>>> But now I got the following error:
>>>>>
>>>>> Already extracted 'linux-3.4.7'
>>>>> [DEBUG]    Already patched 'linux-3.4.7'
>>>>> [DEBUG]    Already extracted 'gmp-4.3.2'
>>>>> [DEBUG]    Already patched 'gmp-4.3.2'
>>>>> [DEBUG]    Already extracted 'mpfr-2.4.2'
>>>>> [DEBUG]    Already patched 'mpfr-2.4.2'
>>>>> [DEBUG]    Running autoreconf
>>>>> [DEBUG]    ==> Executing: 'autoreconf'
>>>>> [ERROR]    acinclude.m4:26: error: Autoconf version 2.60 or higher is
>>>>> required
>>>>> [ALL  ]    acinclude.m4:26: the top level
>>>>> [ALL  ]    autom4te: /usr/bin/m4 failed with exit status: 63
>>>>> [ALL  ]    aclocal: autom4te failed with exit status: 63
>>>>> [ALL  ]    autoreconf: aclocal failed with exit status: 63
>>>>> [ERROR]
>>>>>
>>>>> I ran "yum install autoconf" and it installs autoconf 2.59
>>>>>
>>>>> What autoconf should I install and how ?
>>>>>
>>>>> Thanks,
>>>>> Zvika
>>>>>
>>>>> On Sat, Oct 6, 2012 at 9:05 PM, Bryan Hundven <[hidden email]>
>>>>> wrote:
>>>>>> Zvi,
>>>>>>
>>>>>> On Sat, Oct 6, 2012 at 12:02 PM, Zvi Vered <[hidden email]>
>>>>>> wrote:
>>>>>>> Dear Mr. Hundven,
>>>>>>
>>>>>> My name is Bryan. ;)
>>>>>>
>>>>>>>
>>>>>>> How can I set ct-ng to use "companion tools bundled with ct-ng" ?
>>>>>>
>>>>>> Read the documentation:
>>>>>>
>>>>>> http://crosstool-ng.org/hg/crosstool-ng/raw-file/43ace4bb005e/docs/3%20-%20Configuring%20a%20toolchain.txt
>>>>>>
>>>>>>> The output of "libtool --version" is:
>>>>>>> ltmain.sh (GNU libtool) 1.5.22 (1.1220.2.365 2005/12/18 22:14:06)
>>>>>>> I used "yum install" to install it.
>>>>>>>
>>>>>>> This is weird. According to .configure --help, the minimum libtool
>>>>>>> version should be:
>>>>>>>  1.5.26
>>>>>>> But running .configure does not alert on a libtool problem.
>>>>>>> Can this cause the problem ?
>>>>>>>
>>>>>>> I tried pastebin but I should be a PRO user to paste all build.log
>>>>>>>
>>>>>>> You help is highly appreciated.
>>>>>>>
>>>>>>> Thanks,
>>>>>>> Zvika
>>>>>>>
>>>>>>> On Sat, Oct 6, 2012 at 10:10 AM, Bryan Hundven
>>>>>>> <[hidden email]> wrote:
>>>>>>>> On Fri, Oct 5, 2012 at 10:14 PM, Zvi Vered <[hidden email]>
>>>>>>>> wrote:
>>>>>>>>> Hello,
>>>>>>>>>
>>>>>>>>> I'm using crosstool-ng 1.16.0 to create a toolchain for
>>>>>>>>> "i686-nptl-linux-gnu" under centos 5.3
>>>>>>>>>
>>>>>>>>> I got the following error:
>>>>>>>>>
>>>>>>>>> [ALL  ]    ./libtool: line 466: CDPATH: command not found
>>>>>>>>> [ALL  ]    ./libtool: line 466: CDPATH: command not found
>>>>>>>>> [ALL  ]    ./libtool: line 1144: func_opt_split: command not found
>>>>>>>>> [ALL  ]    libtool: Version mismatch error.  This is libtool 2.2.6
>>>>>>>>> Debian-2.2.6a-1ubuntu1, but the
>>>>>>>>> [ALL  ]    libtool: definition of this LT_INIT comes from an older
>>>>>>>>> release.
>>>>>>>>> [ALL  ]    libtool: You should recreate aclocal.m4 with macros
>>>>>>>>> from
>>>>>>>>> libtool 2.2.6 Debian-2.2.6a-1ubuntu1
>>>>>>>>> [ALL  ]    libtool: and run autoconf again.
>>>>>>>>> [ERROR]    make[1]: *** [loop.lo] Error 1
>>>>>>>>> [ALL  ]    make[1]: *** Waiting for unfinished jobs....
>>>>>>>>> [ALL  ]    ./libtool: line 466: CDPATH: command not found
>>>>>>>>> [ALL  ]    ./libtool: line 1144: func_opt_split: command not found
>>>>>>>>> [ALL  ]    libtool: Version mismatch error.  This is libtool 2.2.6
>>>>>>>>> Debian-2.2.6a-1ubuntu1, but the
>>>>>>>>> [ALL  ]    libtool: definition of this LT_INIT comes from an older
>>>>>>>>> release.
>>>>>>>>> [ALL  ]    libtool: You should recreate aclocal.m4 with macros
>>>>>>>>> from
>>>>>>>>> libtool 2.2.6 Debian-2.2.6a-1ubuntu1
>>>>>>>>> [ALL  ]    libtool: and run autoconf again.
>>>>>>>>> [ERROR]    make[1]: *** [block.lo] Error 1
>>>>>>>>> [ALL  ]    ./libtool: line 1144: func_opt_split: command not found
>>>>>>>>> [ALL  ]    libtool: Version mismatch error.  This is libtool 2.2.6
>>>>>>>>> Debian-2.2.6a-1ubuntu1, but the
>>>>>>>>> [ALL  ]    libtool: definition of this LT_INIT comes from an older
>>>>>>>>> release.
>>>>>>>>> [ALL  ]    libtool: You should recreate aclocal.m4 with macros
>>>>>>>>> from
>>>>>>>>> libtool 2.2.6 Debian-2.2.6a-1ubuntu1
>>>>>>>>> [ALL  ]    libtool: and run autoconf again.
>>>>>>>>> [ERROR]    make[1]: *** [names.lo] Error 1
>>>>>>>>> [ALL  ]    make[1]: Leaving directory
>>>>>>>>> `/home/zvivered/GNU/ct-ng-1.16.0/working/i686-nptl-linux-gnu/build/build-cloog-ppl-host-i686-build_pc-linux-gnu'
>>>>>>>>> [ERROR]
>>>>>>>>> [ERROR]  >>
>>>>>>>>> [ERROR]  >>  Build failed in step 'Installing CLooG/PPL for host'
>>>>>>>>> [ERROR]  >>        called in step '(top-level)'
>>>>>>>>> [ERROR]  >>
>>>>>>>>> [ERROR]  >>  Error happened in:
>>>>>>>>> CT_DoExecLog[scripts/functions@158]
>>>>>>>>> [ERROR]  >>        called from:
>>>>>>>>> do_cloog_backend[scripts/build/companion_libs/cloog.sh@111]
>>>>>>>>> [ERROR]  >>        called from:
>>>>>>>>> do_cloog_for_host[scripts/build/companion_libs/cloog.sh@72]
>>>>>>>>> [ERROR]  >>        called from: main[scripts/crosstool-NG.sh@598]
>>>>>>>>> [ERROR]  >>
>>>>>>>>> [ERROR]  >>  For more info on this error, look at the file:
>>>>>>>>> 'build.log'
>>>>>>>>> [ERROR]  >>  There is a list of known issues, some with
>>>>>>>>> workarounds, in:
>>>>>>>>> [ERROR]  >>
>>>>>>>>> '/home/zvivered/GNU/ct-ng-1.16.0/share/doc/crosstool-ng/ct-ng.1.16.0/B
>>>>>>>>> - Known issues.txt'
>>>>>>>>> [ERROR]
>>>>>>>>> [ERROR]  (elapsed: 6:05.48)
>>>>>>>>>
>>>>>>>>> Attached config.ng (copy of .config).
>>>>>>>>>
>>>>>>>>> Can you help find the problem ?
>>>>>>>>>
>>>>>>>>> Thanks,
>>>>>>>>> Zvika
>>>>>>>>>
>>>>>>>>> --
>>>>>>>>> For unsubscribe information see
>>>>>>>>> http://sourceware.org/lists.html#faq
>>>>>>>>
>>>>>>>> Zvi,
>>>>>>>>
>>>>>>>> Having the full log - posted to pastebin, or similar site, or
>>>>>>>> hosted
>>>>>>>> on some other web site to save space on the mailing list - would
>>>>>>>> also
>>>>>>>> be very helpful in this situation.
>>>>>>>>
>>>>>>>> From what I read, it looks like you have two different versions of
>>>>>>>> libtool in the same path!?! weird!
>>>>>>>>
>>>>>>>> Have you tried cloog 0.15.11?
>>>>>>>>
>>>>>>>> As I said in my previous message about automake, try using the
>>>>>>>> companion tools bundled with ct-ng.
>>>>>>>> ( http://sourceware.org/ml/crossgcc/2012-10/msg00014.html )
>>>>>>>>
>>>>>>>>># CT_COMP_TOOLS is not set
>>>>>>>>
>>>>>>>> Not all systems are compatible with ct-ng, which is why we provide
>>>>>>>> m4,
>>>>>>>> autoconf, automake, libtool, and make.
>>>>>>>>
>>>>>>>> Also, this only seems to be a problem with cloog-ppl, have you also
>>>>>>>> tried google searching around for similar cloog build errors? This
>>>>>>>> doesn't look like it would be specific to crosstool-ng, but having
>>>>>>>> the
>>>>>>>> full build log might prove that otherwise.
>>>>>>>>
>>>>>>>> -Bryan
>>>>>>
>>>>>> -Bryan
>>>>
>>>> -Bryan


--
For unsubscribe information see http://sourceware.org/lists.html#faq

Reply | Threaded
Open this post in threaded view
|

Re: crosstool-ng 1.16.0: libtool problem

zvivered
In reply to this post by Bryan Hundven
Dear Members,

I managed to create the toolchain via buildroot 2012.08 which is
integrated with crosstool-ng 1.16.0

The only change I had to do manually is to set glibc version to 2.13
(instead 2.14.1)
With 2.14.1 I got the following error:

configure: WARNING: cpuid.h: present but cannot be compiled
[CFG  ]    configure: WARNING: cpuid.h:     check for missing
prerequisite headers?
[CFG  ]    configure: WARNING: cpuid.h: see the Autoconf documentation
[CFG  ]    configure: WARNING: cpuid.h:     section "Present But
Cannot Be Compiled"
[CFG  ]    configure: WARNING: cpuid.h: proceeding with the compiler's result
[CFG  ]    checking for cpuid.h... no
[ERROR]    configure: error: gcc must provide the <cpuid.h> header
[ERROR]

There are some articles about this problem in glibc 2.14.1

Thanks,
Zvika

On Sun, Oct 7, 2012 at 8:18 AM, Bryan Hundven <[hidden email]> wrote:

> On Sat, Oct 6, 2012 at 11:12 PM, Zvi Vered <[hidden email]> wrote:
>> Hi Bryan,
>>
>> I just sent the file using https://www.transferbigfiles.com.
>
> I have posted the build.log here:
> http://bryanhundven.com/zvi-build.log
>
> for anyone else to view it.
>
> -Bryan
>
>> Thanks,
>> Zvika
>>
>> On Sun, Oct 7, 2012 at 6:27 AM, Bryan Hundven <[hidden email]> wrote:
>>> On Sat, Oct 6, 2012 at 8:38 PM, Zvi Vered <[hidden email]> wrote:
>>>> Hi Bryan,
>>>>
>>>> Attached the new .config
>>>> Now I got the following error:
>>>
>>> Zvika,
>>>
>>> Please post the full log to pastebin or similar site.
>>>
>>> Thanks,
>>>
>>> -Bryan
>>>
>>>> [ALL  ]    ./libtool: line 466: CDPATH: command not found
>>>> [ALL  ]    ./libtool: line 466: CDPATH: command not found
>>>> [ALL  ]    ./libtool: line 1144: func_opt_split: command not found
>>>> [ALL  ]    libtool: Version mismatch error.  This is libtool 2.2.6
>>>> Debian-2.2.6a-1ubuntu1, but the
>>>> [ALL  ]    libtool: definition of this LT_INIT comes from an older release.
>>>> [ALL  ]    libtool: You should recreate aclocal.m4 with macros from
>>>> libtool 2.2.6 Debian-2.2.6a-1ubuntu1
>>>> [ALL  ]    libtool: and run autoconf again.
>>>> [ERROR]    make[1]: *** [block.lo] Error 1
>>>> [ALL  ]    make[1]: *** Waiting for unfinished jobs....
>>>> [ALL  ]    ./libtool: line 466: CDPATH: command not found
>>>> [ALL  ]    ./libtool: line 1144: func_opt_split: command not found
>>>> [ALL  ]    libtool: Version mismatch error.  This is libtool 2.2.6
>>>> Debian-2.2.6a-1ubuntu1, but the
>>>> [ALL  ]    libtool: definition of this LT_INIT comes from an older release.
>>>> [ALL  ]    libtool: You should recreate aclocal.m4 with macros from
>>>> libtool 2.2.6 Debian-2.2.6a-1ubuntu1
>>>> [ALL  ]    libtool: and run autoconf again.
>>>> [ERROR]    make[1]: *** [names.lo] Error 1
>>>> [ALL  ]    ./libtool: line 1144: func_opt_split: command not found
>>>> [ALL  ]    libtool: Version mismatch error.  This is libtool 2.2.6
>>>> Debian-2.2.6a-1ubuntu1, but the
>>>> [ALL  ]    libtool: definition of this LT_INIT comes from an older release.
>>>> [ALL  ]    libtool: You should recreate aclocal.m4 with macros from
>>>> libtool 2.2.6 Debian-2.2.6a-1ubuntu1
>>>> [ALL  ]    libtool: and run autoconf again.
>>>> [ERROR]    make[1]: *** [loop.lo] Error 1
>>>> [ALL  ]    make[1]: Leaving directory
>>>> `/home/zvivered/GNU/ct-ng-1.16.0/bin/.build/i686-nptl-linux-gnu/build/build-cloog-ppl-host-i686-build_pc-linux-gnu'
>>>> [ERROR]
>>>> [ERROR]  >>
>>>> [ERROR]  >>  Build failed in step 'Installing CLooG/PPL for host'
>>>> [ERROR]  >>        called in step '(top-level)'
>>>> [ERROR]  >>
>>>> [ERROR]  >>  Error happened in: CT_DoExecLog[scripts/functions@158]
>>>> [ERROR]  >>        called from:
>>>> do_cloog_backend[scripts/build/companion_libs/cloog.sh@111]
>>>> [ERROR]  >>        called from:
>>>> do_cloog_for_host[scripts/build/companion_libs/cloog.sh@72]
>>>> [ERROR]  >>        called from: main[scripts/crosstool-NG.sh@598]
>>>> [ERROR]  >>
>>>> [ERROR]  >>  For more info on this error, look at the file: 'build.log'
>>>> [ERROR]  >>  There is a list of known issues, some with workarounds, in:
>>>> [ERROR]  >>
>>>> '/home/zvivered/GNU/ct-ng-1.16.0/share/doc/crosstool-ng/ct-ng.1.16.0/B
>>>> - Known issues.txt'
>>>> [ERROR]
>>>>
>>>> I did not install libtool manually. I have one libtool installed by CENTOS:
>>>> ltmain.sh (GNU libtool) 1.5.22 (1.1220.2.365 2005/12/18 22:14:06)
>>>>
>>>> I installed automake 1.10, autoconf 2.60 ***manually*** because
>>>> crosstool-ng failed at earlier stages. (./configure, make, make
>>>> install). But when I checked "companion tools", crosstool should
>>>> ignore them. Am I right ?
>>>>
>>>> Can you help ?
>>>>
>>>> Thanks,
>>>> Zvika
>>>>
>>>>
>>>> On Sun, Oct 7, 2012 at 3:24 AM, Bryan Hundven <[hidden email]> wrote:
>>>>> Zvika
>>>>>
>>>>> On Sat, Oct 6, 2012 at 4:23 PM, Zvi Vered <[hidden email]> wrote:
>>>>>> Hi Bryan,
>>>>>>
>>>>>> Did you mean:
>>>>>> ./configure --prefix=$HOME/GNU/ct-ng-1.16.0 --without-automake
>>>>>> --without-libtool --without-libtoolize
>>>>>> ?
>>>>>
>>>>> No, It's in 'ct-ng menuconfig'. You should find it under the
>>>>> "companion tools" menu.
>>>>>
>>>>>> But now I got the following error:
>>>>>>
>>>>>> Already extracted 'linux-3.4.7'
>>>>>> [DEBUG]    Already patched 'linux-3.4.7'
>>>>>> [DEBUG]    Already extracted 'gmp-4.3.2'
>>>>>> [DEBUG]    Already patched 'gmp-4.3.2'
>>>>>> [DEBUG]    Already extracted 'mpfr-2.4.2'
>>>>>> [DEBUG]    Already patched 'mpfr-2.4.2'
>>>>>> [DEBUG]    Running autoreconf
>>>>>> [DEBUG]    ==> Executing: 'autoreconf'
>>>>>> [ERROR]    acinclude.m4:26: error: Autoconf version 2.60 or higher is required
>>>>>> [ALL  ]    acinclude.m4:26: the top level
>>>>>> [ALL  ]    autom4te: /usr/bin/m4 failed with exit status: 63
>>>>>> [ALL  ]    aclocal: autom4te failed with exit status: 63
>>>>>> [ALL  ]    autoreconf: aclocal failed with exit status: 63
>>>>>> [ERROR]
>>>>>>
>>>>>> I ran "yum install autoconf" and it installs autoconf 2.59
>>>>>>
>>>>>> What autoconf should I install and how ?
>>>>>>
>>>>>> Thanks,
>>>>>> Zvika
>>>>>>
>>>>>> On Sat, Oct 6, 2012 at 9:05 PM, Bryan Hundven <[hidden email]> wrote:
>>>>>>> Zvi,
>>>>>>>
>>>>>>> On Sat, Oct 6, 2012 at 12:02 PM, Zvi Vered <[hidden email]> wrote:
>>>>>>>> Dear Mr. Hundven,
>>>>>>>
>>>>>>> My name is Bryan. ;)
>>>>>>>
>>>>>>>>
>>>>>>>> How can I set ct-ng to use "companion tools bundled with ct-ng" ?
>>>>>>>
>>>>>>> Read the documentation:
>>>>>>>
>>>>>>> http://crosstool-ng.org/hg/crosstool-ng/raw-file/43ace4bb005e/docs/3%20-%20Configuring%20a%20toolchain.txt
>>>>>>>
>>>>>>>> The output of "libtool --version" is:
>>>>>>>> ltmain.sh (GNU libtool) 1.5.22 (1.1220.2.365 2005/12/18 22:14:06)
>>>>>>>> I used "yum install" to install it.
>>>>>>>>
>>>>>>>> This is weird. According to .configure --help, the minimum libtool
>>>>>>>> version should be:
>>>>>>>>  1.5.26
>>>>>>>> But running .configure does not alert on a libtool problem.
>>>>>>>> Can this cause the problem ?
>>>>>>>>
>>>>>>>> I tried pastebin but I should be a PRO user to paste all build.log
>>>>>>>>
>>>>>>>> You help is highly appreciated.
>>>>>>>>
>>>>>>>> Thanks,
>>>>>>>> Zvika
>>>>>>>>
>>>>>>>> On Sat, Oct 6, 2012 at 10:10 AM, Bryan Hundven <[hidden email]> wrote:
>>>>>>>>> On Fri, Oct 5, 2012 at 10:14 PM, Zvi Vered <[hidden email]> wrote:
>>>>>>>>>> Hello,
>>>>>>>>>>
>>>>>>>>>> I'm using crosstool-ng 1.16.0 to create a toolchain for
>>>>>>>>>> "i686-nptl-linux-gnu" under centos 5.3
>>>>>>>>>>
>>>>>>>>>> I got the following error:
>>>>>>>>>>
>>>>>>>>>> [ALL  ]    ./libtool: line 466: CDPATH: command not found
>>>>>>>>>> [ALL  ]    ./libtool: line 466: CDPATH: command not found
>>>>>>>>>> [ALL  ]    ./libtool: line 1144: func_opt_split: command not found
>>>>>>>>>> [ALL  ]    libtool: Version mismatch error.  This is libtool 2.2.6
>>>>>>>>>> Debian-2.2.6a-1ubuntu1, but the
>>>>>>>>>> [ALL  ]    libtool: definition of this LT_INIT comes from an older release.
>>>>>>>>>> [ALL  ]    libtool: You should recreate aclocal.m4 with macros from
>>>>>>>>>> libtool 2.2.6 Debian-2.2.6a-1ubuntu1
>>>>>>>>>> [ALL  ]    libtool: and run autoconf again.
>>>>>>>>>> [ERROR]    make[1]: *** [loop.lo] Error 1
>>>>>>>>>> [ALL  ]    make[1]: *** Waiting for unfinished jobs....
>>>>>>>>>> [ALL  ]    ./libtool: line 466: CDPATH: command not found
>>>>>>>>>> [ALL  ]    ./libtool: line 1144: func_opt_split: command not found
>>>>>>>>>> [ALL  ]    libtool: Version mismatch error.  This is libtool 2.2.6
>>>>>>>>>> Debian-2.2.6a-1ubuntu1, but the
>>>>>>>>>> [ALL  ]    libtool: definition of this LT_INIT comes from an older release.
>>>>>>>>>> [ALL  ]    libtool: You should recreate aclocal.m4 with macros from
>>>>>>>>>> libtool 2.2.6 Debian-2.2.6a-1ubuntu1
>>>>>>>>>> [ALL  ]    libtool: and run autoconf again.
>>>>>>>>>> [ERROR]    make[1]: *** [block.lo] Error 1
>>>>>>>>>> [ALL  ]    ./libtool: line 1144: func_opt_split: command not found
>>>>>>>>>> [ALL  ]    libtool: Version mismatch error.  This is libtool 2.2.6
>>>>>>>>>> Debian-2.2.6a-1ubuntu1, but the
>>>>>>>>>> [ALL  ]    libtool: definition of this LT_INIT comes from an older release.
>>>>>>>>>> [ALL  ]    libtool: You should recreate aclocal.m4 with macros from
>>>>>>>>>> libtool 2.2.6 Debian-2.2.6a-1ubuntu1
>>>>>>>>>> [ALL  ]    libtool: and run autoconf again.
>>>>>>>>>> [ERROR]    make[1]: *** [names.lo] Error 1
>>>>>>>>>> [ALL  ]    make[1]: Leaving directory
>>>>>>>>>> `/home/zvivered/GNU/ct-ng-1.16.0/working/i686-nptl-linux-gnu/build/build-cloog-ppl-host-i686-build_pc-linux-gnu'
>>>>>>>>>> [ERROR]
>>>>>>>>>> [ERROR]  >>
>>>>>>>>>> [ERROR]  >>  Build failed in step 'Installing CLooG/PPL for host'
>>>>>>>>>> [ERROR]  >>        called in step '(top-level)'
>>>>>>>>>> [ERROR]  >>
>>>>>>>>>> [ERROR]  >>  Error happened in: CT_DoExecLog[scripts/functions@158]
>>>>>>>>>> [ERROR]  >>        called from:
>>>>>>>>>> do_cloog_backend[scripts/build/companion_libs/cloog.sh@111]
>>>>>>>>>> [ERROR]  >>        called from:
>>>>>>>>>> do_cloog_for_host[scripts/build/companion_libs/cloog.sh@72]
>>>>>>>>>> [ERROR]  >>        called from: main[scripts/crosstool-NG.sh@598]
>>>>>>>>>> [ERROR]  >>
>>>>>>>>>> [ERROR]  >>  For more info on this error, look at the file: 'build.log'
>>>>>>>>>> [ERROR]  >>  There is a list of known issues, some with workarounds, in:
>>>>>>>>>> [ERROR]  >>
>>>>>>>>>> '/home/zvivered/GNU/ct-ng-1.16.0/share/doc/crosstool-ng/ct-ng.1.16.0/B
>>>>>>>>>> - Known issues.txt'
>>>>>>>>>> [ERROR]
>>>>>>>>>> [ERROR]  (elapsed: 6:05.48)
>>>>>>>>>>
>>>>>>>>>> Attached config.ng (copy of .config).
>>>>>>>>>>
>>>>>>>>>> Can you help find the problem ?
>>>>>>>>>>
>>>>>>>>>> Thanks,
>>>>>>>>>> Zvika
>>>>>>>>>>
>>>>>>>>>> --
>>>>>>>>>> For unsubscribe information see http://sourceware.org/lists.html#faq
>>>>>>>>>
>>>>>>>>> Zvi,
>>>>>>>>>
>>>>>>>>> Having the full log - posted to pastebin, or similar site, or hosted
>>>>>>>>> on some other web site to save space on the mailing list - would also
>>>>>>>>> be very helpful in this situation.
>>>>>>>>>
>>>>>>>>> From what I read, it looks like you have two different versions of
>>>>>>>>> libtool in the same path!?! weird!
>>>>>>>>>
>>>>>>>>> Have you tried cloog 0.15.11?
>>>>>>>>>
>>>>>>>>> As I said in my previous message about automake, try using the
>>>>>>>>> companion tools bundled with ct-ng.
>>>>>>>>> ( http://sourceware.org/ml/crossgcc/2012-10/msg00014.html )
>>>>>>>>>
>>>>>>>>>># CT_COMP_TOOLS is not set
>>>>>>>>>
>>>>>>>>> Not all systems are compatible with ct-ng, which is why we provide m4,
>>>>>>>>> autoconf, automake, libtool, and make.
>>>>>>>>>
>>>>>>>>> Also, this only seems to be a problem with cloog-ppl, have you also
>>>>>>>>> tried google searching around for similar cloog build errors? This
>>>>>>>>> doesn't look like it would be specific to crosstool-ng, but having the
>>>>>>>>> full build log might prove that otherwise.
>>>>>>>>>
>>>>>>>>> -Bryan
>>>>>>>
>>>>>>> -Bryan
>>>>>
>>>>> -Bryan

--
For unsubscribe information see http://sourceware.org/lists.html#faq