configtool under wxp + cygwin fails

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

configtool under wxp + cygwin fails

Bob Brusa
Hi,
because I had unsurmountable problems when I tried to build an ecos
library for my AT91sam7x-based board on Windows 7-64 with a recent
installation of cygwin, I went back to my old PC which runs under
Windows XPpro and a cygwin dating back to February 2010.

I was able to build a library from a ecos 2010-checkout from anonymous
cvs using configtool of ecos-3.0. When I tried the same with a current
ecos anonymous cvs checkout it failed. Excerpt from the output:
===============================================================
..cut
make -r -C hal/arm/arch/current arm.inc
make[1]: Entering directory
`/usr/lib/icb_ecoslib_2_build/hal/arm/arch/current'
arm-eabi-gcc -finline-limit=7000 -Wall -Wpointer-arith
-Wstrict-prototypes -Wundef  -Wno-write-strings -mno-thumb-interwork
-mcpu=arm7tdmi -g -O2 -ffunction-sections -fdata-sections
-fno-exceptions  -I/usr/lib/icb_ecoslib_2_install/include
-I/opt/ecos/packages/hal/arm/arch/current
-I/opt/ecos/packages/hal/arm/arch/current/src
-I/opt/ecos/packages/hal/arm/arch/current/tests -I. -Wp,-MD,arm.tmp -o
hal_mk_defs.tmp -S /opt/ecos/packages/hal/arm/arch/current/src/hal_mk_defs.c
/opt/ecos/packages/hal/arm/arch/current/src/hal_mk_defs.c:54:25: error:
pkgconf/hal.h: No such file or directory
In file included from
/usr/lib/icb_ecoslib_2_install/include/cyg/hal/hal_intr.h:76,
                  from
/opt/ecos/packages/hal/arm/arch/current/src/hal_mk_defs.c:57:
/usr/lib/icb_ecoslib_2_install/include/cyg/hal/hal_platform_ints.h:59:38: error:
pkgconf/hal_arm_at91sam7.h: No such file or directory
cut.....
====================================================================
The strange thing about the above is, that all these files it can not
find do actually exist and can be found in
<path2mylib_install>/include/pkgconf and this directory pkgconf is the
only entry in the include directory.

On the other hand, the <path2mylib_build> is empty.


Then I got a more recent version of configtools (ecos-tools-bin-120425).
When launching it with the cygwin-terminal nothing happens. Whenn
launching it by double-clicking on the icon the error message

Der Procedureeinsprungspunkt "__assert_func" wurde in der DLL
"cygwin1.dll" nicht gefunden.

Can someone give me a hint how to work around/solve these problems?
Thanks and best regards,
Robert

--
Before posting, please read the FAQ: http://ecos.sourceware.org/fom/ecos
and search the list archive: http://ecos.sourceware.org/ml/ecos-discuss