configtool does not find its database

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

configtool does not find its database

Bob Brusa
Hi,
this is a better version - meaning spelling errors and missing parts fix
- of a previous mail.
++++++++++++
I installed ecos on a windows 10.64/cygwin (32-bit) computer. When
starting up configtool, it reports the following:

ecos.db:error
    couldn't read file "/opt/ecos/ecos_cvs/ecos/packages/ecos.db": no
such file or directory

but the root of the eCos repository is correct:

D:\osy\cygwin\opt\ecos\ecos_cvs\ecos

and the file packages/ecos.db exists.

It seems to be a problem of a missing translation from a windows path to
a posix path or vice versa. How does one fix this?
Regards - Bob

--
Before posting, please read the FAQ: http://ecos.sourceware.org/fom/ecos
and search the list archive: http://ecos.sourceware.org/ml/ecos-discuss

Reply | Threaded
Open this post in threaded view
|

Re: configtool does not find its database

Sergei Gavrikov-4
On Thu, 25 Feb 2016, Bob Brusa wrote:

> Hi,
> this is a better version - meaning spelling errors and missing parts fix - of
> a previous mail.
> ++++++++++++
> I installed ecos on a windows 10.64/cygwin (32-bit) computer. When starting up
> configtool, it reports the following:
>
> ecos.db:error
>    couldn't read file "/opt/ecos/ecos_cvs/ecos/packages/ecos.db": no such file
> or directory
>
> but the root of the eCos repository is correct:
>
> D:\osy\cygwin\opt\ecos\ecos_cvs\ecos
>
> and the file packages/ecos.db exists.
>
> It seems to be a problem of a missing translation from a windows path
> to a posix path or vice versa. How does one fix this?
> Regards - Bob

Hi Bob,

and what's about

  echo $ECOS_REPOSITORY
  cat "$ECOS_REPOSITORY/ecos.db"

Sergei

--
Before posting, please read the FAQ: http://ecos.sourceware.org/fom/ecos
and search the list archive: http://ecos.sourceware.org/ml/ecos-discuss

Reply | Threaded
Open this post in threaded view
|

Fwd: Re: [ECOS] configtool does not find its database

Bob Brusa

-------- Weitergeleitete Nachricht --------
Betreff: Re: [ECOS] configtool does not find its database
Datum: Sat, 27 Feb 2016 01:42:13 +0300 (MSK)
Von: Sergei Gavrikov <[hidden email]>
An: Bob Brusa <[hidden email]>
Kopie (CC): ecos discuss <[hidden email]>



On Thu, 25 Feb 2016, Bob Brusa wrote:

> Hi,
> this is a better version - meaning spelling errors and missing parts fix - of
> a previous mail.
> ++++++++++++
> I installed ecos on a windows 10.64/cygwin (32-bit) computer. When starting up
> configtool, it reports the following:
>
> ecos.db:error
>    couldn't read file "/opt/ecos/ecos_cvs/ecos/packages/ecos.db": no such file
> or directory
>
> but the root of the eCos repository is correct:
>
> D:\osy\cygwin\opt\ecos\ecos_cvs\ecos
>
> and the file packages/ecos.db exists.
>
> It seems to be a problem of a missing translation from a windows path
> to a posix path or vice versa. How does one fix this?
> Regards - Bob

Hi Bob,

and what's about

   echo $ECOS_REPOSITORY
   cat "$ECOS_REPOSITORY/ecos.db"

Sergei

Hi Sergei,
yes, the repository is defined and the database-file is there - see the
lines below, copied from cygwinTerminal:

Robert@w36 ~
$ echo $ECOS_REPOSITORY
/opt/ecos/ecos_cvs/ecos/packages

Robert@w36 ~
$ cd $ECOS_REPOSITORY

Robert@w36 /opt/ecos/ecos_cvs/ecos/packages
$ ls -a
.          compat  devs           error  infra     kernel NEWS     services
..         CVS     ecos.db        fs     io        language pkgconf  
templates
ChangeLog  cygmon  ecosadmin.tcl  hal    isoinfra  net redboot

ECOS_REPOSITORY is also part of the windows environment - copied from
windowsTerminal(cmd):
C:\Windows\System32>echo %ECOS_REPOSITORY%
D:\osy\cygwin\opt\ecos\ecos_cvs\ecos\packages

Meanwhile I also had some exchange with Alex Schuilenburg, but the
problem persists: When launching configtools.exe (with a double click on
a link on my desktop), configtools immediately runs on an error:
Error opening eCos repository: Invalid package database and in its log
windows it displays:

ecos.db: error
    could'nt read file "/opt/ecos/ecos_cvs/ecos/packages/ecos.db": no
such file or directory

otherwize, configtools other windows are empty. Clicking the error
windows away then opens a window to specify the root of the eCos
repository. However, the entry it displays is already correct:
D:\osy\cygwin\opt\ecos\ecos_cvs\ecos

and it does not help iwhen I change the path to
D:\osy\cygwin\opt\ecos\ecos_cvs\ecos\packages

Hence, the problem is yet unsolved.
Bob



--
Before posting, please read the FAQ: http://ecos.sourceware.org/fom/ecos
and search the list archive: http://ecos.sourceware.org/ml/ecos-discuss

Reply | Threaded
Open this post in threaded view
|

Re: Fwd: Re: configtool does not find its database

Grant Edwards-6
On 2016-02-27, Bob Brusa <[hidden email]> wrote:

> yes, the repository is defined and the database-file is there - see the
> lines below, copied from cygwinTerminal:
>
> Robert@w36 ~
> $ echo $ECOS_REPOSITORY
> /opt/ecos/ecos_cvs/ecos/packages

Are you sure that the ECOS_REPOSITORY variable has been exported?  If
not, then child processes (such as configtool) won't see it.

--
Grant




--
Before posting, please read the FAQ: http://ecos.sourceware.org/fom/ecos
and search the list archive: http://ecos.sourceware.org/ml/ecos-discuss