[commit/testsuite] Remove breakpoint/2080 setup_kfail in i386-prologue.exp

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

[commit/testsuite] Remove breakpoint/2080 setup_kfail in i386-prologue.exp

Joel Brobecker
Hello,

I noticed some KPASS while running i386-prologue.exp. I looked a bit
deeper, and it looks like the associated setup_kfail should be removed.
They have always been there since the tests were added, but the bug
they test was fixed almost at the same time...

Testcase: http://www.sourceware.org/ml/gdb-patches/2006-02/msg00293.html
Patch:    http://www.sourceware.org/ml/gdb-patches/2006-02/msg00302.html

2006-12-20  Joel Brobecker  <[hidden email]>

        * gdb.arch/i386-prologue.exp: Remove calls to setup_kfail.
        The associated tests should be PASSing.

Tested on x86-linux. It seems pretty obvious, unless I missed something.
Since it's easy to revert, I'll just apply the obvious rule and commit.

Thanks,
--
Joel

kfail.diff (1K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: [commit/testsuite] Remove breakpoint/2080 setup_kfail in i386-prologue.exp

Daniel Jacobowitz-2
On Wed, Dec 20, 2006 at 01:50:25PM +0400, Joel Brobecker wrote:
> Tested on x86-linux. It seems pretty obvious, unless I missed something.
> Since it's easy to revert, I'll just apply the obvious rule and commit.

Thanks, and this is fine.  I've just been running the testsuite on i686
again, for the first time in ages, and noticed these.

--
Daniel Jacobowitz
CodeSourcery