build/2095: gdb$(EXEEXT) target needs to depend and link in $(SUBDIR_MI_OBS)

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

build/2095: gdb$(EXEEXT) target needs to depend and link in $(SUBDIR_MI_OBS)

masariello

>Number:         2095
>Category:       build
>Synopsis:       gdb$(EXEEXT) target needs to depend and link in $(SUBDIR_MI_OBS)
>Confidential:   no
>Severity:       serious
>Priority:       high
>Responsible:    unassigned
>State:          open
>Class:          maintenance
>Submitter-Id:   net
>Arrival-Date:   Fri Mar 03 11:48:01 GMT 2006
>Closed-Date:
>Last-Modified:
>Originator:     [hidden email]
>Release:        6.4
>Organization:
>Environment:
Fedora Core 4 AMD64 cross building with gcc 4.0.2 i686
>Description:
the linker gives undef mi symbols for gdb$(EXEEXT)
gdb$(EXEEXT) target needs to depend and link in the $(SUBDIR_MI_OBS)
>How-To-Repeat:
Just use www.buildroot.org choosing gcc 4.0.2 and gdb 6.4.
>Fix:

>Release-Note:
>Audit-Trail:
>Unformatted:
Reply | Threaded
Open this post in threaded view
|

Re: build/2095: gdb$(EXEEXT) target needs to depend and link in $(SUBDIR_MI_OBS)

Daniel Jacobowitz-2
The following reply was made to PR build/2095; it has been noted by GNATS.

From: Daniel Jacobowitz <[hidden email]>
To: [hidden email]
Cc: [hidden email]
Subject: Re: build/2095: gdb$(EXEEXT) target needs to depend and link in $(SUBDIR_MI_OBS)
Date: Fri, 3 Mar 2006 09:46:49 -0500

 On Fri, Mar 03, 2006 at 11:43:56AM -0000, [hidden email] wrote:
 > Just use www.buildroot.org choosing gcc 4.0.2 and gdb 6.4.
 
 This is almost certainly a bug in buildroot, then.  Either it is
 using --disable-mi (don't do that) or the source package doesn't
 contain gdb/mi/.
 
 --
 Daniel Jacobowitz
 CodeSourcery