Triggering interrupt on the mpc5200 running eCos

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Triggering interrupt on the mpc5200 running eCos

Boni Jean
hi everybody!

i am working with the boa5200 evaluation board, which has an mpc5200 chip on
it.
i want an interrupt to be triggered, once i pull external pin /IRQ2 down
low.
I created an interrupt with the cyg_interrupt_create function, using the
vector
number 27 (from #define CYGNUM_HAL_INTERRUPT_IRQ2 which i found in
cyg/hal/var_intr.h).
I set the right bits in the Mpc5200's register MPC5XXX_ICTL_EENAB (in
cyg/hal/mpc5xxx).
The main problem is that i am not able to attach the interrupt to the global
interrupt
vector, using the cyg_interrupt_attach command. From debugging, i see that
the attach()
command calls the HAL_INTERRUPT_SET_LEVEL macro from intr.cxx
(in ecos/packages/kernel/current/src/intr.cxx). From there, it jumps to the
EMPTY function
cyg_hal_interrupt_set_level in var_intr.c (in
ecos/packages/hal/powerpc/mpc5xxx/current/src/var_intr.c).
It then jumps back to the macro HAL_INTERRUPT_IN_USE in the intr.cxx
function, then to the
macro HAL_INTERRUPT_ATTACH in intr.cxx, but nothing more is done.
I also checked out the mpc5200 register Main Interrupt Status All Register,
but
it does not indicate any pending interrupt, which means that the interrupt
has not been
attached.
please, HELP!!!!

-John-



--
Before posting, please read the FAQ: http://ecos.sourceware.org/fom/ecos
and search the list archive: http://ecos.sourceware.org/ml/ecos-discuss

Reply | Threaded
Open this post in threaded view
|

Re: Triggering interrupt on the mpc5200 running eCos

Alluitz
Hello,
I don´t speak English well and I don´t know if I have understood your
message correctly.
We are not working with the same board, but in our case interrupt
pending register is 1 only when we push the button and interruption
haven´t been yet. It is 1 since you push the button until interruption
is done.

We don´t understand well what does CYG_INTERRUPT_ATTACH.

To configure interrupt detecting method, you can use cyg_interrupt_configure.

Best regard,
Alluitz


2005/12/15, Boni Jean <[hidden email]>:

> hi everybody!
>
> i am working with the boa5200 evaluation board, which has an mpc5200 chip on
> it.
> i want an interrupt to be triggered, once i pull external pin /IRQ2 down
> low.
> I created an interrupt with the cyg_interrupt_create function, using the
> vector
> number 27 (from #define CYGNUM_HAL_INTERRUPT_IRQ2 which i found in
> cyg/hal/var_intr.h).
> I set the right bits in the Mpc5200's register MPC5XXX_ICTL_EENAB (in
> cyg/hal/mpc5xxx).
> The main problem is that i am not able to attach the interrupt to the global
> interrupt
> vector, using the cyg_interrupt_attach command. From debugging, i see that
> the attach()
> command calls the HAL_INTERRUPT_SET_LEVEL macro from intr.cxx
> (in ecos/packages/kernel/current/src/intr.cxx). From there, it jumps to the
> EMPTY function
> cyg_hal_interrupt_set_level in var_intr.c (in
> ecos/packages/hal/powerpc/mpc5xxx/current/src/var_intr.c).
> It then jumps back to the macro HAL_INTERRUPT_IN_USE in the intr.cxx
> function, then to the
> macro HAL_INTERRUPT_ATTACH in intr.cxx, but nothing more is done.
> I also checked out the mpc5200 register Main Interrupt Status All Register,
> but
> it does not indicate any pending interrupt, which means that the interrupt
> has not been
> attached.
> please, HELP!!!!
>
> -John-
>
>
>
> --
> Before posting, please read the FAQ: http://ecos.sourceware.org/fom/ecos
> and search the list archive: http://ecos.sourceware.org/ml/ecos-discuss
>
>

--
Before posting, please read the FAQ: http://ecos.sourceware.org/fom/ecos
and search the list archive: http://ecos.sourceware.org/ml/ecos-discuss