Redboot 1.92 for GRG

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

Redboot 1.92 for GRG

Augusto Salazar
Hello all,

Does anyone has the original srec image for the coyote
board, the version 1.92.

The one that enables to choose the network device in
the fconfig command.

If anyone has it, can you please email it to me?

Thanks a lot.

Augusto Salazar

AUGUSTO SALAZAR
MIEMBRO DE PIRATAS TM (COL)
CEL: +57 315 7340134.

__________________________________________________
Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around
http://mail.yahoo.com 

--
Before posting, please read the FAQ: http://ecos.sourceware.org/fom/ecos
and search the list archive: http://ecos.sourceware.org/ml/ecos-discuss

Reply | Threaded
Open this post in threaded view
|

Re: Redboot 1.92 for GRG

Mark Salter-2
On Sun, 2005-12-18 at 23:54 -0800, Augusto Salazar wrote:
> Hello all,
>
> Does anyone has the original srec image for the coyote
> board, the version 1.92.
>
> The one that enables to choose the network device in
> the fconfig command.

You'll need to see Intel for the NPE-enabled RedBoot. I don't
know if they still have 1.92 on the web site, but they do have
newer versions with the same functionality including source
code and prebuilt binaries.

--Mark



--
Before posting, please read the FAQ: http://ecos.sourceware.org/fom/ecos
and search the list archive: http://ecos.sourceware.org/ml/ecos-discuss

Reply | Threaded
Open this post in threaded view
|

RE: Redboot 1.92 for GRG

Abraham Celik
 Intel does have the older versions on their website. Look for the archived
versions.


Regards,

Abraham

-----Original Message-----
From: [hidden email]
[mailto:[hidden email]] On Behalf Of Mark Salter
Sent: Tuesday, 20 December 2005 1:10 AM
To: Augusto Salazar
Cc: ecos
Subject: Re: [ECOS] Redboot 1.92 for GRG

On Sun, 2005-12-18 at 23:54 -0800, Augusto Salazar wrote:
> Hello all,
>
> Does anyone has the original srec image for the coyote board, the
> version 1.92.
>
> The one that enables to choose the network device in the fconfig
> command.

You'll need to see Intel for the NPE-enabled RedBoot. I don't know if they
still have 1.92 on the web site, but they do have newer versions with the
same functionality including source code and prebuilt binaries.

--Mark



--
Before posting, please read the FAQ: http://ecos.sourceware.org/fom/ecos
and search the list archive: http://ecos.sourceware.org/ml/ecos-discuss




--
Before posting, please read the FAQ: http://ecos.sourceware.org/fom/ecos
and search the list archive: http://ecos.sourceware.org/ml/ecos-discuss

Reply | Threaded
Open this post in threaded view
|

RE: Redboot 1.92 for GRG

Augusto Salazar

Hello all,

Well, my root problem is that I have not been able to
set up the MAC or the default network device in my GRG
board.

I have tried in the version 2.02 and that option is
not even on the fconfig, in the version 1.94 that I
got from the intel page I get this:

RedBoot> fconfig -l
Run script at boot: false
Use BOOTP for network configuration: false
Gateway IP address: 0.0.0.0
Local IP address: 192.168.1.3
Local IP address mask: 255.255.255.0
Default server IP address: 192.168.1.2
Console baud rate: 115200
DNS server IP address: 0.0.0.0
GDB connection port: 9000
Force console for special debug messages: false
Network debug at boot time: false
net_device:
Request for config value '' - wrong type

Any idea how to get this option working?

Thanks in advance,

Augusto Salazar

--- Abraham Celik <[hidden email]> wrote:

>  Intel does have the older versions on their
> website. Look for the archived
> versions.
>
>
> Regards,
>
> Abraham
>
> -----Original Message-----
> From: [hidden email]
> [mailto:[hidden email]] On
> Behalf Of Mark Salter
> Sent: Tuesday, 20 December 2005 1:10 AM
> To: Augusto Salazar
> Cc: ecos
> Subject: Re: [ECOS] Redboot 1.92 for GRG
>
> On Sun, 2005-12-18 at 23:54 -0800, Augusto Salazar
> wrote:
> > Hello all,
> >
> > Does anyone has the original srec image for the
> coyote board, the
> > version 1.92.
> >
> > The one that enables to choose the network device
> in the fconfig
> > command.
>
> You'll need to see Intel for the NPE-enabled
> RedBoot. I don't know if they
> still have 1.92 on the web site, but they do have
> newer versions with the
> same functionality including source code and
> prebuilt binaries.
>
> --Mark
>
>
>
> --
> Before posting, please read the FAQ:
> http://ecos.sourceware.org/fom/ecos
> and search the list archive:
> http://ecos.sourceware.org/ml/ecos-discuss
>
>
>
>
> --
> Before posting, please read the FAQ:
> http://ecos.sourceware.org/fom/ecos
> and search the list archive:
> http://ecos.sourceware.org/ml/ecos-discuss
>
>


AUGUSTO SALAZAR
MIEMBRO DE PIRATAS TM (COL)
CEL: +57 315 7340134.

__________________________________________________
Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around
http://mail.yahoo.com 

--
Before posting, please read the FAQ: http://ecos.sourceware.org/fom/ecos
and search the list archive: http://ecos.sourceware.org/ml/ecos-discuss

Reply | Threaded
Open this post in threaded view
|

RE: Redboot 1.92 for GRG

Mark Salter-2
On Mon, 2005-12-19 at 17:27 -0800, Augusto Salazar wrote:

> Hello all,
>
> Well, my root problem is that I have not been able to
> set up the MAC or the default network device in my GRG
> board.
>
> I have tried in the version 2.02 and that option is
> not even on the fconfig, in the version 1.94 that I
> got from the intel page I get this:
>
> RedBoot> fconfig -l
> Run script at boot: false
> Use BOOTP for network configuration: false
> Gateway IP address: 0.0.0.0
> Local IP address: 192.168.1.3
> Local IP address mask: 255.255.255.0
> Default server IP address: 192.168.1.2
> Console baud rate: 115200
> DNS server IP address: 0.0.0.0
> GDB connection port: 9000
> Force console for special debug messages: false
> Network debug at boot time: false
> net_device:
> Request for config value '' - wrong type
>
> Any idea how to get this option working?

Do you get the "net_device" option if you "fconfig -i"?
It looks like you're running a RedBoot with no NPE support
on a board that once ran an NPE-enabled RedBoot. All it
takes to get "net_device" working is to have more than one
eth driver builtin to RedBoot.

--Mark




--
Before posting, please read the FAQ: http://ecos.sourceware.org/fom/ecos
and search the list archive: http://ecos.sourceware.org/ml/ecos-discuss

Reply | Threaded
Open this post in threaded view
|

RE: Redboot 1.92 for GRG

Augusto Salazar

Hello,

Thanks Mark for your comment.

Yes, I guees that my problem was that, I had only
support for the i82559 on the redboot.
So, I recompiled the 2.02 version including the
grg_npe and problem solved.

Thanks a lot again.

Augusto Salazar.

--- Mark Salter <[hidden email]> wrote:

> On Mon, 2005-12-19 at 17:27 -0800, Augusto Salazar
> wrote:
> > Hello all,
> >
> > Well, my root problem is that I have not been able
> to
> > set up the MAC or the default network device in my
> GRG
> > board.
> >
> > I have tried in the version 2.02 and that option
> is
> > not even on the fconfig, in the version 1.94 that
> I
> > got from the intel page I get this:
> >
> > RedBoot> fconfig -l
> > Run script at boot: false
> > Use BOOTP for network configuration: false
> > Gateway IP address: 0.0.0.0
> > Local IP address: 192.168.1.3
> > Local IP address mask: 255.255.255.0
> > Default server IP address: 192.168.1.2
> > Console baud rate: 115200
> > DNS server IP address: 0.0.0.0
> > GDB connection port: 9000
> > Force console for special debug messages: false
> > Network debug at boot time: false
> > net_device:
> > Request for config value '' - wrong type
> >
> > Any idea how to get this option working?
>
> Do you get the "net_device" option if you "fconfig
> -i"?
> It looks like you're running a RedBoot with no NPE
> support
> on a board that once ran an NPE-enabled RedBoot. All
> it
> takes to get "net_device" working is to have more
> than one
> eth driver builtin to RedBoot.
>
> --Mark
>
>
>
>
> --
> Before posting, please read the FAQ:
> http://ecos.sourceware.org/fom/ecos
> and search the list archive:
> http://ecos.sourceware.org/ml/ecos-discuss
>
>


AUGUSTO SALAZAR
MIEMBRO DE PIRATAS TM (COL)
CEL: +57 315 7340134.

__________________________________________________
Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around
http://mail.yahoo.com 

--
Before posting, please read the FAQ: http://ecos.sourceware.org/fom/ecos
and search the list archive: http://ecos.sourceware.org/ml/ecos-discuss