Re: newbie - PB startup with Adder875

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Re: newbie - PB startup with Adder875

damien lefort
>
>
>On Tue, Dec 27, 2005 at 06:22:15PM +0100, damien lefort wrote:
>> Hi,
>>
>> I try to run the sample test "basic" from ecos distribution on Adder-875
>> (MPC875).
>> I use the A&M distribution for configuration.
>> I've generated the binary withour error but I can't execute the
>> generated code (only som incoherent chars on console). I've tried with
>> gdb and I got SIGEVT and nothing more.
>> The board works well for RedBoot and also with the Linux installed in
>> the flash.
>>
>> What can I do?
>>
>> Thanks
>>
>>
>> ====trace from console
>> RedBoot(tm) bootstrap and debug environment [ROMRAM]
>> A&M certified release, version 2005-09-07-RELEASE - built 19:59:38, Sep
>> 14 2005
>>
>> Platform: A&M Adder (PowerPC 875)
>> Copyright (C) 2003, 2004, 2005, Analogue & Micro, Ltd.
>> Copyright (C) 2000, 2001, 2002, 2003, 2004 Red Hat, Inc.
>>
>> RAM: 0x00000000-0x01000000, [0x00053270-0x00fe1000] available
>> FLASH: 0xfe000000 - 0xfe800000, 128 blocks of 0x00010000 bytes each.
>> RedBoot> load basic
>> Using default protocol (TFTP)
>> Entry point: 0x00060000, address range: 0x00060000-0x00068cbc
>> RedBoot> go 0x60000
>> D.p.tpzppppqppp{pqzppp.p{Cv.D.p.tpzppppqppp{pqzppp.p{Cv.D.p.tpzppppqppp{pqzppp..
>
>This could be a baud rate problem?
>
>        Andrew
>

I don't think so cause gdb announce fatal error and chars are sent by
eval board without any char sent from console.

Damien.

--

Damien LEFORT
[hidden email]
7, rue de Bièvres - 92140 CLAMART
tel 01 47 36 82 08
mob 06 66 65 48 19





--
Before posting, please read the FAQ: http://ecos.sourceware.org/fom/ecos
and search the list archive: http://ecos.sourceware.org/ml/ecos-discuss

Reply | Threaded
Open this post in threaded view
|

Re: Re: newbie - PB startup with Adder875

Andrew Lunn-2
On Thu, Jan 05, 2006 at 06:31:30PM +0100, damien lefort wrote:

> >
> >
> >On Tue, Dec 27, 2005 at 06:22:15PM +0100, damien lefort wrote:
> >>Hi,
> >>
> >>I try to run the sample test "basic" from ecos distribution on Adder-875
> >>(MPC875).
> >>I use the A&M distribution for configuration.
> >>I've generated the binary withour error but I can't execute the
> >>generated code (only som incoherent chars on console). I've tried with
> >>gdb and I got SIGEVT and nothing more.
> >>The board works well for RedBoot and also with the Linux installed in
> >>the flash.
> >>
> >>What can I do?
> >>
> >>Thanks
> >>
> >>
> >>====trace from console
> >>RedBoot(tm) bootstrap and debug environment [ROMRAM]
> >>A&M certified release, version 2005-09-07-RELEASE - built 19:59:38, Sep
> >>14 2005
> >>
> >>Platform: A&M Adder (PowerPC 875)
> >>Copyright (C) 2003, 2004, 2005, Analogue & Micro, Ltd.
> >>Copyright (C) 2000, 2001, 2002, 2003, 2004 Red Hat, Inc.
> >>
> >>RAM: 0x00000000-0x01000000, [0x00053270-0x00fe1000] available
> >>FLASH: 0xfe000000 - 0xfe800000, 128 blocks of 0x00010000 bytes each.
> >>RedBoot> load basic
> >>Using default protocol (TFTP)
> >>Entry point: 0x00060000, address range: 0x00060000-0x00068cbc
> >>RedBoot> go 0x60000
> >>D.p.tpzppppqppp{pqzppp.p{Cv.D.p.tpzppppqppp{pqzppp.p{Cv.D.p.tpzppppqppp{pqzppp..
> >
> >This could be a baud rate problem?
> >
> >       Andrew
> >
>
> I don't think so cause gdb announce fatal error and chars are sent by
> eval board without any char sent from console.

But if it has crashed the gdb stub will output a string telling you
where it has crashed. Im guessing that that gibberish you see is that
string, but at the wrong baud rate.

        Andrew


--
Before posting, please read the FAQ: http://ecos.sourceware.org/fom/ecos
and search the list archive: http://ecos.sourceware.org/ml/ecos-discuss