Problem with 100% CPU and fan running

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Problem with 100% CPU and fan running

nickfox
I'm running a demo I found on sourceforge:

http://vrp.sourceforge.net/

and when I first start up the demo, the fan on my XP service pack 3 machine starts running. When I run the app, the CPU pegs to 100%. The demo is using pthreads.

Is there a way to keep this from happening?

thanks
Nick
Reply | Threaded
Open this post in threaded view
|

Re: Problem with 100% CPU and fan running

Ross Johnson-2
Hello Nick,

Any reason to suspect the pthreads-win32 library especially? Generally
it's designed not to cause continuous CPU load (with one exception on
SMP machines being pthread_spin_lock, but which is intended only for
very short duration locks).

Have you reported this to the VRP developers?

Regards.
Ross

nickfox wrote:

> I'm running a demo I found on sourceforge:
>
> http://vrp.sourceforge.net/
>
> and when I first start up the demo, the fan on my XP service pack 3 machine
> starts running. When I run the app, the CPU pegs to 100%. The demo is using
> pthreads.
>
> Is there a way to keep this from happening?
>
> thanks
> Nick
>  

Reply | Threaded
Open this post in threaded view
|

Re: Problem with 100% CPU and fan running

nickfox
Hi Ross

Thanks for responding. I do have a dual core AMD processor. And as far as suspecting pthreads, it was just my first guess. I don't think there is anything wrong with pthreads. I think it's maybe the program logic and how the threading is being used. I honestly don't know. As you probably have figured out, my knowledge of threading is not that strong.

I'm not sure how to isolate the problem. Do you have any suggestions?

thanks
Nick

Ross Johnson-2 wrote
Hello Nick,

Any reason to suspect the pthreads-win32 library especially? Generally
it's designed not to cause continuous CPU load (with one exception on
SMP machines being pthread_spin_lock, but which is intended only for
very short duration locks).

Have you reported this to the VRP developers?

Regards.
Ross

nickfox wrote:
> I'm running a demo I found on sourceforge:
>
> http://vrp.sourceforge.net/
>
> and when I first start up the demo, the fan on my XP service pack 3 machine
> starts running. When I run the app, the CPU pegs to 100%. The demo is using
> pthreads.
>
> Is there a way to keep this from happening?
>
> thanks
> Nick
>