PR 16017: New ld testsuite failure

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

PR 16017: New ld testsuite failure

Sourceware - binutils list mailing list
Hi Tamar,

  I have just started seeing this new failure in the linker testsuite:

    exited abnormally with 0, output:objdump: tmpdir/dump(.rel.plt): relocation 0 has invalid symbol index 14885104
    FAIL: Thumb only PLT and GOT

  This is for a toolchain configured as "arm-nacl".  Would you mind
  taking a look and deciding on the appropriate action ?

Cheers
  Nick

Reply | Threaded
Open this post in threaded view
|

RE: PR 16017: New ld testsuite failure

Tamar Christina-2
Hi Nick,

Sorry about that, didn't know about that target at all..

Seems it doesn't support dynamic linking so I'll check in a patch to skip it as the rest of the testsuite does under the trivial rule.

Cheers,
Tamar

> -----Original Message-----
> From: Nick Clifton <[hidden email]>
> Sent: Wednesday, April 1, 2020 5:20 PM
> To: Tamar Christina <[hidden email]>
> Cc: [hidden email]
> Subject: PR 16017: New ld testsuite failure
>
> Hi Tamar,
>
>   I have just started seeing this new failure in the linker testsuite:
>
>     exited abnormally with 0, output:objdump: tmpdir/dump(.rel.plt):
> relocation 0 has invalid symbol index 14885104
>     FAIL: Thumb only PLT and GOT
>
>   This is for a toolchain configured as "arm-nacl".  Would you mind
>   taking a look and deciding on the appropriate action ?
>
> Cheers
>   Nick