Missing 'ecos/host' and 'ecos/images' when doing an anonymous CVS checkout

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Missing 'ecos/host' and 'ecos/images' when doing an anonymous CVS checkout

Bernard Fouché
Hi there,

while performing a full CVS checkout to check my local eCos repo with
the sourceware CVS repo, using anonymous CVS ("cvs -z3 -d
:pserver:[hidden email]:/cvs/ecos co -P ecos"), I don't get
'ecos/host' and 'ecos/images', while I still can see them on
http://ecos.sourceware.org/cgi-bin/cvsweb.cgi/ecos/?cvsroot=ecos . Is it
normal?

Thanks,

   Bernard


--
Before posting, please read the FAQ: http://ecos.sourceware.org/fom/ecos
and search the list archive: http://ecos.sourceware.org/ml/ecos-discuss

Reply | Threaded
Open this post in threaded view
|

Re: Missing 'ecos/host' and 'ecos/images' when doing an anonymous CVS checkout

Bernard Fouché
Le 31/10/2013 11:07, Bernard Fouché a écrit :

> Hi there,
>
> while performing a full CVS checkout to check my local eCos repo with
> the sourceware CVS repo, using anonymous CVS ("cvs -z3 -d
> :pserver:[hidden email]:/cvs/ecos co -P ecos"), I don't
> get 'ecos/host' and 'ecos/images', while I still can see them on
> http://ecos.sourceware.org/cgi-bin/cvsweb.cgi/ecos/?cvsroot=ecos . Is
> it normal?
>
> Thanks,
>
>   Bernard
>
There is also
http://ecos.sourceware.org/cgi-bin/cvsweb.cgi/ecos/packages/services/curses/pdcurses/current/examples/?cvsroot=ecos 
which isn't downloaded when doing the CVS checkout.

   Bernard


--
Before posting, please read the FAQ: http://ecos.sourceware.org/fom/ecos
and search the list archive: http://ecos.sourceware.org/ml/ecos-discuss

Reply | Threaded
Open this post in threaded view
|

Re: Missing 'ecos/host' and 'ecos/images' when doing an anonymous CVS checkout

Bernard Fouché
Le 31/10/2013 11:38, Bernard Fouché a écrit :

> Le 31/10/2013 11:07, Bernard Fouché a écrit :
>> Hi there,
>>
>> while performing a full CVS checkout to check my local eCos repo with
>> the sourceware CVS repo, using anonymous CVS ("cvs -z3 -d
>> :pserver:[hidden email]:/cvs/ecos co -P ecos"), I don't
>> get 'ecos/host' and 'ecos/images', while I still can see them on
>> http://ecos.sourceware.org/cgi-bin/cvsweb.cgi/ecos/?cvsroot=ecos . Is
>> it normal?
> There is also
> http://ecos.sourceware.org/cgi-bin/cvsweb.cgi/ecos/packages/services/curses/pdcurses/current/examples/?cvsroot=ecos 
> which isn't downloaded when doing the CVS checkout.
Oops, sorry, the last one missing it seems:
http://ecos.sourceware.org/cgi-bin/cvsweb.cgi/ecos/doc/sgml/tutorials/?cvsroot=ecos


--
Before posting, please read the FAQ: http://ecos.sourceware.org/fom/ecos
and search the list archive: http://ecos.sourceware.org/ml/ecos-discuss

Reply | Threaded
Open this post in threaded view
|

Re: Missing 'ecos/host' and 'ecos/images' when doing an anonymous CVS checkout

John Dallaway-2
In reply to this post by Bernard Fouché
Hi Bernard

On 31/10/13 10:07, Bernard Fouché wrote:

> while performing a full CVS checkout to check my local eCos repo with
> the sourceware CVS repo, using anonymous CVS ("cvs -z3 -d
> :pserver:[hidden email]:/cvs/ecos co -P ecos"), I don't get
> 'ecos/host' and 'ecos/images', while I still can see them on
> http://ecos.sourceware.org/cgi-bin/cvsweb.cgi/ecos/?cvsroot=ecos . Is it
> normal?

The "ecos" parameter you have specified on the CVS checkout command line
is a CVS module name. The "ecos" module does not include the ecos/host/
and ecos/images/ directories. If you wish to checkout everything under
the ecos/ directory, try the "ecos-full" module.

I hope this helps...

John Dallaway
eCos maintainer
http://www.dallaway.org.uk/john

--
Before posting, please read the FAQ: http://ecos.sourceware.org/fom/ecos
and search the list archive: http://ecos.sourceware.org/ml/ecos-discuss