LD_POINTER_GUARD, and binary compatibility

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

LD_POINTER_GUARD, and binary compatibility

Yuval Kfir
Is the environment variable LD_POINTER_GUARD documented anywhere? My
library messes around with the jmp_buf structure a little, and its
behaviour has changed in glibc 2.4.  LD_POINTER_GUARD seems to restore
the old behaviour of setjmp/longjmp, but I want to understand what else
it does and what else I might be breaking.

Also: while Googling for information on LD_POINTER_GUARD I came across
the statement that glibc-2.5 is binary incompatible with glibc-2.4 (and,
by implication, earlier releases).  Is that correct?  If I have
libraries built and linked with glibc-2.3, will I not be able to link
them and run them safely on a machine with glibc-2.5?

- Yuval