Insight for Cygwin

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Insight for Cygwin

Pavel Fedin
 Hello! I have succesfully built Insight for modern 64-bit Cygwin. I have
built it using preinstalled tcl/tk and itcl/itk libraries. However i have
problem running it. The only output i get is:
--- cut ---
Error: version conflict for package "Itk": have 3.3, need 3.4
--- cut ---
 The same error message is displayed in an opened X window. This is very
interesting because gdb/gdbtk/library/main.tcl file says:
--- cut ---
foreach p {{Tcl 8.4} {Tk 8.4} {Itcl 3.3} {Itk 3.3} {Iwidgets 4.0} {Gdbtk
1.0} {combobox 2.2} {debug 1.0}} {
--- cut ---
 So, it does not ask for Itk 3.4. How to determine who does this ? Installed
Itk version is really 3.3-2. Can it be Cygwin's bug ? Itcl version is 3.4-1.
 

Kind regards,
Pavel Fedin
Expert Engineer
Samsung Electronics Research center Russia