Glibc : Probem at configure glibc

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

Glibc : Probem at configure glibc

SandeepKsinha
Hello everyone,


I am  trying to compile glibc2.3.5 on Red Hat 9.0(2.4.20-8) on a x86
machine with
binutilies 2.16.1 installed on it but i am are getting an error :


.....
checking for stdint.h... yes
checking for unistd.h... yes
checking for long double... yes
checking size of long double... 12
running configure fragment for sysdeps/i386/elf
checking for i386 TLS support... yes
running configure fragment for nptl/sysdeps/unix/sysv/linux
running configure fragment for nptl/sysdeps/pthread
checking for forced unwind support... no
configure: error: forced unwind support is required


.....


Can any body direct us how to proceed further ?




--
Regards,
Sandeep





A candle loses nothing if it is used to light another one!

Reply | Threaded
Open this post in threaded view
|

Re: Glibc : Probem at configure glibc

Jakub Jelinek
On Sat, Jan 07, 2006 at 09:14:02PM -0800, Sandeep Kumar wrote:

> Hello everyone,
>
>
> I am  trying to compile glibc2.3.5 on Red Hat 9.0(2.4.20-8) on a x86
> machine with
> binutilies 2.16.1 installed on it but i am are getting an error :
>
>
> .....
> checking for stdint.h... yes
> checking for unistd.h... yes
> checking for long double... yes
> checking size of long double... 12
> running configure fragment for sysdeps/i386/elf
> checking for i386 TLS support... yes
> running configure fragment for nptl/sysdeps/unix/sysv/linux
> running configure fragment for nptl/sysdeps/pthread
> checking for forced unwind support... no
> configure: error: forced unwind support is required
>
>
> .....
>
>
> Can any body direct us how to proceed further ?

Your gcc (particularly libgcc_s.so.1) is too old.
You are much better to upgrade to a contemporary distro rather than trying
to use selected contemporary components with 3 years old distro.

        Jakub

Reply | Threaded
Open this post in threaded view
|

Re: Glibc : Probem at configure glibc

SandeepKsinha
On 1/7/06, Jakub Jelinek <[hidden email]> wrote:

> On Sat, Jan 07, 2006 at 09:14:02PM -0800, Sandeep Kumar wrote:
> > Hello everyone,
> >
> >
> > I am  trying to compile glibc2.3.5 on Red Hat 9.0(2.4.20-8) on a x86
> > machine with
> > binutilies 2.16.1 installed on it but i am are getting an error :
> >
> >
> > .....
> > checking for stdint.h... yes
> > checking for unistd.h... yes
> > checking for long double... yes
> > checking size of long double... 12
> > running configure fragment for sysdeps/i386/elf
> > checking for i386 TLS support... yes
> > running configure fragment for nptl/sysdeps/unix/sysv/linux
> > running configure fragment for nptl/sysdeps/pthread
> > checking for forced unwind support... no
> > configure: error: forced unwind support is required
> >
> >
> > .....
> >
> >
> > Can any body direct us how to proceed further ?
>
> Your gcc (particularly libgcc_s.so.1) is too old.
> You are much better to upgrade to a contemporary distro rather than trying
> to use selected contemporary components with 3 years old distro.
>
True , its an older one. But does it really makes a difference ?


--
Regards,
Sandeep





A candle loses nothing if it is used to light another one!

Reply | Threaded
Open this post in threaded view
|

Re: Glibc : Probem at configure glibc

Jakub Jelinek
On Sat, Jan 07, 2006 at 09:51:24PM -0800, Sandeep Kumar wrote:
> > Your gcc (particularly libgcc_s.so.1) is too old.
> > You are much better to upgrade to a contemporary distro rather than trying
> > to use selected contemporary components with 3 years old distro.
> >
> True , its an older one. But does it really makes a difference ?

Of course it does, e.g. _Unwind_GetCFA function which NPTL relies on
was introduced in GCC CVS 2003-04-02 and backported also to GCC 3.3
and RHEL3 gcc 3.2.3-RH.  But RHL9 GCC is older than that.

        Jakub

Reply | Threaded
Open this post in threaded view
|

Re: Glibc : Probem at configure glibc

Paviee
Hello.
I am also facing the same problem of: "Unwind support"
My Linux version is 2.4.20-8
I just built gcc 4.2.2 and installed it also. Even upgraded binutils to 2.18...

Basically I am trying to upgrade glibc to 2.7...
Any Ideas what is wrong...

Jakub Jelinek wrote
On Sat, Jan 07, 2006 at 09:51:24PM -0800, Sandeep Kumar wrote:
> > Your gcc (particularly libgcc_s.so.1) is too old.
> > You are much better to upgrade to a contemporary distro rather than trying
> > to use selected contemporary components with 3 years old distro.
> >
> True , its an older one. But does it really makes a difference ?

Of course it does, e.g. _Unwind_GetCFA function which NPTL relies on
was introduced in GCC CVS 2003-04-02 and backported also to GCC 3.3
and RHEL3 gcc 3.2.3-RH.  But RHL9 GCC is older than that.

        Jakub
Reply | Threaded
Open this post in threaded view
|

Re: Glibc : Probem at configure glibc

Kurt Roeckx
On Sat, Dec 08, 2007 at 06:32:15AM -0800, Paviee wrote:
>
> Hello.
> I am also facing the same problem of: "Unwind support"
> My Linux version is 2.4.20-8
> I just built gcc 4.2.2 and installed it also. Even upgraded binutils to
> 2.18...
>
> Basically I am trying to upgrade glibc to 2.7...
> Any Ideas what is wrong...

I think your problem is that you're running a 2.4 kernel.  As far as I
know glibc no longer supports linuxthreads and now uses NPTL which is
only available in the 2.6 kernel.


Kurt