GDB dropping support for mips-irix and alpha-tru64

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

GDB dropping support for mips-irix and alpha-tru64

Joel Brobecker
Dear all,

The GDB project is planning on removing support for the following
platforms:
  - MIPS IRIX (mips*-sgi-irix5*, mips*-sgi-irix6*)
  - Alpha Tru64 (alpha*-*-osf*)
This only affect code maintained by GDB project (not binutils or GCC).
Also, support for any other target on MIPS (including embedded ones)
will be maintained as is.

As of GDB 7.8, our latest release, we hope that GDB will build and work.
But we currently have no report of anyone who has tried it, so we do not
know for sure.

If you are still using a recent GDB on either of these platforms,
and would like to step up to continue maintaining either of them,
please let us know. We have been maintaining them as best we can
up to now, but we have reached a point where this is becoming
too difficult and/or more effort that anyone is willing to invest.

As per our "Obsoleting Code Procedures"
(https://sourceware.org/gdb/wiki/Internals%20Obsoleting-code),
these platforms will be declared unsupported a week from now.
If you are interested in maintaining either port, please contact
us immediately, even if you the deadline is past or even if
you are not sure.

Thank you,
--
Joel