Error in glibc configure

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Error in glibc configure

khushboo chandak
Hi,
   I am getting error while configuring Glibc-2.5 with NPTL support
for big endian target.

Glibc is configured using following option:

CC="sh4eb-linux-gcc -mb -m4"
/ashay/eb-toolchain/src/glibc-2.5/configure --host=sh4eb-linux
--prefix=/ashay/eb-toolchain/run/ --build=i686-linux
--enable-add-ons=nptl --enable-kernel=2.6.17 --with-tls
--with-__threads --without-cvs --disable-debug --disable-profile
--disable-sanity-checks
--with-headers=/home/khushbooc/newtoolchain/src/linux-2.6.17/include/
--without-fp

The error i am getting is:

running configure fragment for nptl/sysdeps/pthread
configure: error: compiler support for __thread is required

Can you please help me in resolving this error.

Thanks in advance
Khushboo Chandak