Configuration Tool binaries

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Configuration Tool binaries

Michele Portolan
Hi everyone,
does anyone knows where I can found binaries for the Ecos Configuration Tool (windows) for a version later than 2.11?
I am using eCos with Leon and the new version of the toolchain (rtem-4.6) requires gcc to be added the flag -qleon2 and the version I have now (2.11) does not permit to change flags. Or maybe is just me who does not know how to do it?
Thank you very much,

Michele


--
Before posting, please read the FAQ: http://ecos.sourceware.org/fom/ecos
and search the list archive: http://ecos.sourceware.org/ml/ecos-discuss

Reply | Threaded
Open this post in threaded view
|

Re: Configuration Tool binaries

Andrew Lunn-2
On Tue, Jan 10, 2006 at 10:07:01AM +0100, Michele Portolan wrote:
> Hi everyone,
> does anyone knows where I can found binaries for the Ecos Configuration
> Tool (windows) for a version later than 2.11? I am using eCos with Leon and
> the new version of the toolchain (rtem-4.6) requires gcc to be added the
> flag -qleon2 and the version I have now (2.11) does not permit to change
> flags. Or maybe is just me who does not know how to do it?

You need to edit the option

CYGBLD_GLOBAL_CFLAGS

and add the flag to that. You should be able to do that with any
version of the config tool, or you can just edit the .ecc file with
your favour text editor.

        Andrew


--
Before posting, please read the FAQ: http://ecos.sourceware.org/fom/ecos
and search the list archive: http://ecos.sourceware.org/ml/ecos-discuss

Reply | Threaded
Open this post in threaded view
|

Re: Configuration Tool binaries

John Dallaway
In reply to this post by Michele Portolan
Hi Michele

Michele Portolan wrote:

> does anyone knows where I can found binaries for the Ecos Configuration
> Tool (windows) for a version later than 2.11? I am using eCos with Leon
> and the new version of the toolchain (rtem-4.6) requires gcc to be added
> the flag -qleon2 and the version I have now (2.11) does not permit to
> change flags. Or maybe is just me who does not know how to do it?
> Thank you very much,

Version 2.11 is very old. Version numbers were brought in-line with the
eCos repository versioning scheme prior to the eCos 2.0 release. You
will find the latest public build for Windows hosts at:

  http://www.ecoscentric.com/devzone/configtool.shtml

John Dallaway
eCosCentric Limited


--
Before posting, please read the FAQ: http://ecos.sourceware.org/fom/ecos
and search the list archive: http://ecos.sourceware.org/ml/ecos-discuss