Changing memery

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Changing memery

Augusto Salazar

Hello all,

I am stuck in the process of changing the memory size
of the redboot for my GRG board ( I though that I had
solved this but now the changes don't seems to take
place )

So, going into the code I see that even if I put
0x04000000 as the ram size in this part of the code
the value changes to 0x0200000

 if ( regionend ==
         ((cyg_uint8 *)CYGMEM_REGION_ram +
CYGMEM_REGION_ram_SIZE) ) {
         
        regionend = (cyg_uint8 *)CYGMEM_REGION_ram +
hal_dram_size;
}

Now, I am sure that I have 64 mb of RAM... before I
had the redboot to show me that but I lost that image
and that time I just made the normal changes (grg.h
and hal_*)

Any tip of why this is happening?

Thanks a lot in advance,

Augusto Salazar

AUGUSTO SALAZAR
MIEMBRO DE PIRATAS TM (COL)
CEL: +57 315 7340134.

__________________________________________________
Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around
http://mail.yahoo.com 

--
Before posting, please read the FAQ: http://ecos.sourceware.org/fom/ecos
and search the list archive: http://ecos.sourceware.org/ml/ecos-discuss

Reply | Threaded
Open this post in threaded view
|

Re: Changing memery

Augusto Salazar

Hi all,

Any idea of how to solve this problem?? to me it seems
that redboot still thinks that the real memory is
0x02000000, why is that???

I have make changes in:

grg.h
mlt_arm_xscale_grg_ram.h
mlt_arm_xscale_grg_rom.h
mlt_arm_xscale_grg_ram.ldi
mlt_arm_xscale_grg_rom.ldi
mlt_arm_xscale_grg_rom.mlt

Thanks a lot in advance,

BR

Augusto Salazar

--- Augusto Salazar <[hidden email]> wrote:

>
> Hello all,
>
> I am stuck in the process of changing the memory
> size
> of the redboot for my GRG board ( I though that I
> had
> solved this but now the changes don't seems to take
> place )
>
> So, going into the code I see that even if I put
> 0x04000000 as the ram size in this part of the code
> the value changes to 0x0200000
>
>  if ( regionend ==
>          ((cyg_uint8 *)CYGMEM_REGION_ram +
> CYGMEM_REGION_ram_SIZE) ) {
>          
>         regionend = (cyg_uint8 *)CYGMEM_REGION_ram +
> hal_dram_size;
> }
>
> Now, I am sure that I have 64 mb of RAM... before I
> had the redboot to show me that but I lost that
> image
> and that time I just made the normal changes (grg.h
> and hal_*)
>
> Any tip of why this is happening?
>
> Thanks a lot in advance,
>
> Augusto Salazar
>
> AUGUSTO SALAZAR
> MIEMBRO DE PIRATAS TM (COL)
> CEL: +57 315 7340134.
>
> __________________________________________________
> Do You Yahoo!?
> Tired of spam?  Yahoo! Mail has the best spam
> protection around
> http://mail.yahoo.com 
>
> --
> Before posting, please read the FAQ:
> http://ecos.sourceware.org/fom/ecos
> and search the list archive:
> http://ecos.sourceware.org/ml/ecos-discuss
>
>


AUGUSTO SALAZAR
MIEMBRO DE PIRATAS TM (COL)
CEL: +57 315 7340134.

__________________________________________________
Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around
http://mail.yahoo.com 

--
Before posting, please read the FAQ: http://ecos.sourceware.org/fom/ecos
and search the list archive: http://ecos.sourceware.org/ml/ecos-discuss