Can't import srfi 101

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

Can't import srfi 101

Elías Alonso G.-Cornejo
This is probably a silly question, but how can I import the srfi 101
library (random access lists)? I've tried:

(import (srfi 101))

and:

(import (gnu kawa slib ralists))

Without any luck.

Thanks!

Elias.
Reply | Threaded
Open this post in threaded view
|

Re: Can't import srfi 101

alex mitchell-3
(sorry, resending as plain text for the benefit of the list)

I think you need to do:

(require 'srfi-101)

Alex

> On 5 Jul 2015, at 4:06 pm, Elías Alonso G.-Cornejo <[hidden email]> wrote:
>
> This is probably a silly question, but how can I import the srfi 101
> library (random access lists)? I've tried:
>
> (import (srfi 101))
>
> and:
>
> (import (gnu kawa slib ralists))
>
> Without any luck.
>
> Thanks!
>
> Elias.

Reply | Threaded
Open this post in threaded view
|

Re: Can't import srfi 101

Elías Alonso G.-Cornejo
> I think you need to do:
> (require 'srfi-101)
> Alex

I've tried, but I get this error:

#|kawa:1|# (require 'srfi-101)
/dev/stdin:1:1: unknown class gnu.kawa.slib.ralists
#|kawa:2|#

Does it work for you?

2015-07-05 10:59 GMT+02:00 Alex Mitchell <[hidden email]>:

> (sorry, resending as plain text for the benefit of the list)
>
> I think you need to do:
>
> (require 'srfi-101)
>
> Alex
>
>> On 5 Jul 2015, at 4:06 pm, Elías Alonso G.-Cornejo <[hidden email]> wrote:
>>
>> This is probably a silly question, but how can I import the srfi 101
>> library (random access lists)? I've tried:
>>
>> (import (srfi 101))
>>
>> and:
>>
>> (import (gnu kawa slib ralists))
>>
>> Without any luck.
>>
>> Thanks!
>>
>> Elias.
>
Reply | Threaded
Open this post in threaded view
|

Re: Can't import srfi 101

alex mitchell-3
Yes, it does - at least I don’t get any errors. I haven’t tried using anything from srfi 101.

$ kawa
#|kawa:1|# (require 'srfi-101)
#|kawa:2|# (exit)
$ kawa --version
Kawa 2.0
Copyright (C) 2014 Per Bothner
$ java -version
java version "1.8.0_45"
Java(TM) SE Runtime Environment (build 1.8.0_45-b14)
Java HotSpot(TM) 64-Bit Server VM (build 25.45-b02, mixed mode)

Note that I’m using the precompiled kawa 2.0 rather than the latest from svn.

Alex

> On 5 Jul 2015, at 5:26 pm, Elías Alonso G.-Cornejo <[hidden email]> wrote:
>
>> I think you need to do:
>> (require 'srfi-101)
>> Alex
>
> I've tried, but I get this error:
>
> #|kawa:1|# (require 'srfi-101)
> /dev/stdin:1:1: unknown class gnu.kawa.slib.ralists
> #|kawa:2|#
>
> Does it work for you?
>
> 2015-07-05 10:59 GMT+02:00 Alex Mitchell <[hidden email]>:
>> (sorry, resending as plain text for the benefit of the list)
>>
>> I think you need to do:
>>
>> (require 'srfi-101)
>>
>> Alex
>>
>>> On 5 Jul 2015, at 4:06 pm, Elías Alonso G.-Cornejo <[hidden email]> wrote:
>>>
>>> This is probably a silly question, but how can I import the srfi 101
>>> library (random access lists)? I've tried:
>>>
>>> (import (srfi 101))
>>>
>>> and:
>>>
>>> (import (gnu kawa slib ralists))
>>>
>>> Without any luck.
>>>
>>> Thanks!
>>>
>>> Elias.
>>

Reply | Threaded
Open this post in threaded view
|

Re: Can't import srfi 101

Elías Alonso G.-Cornejo
I'm using a version built from svn a couple weeks ago.

$ java -jar kawa.jar --version
Kawa 2.0.1
Copyright (C) 2015 Per Bothner

$ java -version
java version "1.7.0_80"
Java(TM) SE Runtime Environment (build 1.7.0_80-b15)
Java HotSpot(TM) 64-Bit Server VM (build 24.80-b11, mixed mode)

2015-07-05 11:57 GMT+02:00 Alex Mitchell <[hidden email]>:

> Yes, it does - at least I don’t get any errors. I haven’t tried using anything from srfi 101.
>
> $ kawa
> #|kawa:1|# (require 'srfi-101)
> #|kawa:2|# (exit)
> $ kawa --version
> Kawa 2.0
> Copyright (C) 2014 Per Bothner
> $ java -version
> java version "1.8.0_45"
> Java(TM) SE Runtime Environment (build 1.8.0_45-b14)
> Java HotSpot(TM) 64-Bit Server VM (build 25.45-b02, mixed mode)
>
> Note that I’m using the precompiled kawa 2.0 rather than the latest from svn.
>
> Alex
>
>> On 5 Jul 2015, at 5:26 pm, Elías Alonso G.-Cornejo <[hidden email]> wrote:
>>
>>> I think you need to do:
>>> (require 'srfi-101)
>>> Alex
>>
>> I've tried, but I get this error:
>>
>> #|kawa:1|# (require 'srfi-101)
>> /dev/stdin:1:1: unknown class gnu.kawa.slib.ralists
>> #|kawa:2|#
>>
>> Does it work for you?
>>
>> 2015-07-05 10:59 GMT+02:00 Alex Mitchell <[hidden email]>:
>>> (sorry, resending as plain text for the benefit of the list)
>>>
>>> I think you need to do:
>>>
>>> (require 'srfi-101)
>>>
>>> Alex
>>>
>>>> On 5 Jul 2015, at 4:06 pm, Elías Alonso G.-Cornejo <[hidden email]> wrote:
>>>>
>>>> This is probably a silly question, but how can I import the srfi 101
>>>> library (random access lists)? I've tried:
>>>>
>>>> (import (srfi 101))
>>>>
>>>> and:
>>>>
>>>> (import (gnu kawa slib ralists))
>>>>
>>>> Without any luck.
>>>>
>>>> Thanks!
>>>>
>>>> Elias.
>>>
>
Reply | Threaded
Open this post in threaded view
|

Re: Can't import srfi 101

Andrea Bernardini
I'm using latest version from svn, it works for me.

I would try:

svn update
make clean
make

Andrea

On Sun, 5 Jul 2015 12:12:31 +0200
Elías Alonso G.-Cornejo <[hidden email]> wrote:

> I'm using a version built from svn a couple weeks ago.
>
> $ java -jar kawa.jar --version
> Kawa 2.0.1
> Copyright (C) 2015 Per Bothner
>
> $ java -version
> java version "1.7.0_80"
> Java(TM) SE Runtime Environment (build 1.7.0_80-b15)
> Java HotSpot(TM) 64-Bit Server VM (build 24.80-b11, mixed mode)


Reply | Threaded
Open this post in threaded view
|

Re: Can't import srfi 101

Elías Alonso G.-Cornejo
Updating the svn repo fixed the issue.

Thanks!
Elias.

2015-07-05 14:17 GMT+02:00 Andrea Bernardini <[hidden email]>:

> I'm using latest version from svn, it works for me.
>
> I would try:
>
> svn update
> make clean
> make
>
> Andrea
>
> On Sun, 5 Jul 2015 12:12:31 +0200
> Elías Alonso G.-Cornejo <[hidden email]> wrote:
>
>> I'm using a version built from svn a couple weeks ago.
>>
>> $ java -jar kawa.jar --version
>> Kawa 2.0.1
>> Copyright (C) 2015 Per Bothner
>>
>> $ java -version
>> java version "1.7.0_80"
>> Java(TM) SE Runtime Environment (build 1.7.0_80-b15)
>> Java HotSpot(TM) 64-Bit Server VM (build 24.80-b11, mixed mode)
>
>