Build problems - no libiberty/pic

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Build problems - no libiberty/pic

Peter Allin
Hi,

I've tried to build the three SID snapshots currently found on
sources.redhat.com and the latest from CVS.

In all four cases I got the following error:

/bin/sh ./libtool --tag=CXX --mode=link c++ -g -O2     -o libcgencpu.la
-rpath /home/pal/local/arm-tools//lib/sidcomp -module -no-undefined
compCGEN.lo cgen-fpu.lo fp.lo tracedis.lo arm7t/libarm7t.la
m32r/libm32r.la mt/libmt.la xstormy16/libxstormy16.la  
-L../../../libiberty/pic -liberty cgen-asm.lo cgen-dis.lo cgen-opc.lo
dis-buf.lo dis-init.lo -lpthread -lm
./libtool: line 1803: cd: ../../../libiberty/pic: No such file or directory
libtool: link: cannot determine absolute directory name of
`../../../libiberty/pic'
make[7]: *** [libcgencpu.la] Error 1

Any hints on how to get past this woul be greatly appreciated.

Best regards,
 Peter Allin

Reply | Threaded
Open this post in threaded view
|

Re: Build problems - no libiberty/pic

Frank Ch. Eigler

Peter Allin <[hidden email]> writes:

> I've tried to build the three SID snapshots currently found on
> sources.redhat.com and the latest from CVS. [...]

This was a consequence of an earlier partially accepted contribution.
I checked in some code that works/hacks around the situation.  Please
try it out.

- FChE
Reply | Threaded
Open this post in threaded view
|

Re: Build problems - no libiberty/pic

Peter Allin

>This was a consequence of an earlier partially accepted contribution.
>I checked in some code that works/hacks around the situation.  Please
>try it out.
>
>  
>
Yes - that did it. It compiles fine now. I'm looking forward to
experimenting with it.

Thanks a lot,
 Peter Allin