[Bug python/23830] New: use the stable python 3 ABI

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[Bug python/23830] New: use the stable python 3 ABI

albert.aribaud at 3adev dot fr
https://sourceware.org/bugzilla/show_bug.cgi?id=23830

            Bug ID: 23830
           Summary: use the stable python 3 ABI
           Product: gdb
           Version: HEAD
            Status: NEW
          Severity: normal
          Priority: P2
         Component: python
          Assignee: unassigned at sourceware dot org
          Reporter: tromey at sourceware dot org
  Target Milestone: ---

Perhaps gdb could use the Python 3 stable ABI:

https://docs.python.org/3/c-api/stable.html

This would make it possible to compile gdb against one version
of Python 3 but then have it use any version of Python 3 that
is found on the user's machine -- that is, it would help in
situations where one wants to copy the gdb executable
somewhere else.

--
You are receiving this mail because:
You are on the CC list for the bug.