[Bug build/26217] New: Build of glibc 2.11.1 configure fails make too old but is GNU make 4.2.1

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

[Bug build/26217] New: Build of glibc 2.11.1 configure fails make too old but is GNU make 4.2.1

Sourceware - glibc-bugs mailing list
https://sourceware.org/bugzilla/show_bug.cgi?id=26217

            Bug ID: 26217
           Summary: Build of glibc 2.11.1 configure fails make too old but
                    is GNU make 4.2.1
           Product: glibc
           Version: unspecified
            Status: UNCONFIRMED
          Severity: normal
          Priority: P2
         Component: build
          Assignee: unassigned at sourceware dot org
          Reporter: rh100605 at aol dot com
                CC: carlos at redhat dot com
  Target Milestone: ---

Configure for glibc-2.11.1 halts reporting make as version 3.79 or lower but it
is version 4.2.1 which should be ok.

pi@raspberrypi:~/Downloads/glibc-build $ sudo ../glibc-2.11.1/configure
--prefix=/opt/glibc/2.11.1 --enable-kernel=2.6.36
--enable-add-ons=../glibc-ports-bba331b
checking build system type... armv7l-unknown-linux-gnueabihf
checking host system type... armv7l-unknown-linux-gnueabihf
checking for gcc... gcc
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking how to run the C preprocessor... gcc -E
checking for g++... g++
checking whether we are using the GNU C++ compiler... yes
checking whether g++ accepts -g... yes
checking add-on ../glibc-ports-bba331b for preconfigure fragments... alpha am33
arm hppa m68k mips
checking sysdep dirs... ../glibc-ports-bba331b/sysdeps/arm/elf
../glibc-ports-bba331b/sysdeps/unix/sysv/linux/arm
../glibc-ports-bba331b/sysdeps/unix/sysv/linux sysdeps/unix/sysv/linux
sysdeps/gnu sysdeps/unix/common sysdeps/unix/mman sysdeps/unix/inet
../glibc-ports-bba331b/sysdeps/unix/sysv sysdeps/unix/sysv
../glibc-ports-bba331b/sysdeps/unix/arm ../glibc-ports-bba331b/sysdeps/unix
sysdeps/unix sysdeps/posix ../glibc-ports-bba331b/sysdeps/arm/fpu
../glibc-ports-bba331b/sysdeps/arm sysdeps/wordsize-32 sysdeps/ieee754/flt-32
sysdeps/ieee754/dbl-64 sysdeps/ieee754 sysdeps/generic/elf sysdeps/generic
checking for a BSD-compatible install... /usr/bin/install -c
checking whether ln -s works... yes
checking for ranlib... ranlib
checking whether as is GNU as... yes
checking whether ld is GNU ld... yes
checking for as... as
checking version of as... 2.31.1, ok
checking for ld... ld
checking version of ld... 2.31.1, ok
checking for pwd... /bin/pwd
checking for gcc... gcc
checking version of gcc... 8.3.0, bad
checking for gnumake... no
checking for gmake... no
checking for make... make
checking version of make... 4.2.1, bad
checking for gnumsgfmt... no
checking for gmsgfmt... no
checking for msgfmt... no
checking for makeinfo... no
checking for sed... sed
checking version of sed... v. ?.??, bad
checking for autoconf... no
configure: error:
*** These critical programs are missing or too old: gcc make
*** Check the INSTALL file for required versions.

The INSTALL file says:-
We recommend installing the following GNU tools before attempting to
build the GNU C library:

   * GNU `make' 3.79 or newer

     You need the latest version of GNU `make'.  Modifying the GNU C
     Library to work with other `make' programs would be so difficult


pi@raspberrypi:~/Downloads/glibc-build $ make -v
GNU Make 4.2.1
Built for arm-unknown-linux-gnueabihf
Copyright (C) 1988-2016 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.

/********************************************************/

The "sed"  version which is reported as ????? is also in error
pi@raspberrypi:~/Downloads/glibc-build $ sed --version

sed (GNU sed) 4.7
Packaged by Debian
Copyright (C) 2018 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <https://gnu.org/licenses/gpl.html>.
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.

Written by Jay Fenlason, Tom Lord, Ken Pizzini,
Paolo Bonzini, Jim Meyering, and Assaf Gordon.
GNU sed home page: <https://www.gnu.org/software/sed/>.
General help using GNU software: <https://www.gnu.org/gethelp/>.
E-mail bug reports to: <[hidden email]>.

--
You are receiving this mail because:
You are on the CC list for the bug.
Reply | Threaded
Open this post in threaded view
|

[Bug build/26217] Build of glibc 2.11.1 configure fails make too old but is GNU make 4.2.1

Sourceware - glibc-bugs mailing list
https://sourceware.org/bugzilla/show_bug.cgi?id=26217

Andreas Schwab <[hidden email]> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|UNCONFIRMED                 |RESOLVED
         Resolution|---                         |WONTFIX

--- Comment #1 from Andreas Schwab <[hidden email]> ---
The 2.11 branch is no longer maintained.  You can find the solution in commit
28d708c44b.

--
You are receiving this mail because:
You are on the CC list for the bug.