Autoconf catch 22

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Autoconf catch 22

John Darrington-4
Something is rotten in the way autoconf has been configured in binutils.

I needed to bootstrap, so I run:

$ autoreconf

and I get:

 configure.ac:25: error: Please use exactly Autoconf 2.64 instead of 2.69.

Fine.  I use 2.64 as instructed:

$ autoreconf2.64

and get:

 configure.ac:35: error: Autoconf version 2.65 or higher is required

This is a contradiction !!!!!


--
Avoid eavesdropping.  Send strong encrypted email.
PGP Public key ID: 1024D/2DE827B3
fingerprint = 8797 A26D 0854 2EAB 0285  A290 8A67 719C 2DE8 27B3
See http://sks-keyservers.net or any PGP keyserver for public key.


signature.asc (188 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Autoconf catch 22

Andreas Schwab-2
On Jan 12 2018, John Darrington <[hidden email]> wrote:

> $ autoreconf2.64
>
> and get:
>
>  configure.ac:35: error: Autoconf version 2.65 or higher is required

You also need to use the correct version of automake.

Andreas.

--
Andreas Schwab, [hidden email]
GPG Key fingerprint = 58CA 54C7 6D53 942B 1756  01D3 44D5 214B 8276 4ED5
"And now for something completely different."
Reply | Threaded
Open this post in threaded view
|

Re: Autoconf catch 22

Maciej W. Rozycki-2
In reply to this post by John Darrington-4
On Fri, 12 Jan 2018, John Darrington wrote:

> Fine.  I use 2.64 as instructed:
>
> $ autoreconf2.64
>
> and get:
>
>  configure.ac:35: error: Autoconf version 2.65 or higher is required
>
> This is a contradiction !!!!!

 Please make sure you use the exact versions of autotools originally used
(unless you are prepared to hack things yourself).  This is autoconf 2.64
and automake 1.11.6, as determined by numbers reported at the beginning of
the respective generated files.  E.g.:

$ head bfd/Makefile.in bfd/configure

will tell you that.  You may have to set the AUTOCONF, AUTOHEADER and
AUTOM4TE environment variables to point to the right version of the
corresponding scripts to make things work.  The requirement for autoconf
>= 2.65 comes from a newer version of automake.

 HTH,

  Maciej